summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-20 17:03:45 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-20 17:03:45 +0000
commitbd4582b5a835beacc3e317a9dc5e5a6fb2d76697 (patch)
tree356517229e0cae93f242c97da69b9848726ca665 /net-libs
parentUse UID 0 instead of root to assign permissions to super user, bug #315807. (diff)
downloadgentoo-2-bd4582b5a835beacc3e317a9dc5e5a6fb2d76697.tar.gz
gentoo-2-bd4582b5a835beacc3e317a9dc5e5a6fb2d76697.tar.bz2
gentoo-2-bd4582b5a835beacc3e317a9dc5e5a6fb2d76697.zip
Version bump.
(Portage version: 2.1.11.52/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ccrtp/ChangeLog8
-rw-r--r--net-libs/ccrtp/ccrtp-2.0.5.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/net-libs/ccrtp/ChangeLog b/net-libs/ccrtp/ChangeLog
index a0a16ce7c581..654a2e1ea91a 100644
--- a/net-libs/ccrtp/ChangeLog
+++ b/net-libs/ccrtp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/ccrtp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ChangeLog,v 1.25 2013/02/13 10:57:26 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ChangeLog,v 1.26 2013/03/20 17:03:45 chithanh Exp $
+
+*ccrtp-2.0.5 (20 Mar 2013)
+
+ 20 Mar 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +ccrtp-2.0.5.ebuild:
+ Version bump.
13 Feb 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+files/ccrtp-1.7.0-cstddef.patch, ccrtp-1.7.0.ebuild:
diff --git a/net-libs/ccrtp/ccrtp-2.0.5.ebuild b/net-libs/ccrtp/ccrtp-2.0.5.ebuild
new file mode 100644
index 000000000000..9b790e9e9382
--- /dev/null
+++ b/net-libs/ccrtp/ccrtp-2.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ccrtp/ccrtp-2.0.5.ebuild,v 1.1 2013/03/20 17:03:45 chithanh Exp $
+
+EAPI=4
+inherit eutils multilib
+
+DESCRIPTION="GNU ccRTP is an implementation of RTP, the real-time transport protocol from the IETF"
+HOMEPAGE="http://www.gnu.org/software/ccrtp/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+IUSE="doc"
+SLOT="0"
+
+RDEPEND=">=dev-cpp/commoncpp2-1.3.0
+ dev-libs/libgcrypt
+ >=dev-libs/ucommon-5.0.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use doc && dohtml -r doc/html/*
+}
+
+pkg_postinst() {
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.5.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.5.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.6.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.6.so.0"
+ fi
+}