summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-09 06:20:15 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-09 06:20:15 +0000
commitf57f486f7e3b17ed253b3333b08c2c47ae78f265 (patch)
tree6da8c28b5aafbb7d6e936e53a23a71843d64e167 /net-libs
parentppc stable (bug 400359) (diff)
downloadgentoo-2-f57f486f7e3b17ed253b3333b08c2c47ae78f265.tar.gz
gentoo-2-f57f486f7e3b17ed253b3333b08c2c47ae78f265.tar.bz2
gentoo-2-f57f486f7e3b17ed253b3333b08c2c47ae78f265.zip
net-libs/xrootd: Cleaned old, add missing eclass
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xrootd/ChangeLog6
-rw-r--r--net-libs/xrootd/metadata.xml10
-rw-r--r--net-libs/xrootd/xrootd-3.1.0.ebuild93
-rw-r--r--net-libs/xrootd/xrootd-3.1.1.ebuild93
-rw-r--r--net-libs/xrootd/xrootd-3.2.1.ebuild4
5 files changed, 12 insertions, 194 deletions
diff --git a/net-libs/xrootd/ChangeLog b/net-libs/xrootd/ChangeLog
index 5630acbf776c..24241ee445b4 100644
--- a/net-libs/xrootd/ChangeLog
+++ b/net-libs/xrootd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/xrootd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/ChangeLog,v 1.5 2012/07/08 22:43:31 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/ChangeLog,v 1.6 2012/07/09 06:20:15 jlec Exp $
+
+ 09 Jul 2012; Justin Lecher <jlec@gentoo.org> -xrootd-3.1.0.ebuild,
+ -xrootd-3.1.1.ebuild, xrootd-3.2.1.ebuild, metadata.xml:
+ Cleaned old, add missing eclass
08 Jul 2012; Jeff Horelick <jdhore@gentoo.org> xrootd-3.2.1.ebuild:
marked x86 per bug 425054
diff --git a/net-libs/xrootd/metadata.xml b/net-libs/xrootd/metadata.xml
index b629e537dcfd..9185dde4a699 100644
--- a/net-libs/xrootd/metadata.xml
+++ b/net-libs/xrootd/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-physics</herd>
-<longdescription lang="en">
+ <herd>sci-physics</herd>
+ <longdescription lang="en">
XROOTD software framework is a fully generic suite for fast, low latency and
scalable data access, which can serve natively any kind of data, organized as
a hierarchical filesystem-like namespace, based on the concept of directory.
It is usually used with <pkg>sci-physics/root</pkg> and its PROOF facilities
for cluster computing in high energy physics.
</longdescription>
-<use>
- <flag name="fuse">Enable the <pkg>sys-fs/fuse</pkg> filesystem driver</flag>
-</use>
+ <use>
+ <flag name="fuse">Enable the <pkg>sys-fs/fuse</pkg> filesystem driver</flag>
+ </use>
</pkgmetadata>
diff --git a/net-libs/xrootd/xrootd-3.1.0.ebuild b/net-libs/xrootd/xrootd-3.1.0.ebuild
deleted file mode 100644
index f8f1fedd460d..000000000000
--- a/net-libs/xrootd/xrootd-3.1.0.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/xrootd-3.1.0.ebuild,v 1.1 2011/12/19 19:36:35 bicatali Exp $
-
-EAPI=4
-
-inherit cmake-utils eutils
-
-DURI="http://xrootd.slac.stanford.edu/doc/prod"
-
-DESCRIPTION="Extended ROOT remote file server"
-HOMEPAGE="http://xrootd.org/"
-SRC_URI="${HOMEPAGE}/download/v${PV}/${P}.tar.gz
- doc? (
- ${DURI}/Syntax_config.pdf
- ${DURI}/xrd_config.pdf
- ${DURI}/ofs_config.pdf
- ${DURI}/cms_config.pdf
- ${DURI}/sec_config.pdf
- ${DURI}/xrd_monitoring.pdf
- ${DURI}/frm_config.pdf
- ${DURI}/XRdv297.pdf
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc fuse kerberos perl readline ssl"
-
-RDEPEND="!<sci-physics/root-5.32[xrootd]
- sys-libs/zlib
- fuse? ( sys-fs/fuse )
- kerberos? ( virtual/krb5 )
- perl? (
- dev-lang/perl
- readline? ( dev-perl/Term-ReadLine-Perl )
- )
- readline? ( sys-libs/readline )
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}
- perl? ( dev-lang/swig )"
-
-pkg_setup() {
- enewgroup xrootd
- enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
-}
-
-src_configure() {
-# "-DCMAKE_BUILD_TYPE=Release"
- mycmakeargs=(
- $(cmake-utils_use_enable fuse)
- $(cmake-utils_use_enable kerberos KRB5)
- $(cmake-utils_use_enable perl)
- $(cmake-utils_use_enable readline)
- $(cmake-utils_use_enable ssl CRYPTO)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- # base configs
- insinto /etc/xrootd
- doins packaging/common/*.cfg
-
- # create aux dirs and correct permissions so that xrootd
- # will be happy as a non-priviledged user
- fowners root:xrootd "${EPREFIX}"/etc/xrootd
- keepdir "${EPREFIX}"/var/log/xrootd
- keepdir "${EPREFIX}"/var/run/xrootd
- keepdir "${EPREFIX}"/var/spool/xrootd
- fowners xrootd:xrootd "${EPREFIX}"/var/{log,run,spool}/xrootd
-
- local i
- for i in cmsd frm_purged frm_xfrd xrootd; do
- newinitd "${FILESDIR}"/${i}.initd ${i}
- done
- # all daemons MUST use single master config file
- newconfd "${FILESDIR}"/xrootd.confd xrootd
-
- dodoc docs/ReleaseNotes.txt
- use doc && \
- dodoc \
- "${DISTDIR}"/Syntax_config.pdf \
- "${DISTDIR}"/xrd_config.pdf \
- "${DISTDIR}"/ofs_config.pdf \
- "${DISTDIR}"/cms_config.pdf \
- "${DISTDIR}"/sec_config.pdf \
- "${DISTDIR}"/xrd_monitoring.pdf \
- "${DISTDIR}"/frm_config.pdf \
- "${DISTDIR}"/XRdv297.pdf
-}
diff --git a/net-libs/xrootd/xrootd-3.1.1.ebuild b/net-libs/xrootd/xrootd-3.1.1.ebuild
deleted file mode 100644
index 8f3d61b943a6..000000000000
--- a/net-libs/xrootd/xrootd-3.1.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/xrootd-3.1.1.ebuild,v 1.1 2012/03/06 17:04:22 bicatali Exp $
-
-EAPI=4
-
-inherit cmake-utils eutils
-
-DURI="http://xrootd.slac.stanford.edu/doc/prod"
-
-DESCRIPTION="Extended ROOT remote file server"
-HOMEPAGE="http://xrootd.org/"
-SRC_URI="${HOMEPAGE}/download/v${PV}/${P}.tar.gz
- doc? (
- ${DURI}/Syntax_config.pdf
- ${DURI}/xrd_config.pdf
- ${DURI}/ofs_config.pdf
- ${DURI}/cms_config.pdf
- ${DURI}/sec_config.pdf
- ${DURI}/xrd_monitoring.pdf
- ${DURI}/frm_config.pdf
- ${DURI}/XRdv297.pdf
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc fuse kerberos perl readline ssl"
-
-RDEPEND="!<sci-physics/root-5.32[xrootd]
- sys-libs/zlib
- fuse? ( sys-fs/fuse )
- kerberos? ( virtual/krb5 )
- perl? (
- dev-lang/perl
- readline? ( dev-perl/Term-ReadLine-Perl )
- )
- readline? ( sys-libs/readline )
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}
- perl? ( dev-lang/swig )"
-
-pkg_setup() {
- enewgroup xrootd
- enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
-}
-
-src_configure() {
-# "-DCMAKE_BUILD_TYPE=Release"
- mycmakeargs=(
- $(cmake-utils_use_enable fuse)
- $(cmake-utils_use_enable kerberos KRB5)
- $(cmake-utils_use_enable perl)
- $(cmake-utils_use_enable readline)
- $(cmake-utils_use_enable ssl CRYPTO)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- # base configs
- insinto /etc/xrootd
- doins packaging/common/*.cfg
-
- # create aux dirs and correct permissions so that xrootd
- # will be happy as a non-priviledged user
- fowners root:xrootd "${EPREFIX}"/etc/xrootd
- keepdir "${EPREFIX}"/var/log/xrootd
- keepdir "${EPREFIX}"/var/run/xrootd
- keepdir "${EPREFIX}"/var/spool/xrootd
- fowners xrootd:xrootd "${EPREFIX}"/var/{log,run,spool}/xrootd
-
- local i
- for i in cmsd frm_purged frm_xfrd xrootd; do
- newinitd "${FILESDIR}"/${i}.initd ${i}
- done
- # all daemons MUST use single master config file
- newconfd "${FILESDIR}"/xrootd.confd xrootd
-
- dodoc docs/ReleaseNotes.txt
- use doc && \
- dodoc \
- "${DISTDIR}"/Syntax_config.pdf \
- "${DISTDIR}"/xrd_config.pdf \
- "${DISTDIR}"/ofs_config.pdf \
- "${DISTDIR}"/cms_config.pdf \
- "${DISTDIR}"/sec_config.pdf \
- "${DISTDIR}"/xrd_monitoring.pdf \
- "${DISTDIR}"/frm_config.pdf \
- "${DISTDIR}"/XRdv297.pdf
-}
diff --git a/net-libs/xrootd/xrootd-3.2.1.ebuild b/net-libs/xrootd/xrootd-3.2.1.ebuild
index d43b18ff653d..ce2a7588a90c 100644
--- a/net-libs/xrootd/xrootd-3.2.1.ebuild
+++ b/net-libs/xrootd/xrootd-3.2.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/xrootd-3.2.1.ebuild,v 1.3 2012/07/08 22:43:31 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/xrootd-3.2.1.ebuild,v 1.4 2012/07/09 06:20:15 jlec Exp $
EAPI=4
-inherit cmake-utils eutils
+inherit cmake-utils eutils user
DURI="http://xrootd.slac.stanford.edu/doc/prod"