summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-06 03:02:18 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-08-06 03:02:18 +0000
commitfab7a9b6d5c939f2d60fdfba4826675f91da5da2 (patch)
tree7692df1916341a02378752b0d9ca5a6853b5b2fd /net-libs
parentfixed multilib-strict QA violation (diff)
downloadgentoo-2-fab7a9b6d5c939f2d60fdfba4826675f91da5da2.tar.gz
gentoo-2-fab7a9b6d5c939f2d60fdfba4826675f91da5da2.tar.bz2
gentoo-2-fab7a9b6d5c939f2d60fdfba4826675f91da5da2.zip
EAPI bumped to 4 and included prefix patches
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libwww/ChangeLog7
-rw-r--r--net-libs/libwww/libwww-5.4.0-r8.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-libs/libwww/ChangeLog b/net-libs/libwww/ChangeLog
index ce6ff6b82f86..d2e34323707e 100644
--- a/net-libs/libwww/ChangeLog
+++ b/net-libs/libwww/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libwww
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/ChangeLog,v 1.82 2012/05/05 02:54:28 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/ChangeLog,v 1.83 2012/08/06 03:02:18 ottxor Exp $
+
+*libwww-5.4.0-r8 (06 Aug 2012)
+
+ 06 Aug 2012; Christoph Junghans <ottxor@gentoo.org> +libwww-5.4.0-r8.ebuild:
+ EAPI bumped to 4 and included prefix patches
05 May 2012; Jeff Horelick <jdhore@gentoo.org> libwww-5.4.0-r7.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/net-libs/libwww/libwww-5.4.0-r8.ebuild b/net-libs/libwww/libwww-5.4.0-r8.ebuild
new file mode 100644
index 000000000000..ffc936fc95b8
--- /dev/null
+++ b/net-libs/libwww/libwww-5.4.0-r8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.4.0-r8.ebuild,v 1.1 2012/08/06 03:02:18 ottxor Exp $
+
+EAPI=4
+
+inherit eutils multilib autotools
+
+PATCHVER="1.3"
+MY_P=w3c-${P}
+
+DESCRIPTION="A general-purpose client side WEB API"
+HOMEPAGE="http://www.w3.org/Library/"
+SRC_URI="http://www.w3.org/Library/Distribution/${MY_P}.tgz
+ mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="mysql ssl"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ mysql? ( virtual/mysql )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm -f configure.in
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
+ eautoreconf
+}
+
+src_configure() {
+ if use mysql; then
+ myconf="--with-mysql=${EPREFIX}/usr/$(get_libdir)/mysql/libmysqlclient.a"
+ else
+ myconf="--without-mysql"
+ fi
+
+ export ac_cv_header_appkit_appkit_h=no
+ econf \
+ --enable-shared \
+ --enable-static \
+ --with-zlib \
+ --with-md5 \
+ --with-expat \
+ $(use_with ssl) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog
+ dohtml -r .
+}