summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-12-13 01:36:29 +0000
committerMarinus Schraal <foser@gentoo.org>2002-12-13 01:36:29 +0000
commit56f90a4819b1c5135af73b6901653caa11fce492 (patch)
tree72fd61d070e7c1bcea606c7f206c2dd6b5b52557 /net-mail/balsa
parentprocps is like a really busy package and stuff ) (diff)
downloadgentoo-2-56f90a4819b1c5135af73b6901653caa11fce492.tar.gz
gentoo-2-56f90a4819b1c5135af73b6901653caa11fce492.tar.bz2
gentoo-2-56f90a4819b1c5135af73b6901653caa11fce492.zip
New version
Diffstat (limited to 'net-mail/balsa')
-rw-r--r--net-mail/balsa/ChangeLog9
-rw-r--r--net-mail/balsa/balsa-2.0.3.ebuild94
-rw-r--r--net-mail/balsa/files/balsa-2.0.3-aspell-configure.patch22
-rw-r--r--net-mail/balsa/files/digest-balsa-2.0.31
4 files changed, 124 insertions, 2 deletions
diff --git a/net-mail/balsa/ChangeLog b/net-mail/balsa/ChangeLog
index dfa1d16e1f8a..09ffb7bd7a71 100644
--- a/net-mail/balsa/ChangeLog
+++ b/net-mail/balsa/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for net-mail/balsa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.23 2002/12/09 04:33:13 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.24 2002/12/13 01:36:29 foser Exp $
-\* Autoupdate keywords (12-6-02)
+*balsa-2.0.3 (11 Dec 2002)
+
+ 11 Dec 2002; foser <foser@gentoo.org> balsa-2.0.3.ebuild :
+ New version with input from Edy <edybsd@yahoo.com.ar> (LDAP) and Evan Read <eread@freeshell.org> (aspell/general) (bug #9931)
+
+* Autoupdate keywords (12-6-02)
06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
*balsa-1.4.0-r1 (03 Sep 2002)
diff --git a/net-mail/balsa/balsa-2.0.3.ebuild b/net-mail/balsa/balsa-2.0.3.ebuild
new file mode 100644
index 000000000000..53cc72cc8f58
--- /dev/null
+++ b/net-mail/balsa/balsa-2.0.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.3.ebuild,v 1.1 2002/12/13 01:36:29 foser Exp $
+
+inherit debug gnome2 eutils
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Balsa: Technical Preview email client for GNOME"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+HOMEPAGE="http://balsa.gnome.org"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~sparc64"
+
+RDEPEND="net-mail/mailbase
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=net-libs/libesmtp-0.8.11
+ >=app-text/aspell-0.50
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ =gnome-base/libgnomeprint-1*
+ =gnome-base/libgnomeprintui-1*
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ gtkhtml? ( >=gnome-extra/libgtkhtml-2 )
+ ldap? ( net-nds/openldap )"
+
+DEPEND="dev-util/pkgconfig
+ >=app-text/scrollkeeper-0.1.4
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ # this patch is from Riccardo Persichetti
+ # (ricpersi@libero.it) to make balsa compile
+ # <seemant@gentoo.org> this patch is updated by me to compile
+ # against the new aspell (until upstream gets its act together, aspell
+ # will be a required dep).
+ epatch ${FILESDIR}/${P}-aspell-configure.patch
+
+ # and get our patch in
+ cd ${S}
+ autoconf || die
+}
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+ use gtkhtml \
+ && myconf="${myconf} --with-gtkhtml" \
+ || myconf="${myconf} --without-gtkhtml"
+ use perl \
+ && myconf="${myconf} --enable-pcre" \
+ || myconf="${myconf} --disable-pcre"
+
+# use spell \
+# && myconf="${myconf} --with-aspell" \
+# || myconf="${myconf} --without-aspell --without-spell"
+
+# aspell is not optional atm
+ myconf="${myconf} --with-aspell"
+
+ libmutt/configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ myconf="${myconf} --enable-threads"
+
+ econf ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ local myinst
+ myinst="gnomeconfdir=${D}/etc \
+ gnomedatadir=${D}/usr/share"
+
+ einstall ${myinst} || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+ docinto docs
+ dodoc docs/*
+}
diff --git a/net-mail/balsa/files/balsa-2.0.3-aspell-configure.patch b/net-mail/balsa/files/balsa-2.0.3-aspell-configure.patch
new file mode 100644
index 000000000000..5aa6a3b4dadb
--- /dev/null
+++ b/net-mail/balsa/files/balsa-2.0.3-aspell-configure.patch
@@ -0,0 +1,22 @@
+--- balsa-2.0.3.orig/configure.in 2002-10-26 18:08:14.000000000 +0200
++++ balsa-2.0.3/configure.in 2002-10-30 01:18:02.000000000 +0100
+@@ -89,9 +89,16 @@
+ AC_CONFIG_SUBDIRS(libmutt)
+
+
+-AC_CHECK_LIB(pspell, new_pspell_manager,,[
+- AC_MSG_ERROR([*** libpspell(-devel) not found. Please check http://www.balsa.net for information on the required files.])
+-], -lstdc++ -lpspell-modules)
++AC_ARG_WITH(aspell,
++ [ --with-aspell Turn on aspell ],
++ [case "${withval}" in
++ yes) LIBS="-lstdc++ -laspell" ;
++ aspell=true ;;
++ no) LIBS="-lstdc++" ;
++ aspell=false ;;
++ *) AC_MSG_ERROR(bad value ${withval} for --with-aspell) ;;
++ esac],[LIBS=""])
++AM_CONDITIONAL(WITH_ASPELL, test, x$aspell = xtrue)
+
+ dnl Reset
+ # LDFLAGS="$balsa_save_LDFLAGS"
diff --git a/net-mail/balsa/files/digest-balsa-2.0.3 b/net-mail/balsa/files/digest-balsa-2.0.3
new file mode 100644
index 000000000000..b9f696cbdea0
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-2.0.3
@@ -0,0 +1 @@
+MD5 76a8b19117b149387d11a1580e3839b6 balsa-2.0.3.tar.bz2 2431169