summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-30 14:12:40 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-30 14:12:40 +0000
commitf08d54e6ba0bfd56fe0ec57b38e67ff2959c1037 (patch)
treef310b48858735d6b6695aa04ef47ffbd8995cf2b /net-mail/balsa
parentfix build problems if avifile and dvdread are not used (diff)
downloadgentoo-2-f08d54e6ba0bfd56fe0ec57b38e67ff2959c1037.tar.gz
gentoo-2-f08d54e6ba0bfd56fe0ec57b38e67ff2959c1037.tar.bz2
gentoo-2-f08d54e6ba0bfd56fe0ec57b38e67ff2959c1037.zip
balsa 2 for gnome2
Diffstat (limited to 'net-mail/balsa')
-rw-r--r--net-mail/balsa/ChangeLog16
-rw-r--r--net-mail/balsa/balsa-2.0.0_pre1.ebuild70
-rw-r--r--net-mail/balsa/files/balsa-2.0.0-gentoo.patch12
-rw-r--r--net-mail/balsa/files/digest-balsa-2.0.0_pre11
4 files changed, 97 insertions, 2 deletions
diff --git a/net-mail/balsa/ChangeLog b/net-mail/balsa/ChangeLog
index c8db938f8246..3528f2b983c8 100644
--- a/net-mail/balsa/ChangeLog
+++ b/net-mail/balsa/ChangeLog
@@ -1,9 +1,21 @@
# ChangeLog for net-mail/balsa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.10 2002/05/28 10:57:43 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.11 2002/05/30 14:12:40 spider Exp $
-*balsa-1.3.6-r1 (28 May 2002)
+*balsa-2.0.0_pre1 (30May 2002)
+ 30 May 2002; Spider <spider@gentoo.org> balsa-2.0.0_pre1.ebuild :
+ Adding the Gnome2 branch
+ updated the patch to apply
+ please note that this is a "technical preview" thats why I added the
+ _pre1 and the date tag inside the ebuild, when balsa updates the
+ package we can modify the date and upp the pre until the final version
+ is released.
+
+ Btw.. do balsa -ever- release a "stable" product? I sense debianism
+ here.
+
+*balsa-1.3.6-r1 (28 May 2002)
28 May 2002; Seemant Kulleen <seemant@gentoo.org> balsa-1.3.6-r1.ebuild
files/balsa-1.3.6-gentoo.patch files/digest-balsa-1.3.6-r1 :
diff --git a/net-mail/balsa/balsa-2.0.0_pre1.ebuild b/net-mail/balsa/balsa-2.0.0_pre1.ebuild
new file mode 100644
index 000000000000..842a919146ba
--- /dev/null
+++ b/net-mail/balsa/balsa-2.0.0_pre1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-2.0.0_pre1.ebuild,v 1.1 2002/05/30 14:12:40 spider Exp $
+
+MY_V="2.0.0"
+MY_P="${PN}-${MY_V}"
+DATE="2002.04.24" # Get this from the download page
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Balsa: Technical Preview email client for GNOME"
+SRC_URI="http://balsa.gnome.org/${MY_P}.tar.bz2"
+HOMEPAGE="http://balsa.gnome.org"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND="=dev-libs/glib-2.0*
+ =x11-libs/gtk+-2.0*
+ >=net-libs/libesmtp-0.8.11
+ app-text/scrollkeeper
+ >=gnome-base/libgnome-1.117.2
+ >=gnome-base/libgnomeui-1.117.2
+ >=gnome-base/gnome-vfs-1.9.16
+ >=gnome-extra/libgnomeprint-1.114.0
+ >=gnome-extra/libgnomeprintui-1.114.0
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ gtkhtml? ( >=gnome-extra/libgtkhtml-1.99.8 )"
+
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ # this patch is from Riccardo Persichetti
+ # (ricpersi@libero.it) to make balsa compile
+ patch -p0 < ${FILESDIR}/${MY_P}-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl && myconf="${myconf} --with-ssl"
+ use gtkhtml && myconf="${myconf} --with-gtkhtml"
+ use perl && myconf="${myconf} --enable-pcre"
+# use spell && myconf="${myconf} --enable-all"
+
+ libmutt/configure --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ myconf="${myconf} --enable-threads"
+
+ econf ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+
+
+src_install () {
+ local myinst
+ myinst="gnomeconfdir=${D}/etc \
+ gnomedatadir=${D}/usr/share"
+
+ einstall ${myinst} || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+ docinto docs
+ dodoc docs/*
+}
diff --git a/net-mail/balsa/files/balsa-2.0.0-gentoo.patch b/net-mail/balsa/files/balsa-2.0.0-gentoo.patch
new file mode 100644
index 000000000000..f65068c5f0c1
--- /dev/null
+++ b/net-mail/balsa/files/balsa-2.0.0-gentoo.patch
@@ -0,0 +1,12 @@
+--- balsa-2.0.0-orig/configure Mon Mar 25 00:34:33 2002
++++ balsa-2.0.0/configure Tue Apr 23 02:15:35 2002
+@@ -6629,7 +6629,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpspell $LIBS"
++ LIBS="-lpspell -lstdc++ $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+
diff --git a/net-mail/balsa/files/digest-balsa-2.0.0_pre1 b/net-mail/balsa/files/digest-balsa-2.0.0_pre1
new file mode 100644
index 000000000000..f33d59ef8635
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-2.0.0_pre1
@@ -0,0 +1 @@
+MD5 dde603b4a12fb9232d62361775b30d71 balsa-2.0.0.tar.bz2 2089825