summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-17 02:59:51 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-17 02:59:51 +0000
commitadb67582483d81f38e08acdfa6fd5dcf516325df (patch)
tree549146db2d5338c410eb24514f70d86a8900657c /net-mail/bmf/bmf-0.9.4.ebuild
parentNew ebuild. Comment on bug #19629 if you feel like it. :) (diff)
downloadgentoo-2-adb67582483d81f38e08acdfa6fd5dcf516325df.tar.gz
gentoo-2-adb67582483d81f38e08acdfa6fd5dcf516325df.tar.bz2
gentoo-2-adb67582483d81f38e08acdfa6fd5dcf516325df.zip
New ebuild - bayesian spam filter
Diffstat (limited to 'net-mail/bmf/bmf-0.9.4.ebuild')
-rw-r--r--net-mail/bmf/bmf-0.9.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/bmf/bmf-0.9.4.ebuild b/net-mail/bmf/bmf-0.9.4.ebuild
new file mode 100644
index 000000000000..3078d83564f6
--- /dev/null
+++ b/net-mail/bmf/bmf-0.9.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/bmf/bmf-0.9.4.ebuild,v 1.1 2003/07/17 02:59:51 raker Exp $
+
+IUSE="mysql berkdb"
+
+DESCRIPTION="A fast and small Bayesian spam filter"
+HOMEPAGE="http://bmf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bmf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="mysql? ( >=mysql-3.23.56 )
+ berkdb? ( >=db-3.2.9 )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf
+
+ use mysql || myconf="--without-mysql"
+ use berkdb || myconf="${myconf} --without-libdb"
+
+ ./configure ${myconf} || die "configure failed"
+ emake
+}
+
+src_install() {
+ dodoc README AUTHORS ChangeLog
+ einstall DESTDIR=${D}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Important: Remember to train bmf before you start using it."
+ einfo "Instructions for training and using bmf with procmail: "
+ einfo "less /usr/share/doc/${P}/README.gz"
+ einfo
+}