summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-14 04:39:44 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-14 04:39:44 +0000
commit2818712daaa1c7a3f0d9714570c93794e6d44ef8 (patch)
tree913ff2803dc7eb4c64bd5323ac80edaf22819122 /net-mail/checkpassword
parentAdded java-pkg_dowar. (diff)
downloadgentoo-2-2818712daaa1c7a3f0d9714570c93794e6d44ef8.tar.gz
gentoo-2-2818712daaa1c7a3f0d9714570c93794e6d44ef8.tar.bz2
gentoo-2-2818712daaa1c7a3f0d9714570c93794e6d44ef8.zip
Fix gcc/$CC bug, make sure CFLAGS are used as well.
Diffstat (limited to 'net-mail/checkpassword')
-rw-r--r--net-mail/checkpassword/ChangeLog3
-rw-r--r--net-mail/checkpassword/Manifest4
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r1.ebuild13
3 files changed, 13 insertions, 7 deletions
diff --git a/net-mail/checkpassword/ChangeLog b/net-mail/checkpassword/ChangeLog
index cfe4129635ec..fcf8b9722903 100644
--- a/net-mail/checkpassword/ChangeLog
+++ b/net-mail/checkpassword/ChangeLog
@@ -1,11 +1,12 @@
# ChangeLog for net-mail/checkpassword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.7 2003/05/14 03:51:16 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.8 2003/05/14 04:39:41 robbat2 Exp $
*checkpassword-0.90-r1 (05 Mar 2003)
13 May 2003; Robin Johnson <robbat2@gentoo.org> checkpassword-0.90-r1.ebuild:
Fixed DESCRIPTION and HOMEPAGE, added more docs to install list.
+ Fix gcc/$CC bug, make sure CFLAGS are used as well.
16 Mar 2003; Will Woods <wwoods@gentoo.org> checkpassword-0.90-r1.ebuild:
Added alpha to KEYWORDS
diff --git a/net-mail/checkpassword/Manifest b/net-mail/checkpassword/Manifest
index cfe67fb9c2c8..476e8e7d7f50 100644
--- a/net-mail/checkpassword/Manifest
+++ b/net-mail/checkpassword/Manifest
@@ -1,4 +1,4 @@
-MD5 7e1a318fc4ceee45f1b6baa2dedd4804 checkpassword-0.90-r1.ebuild 731
-MD5 7b0105976f62acb5331ec94a1352e758 ChangeLog 1094
+MD5 582c228efa573ac5ad4f264c871ca54c checkpassword-0.90-r1.ebuild 945
+MD5 73b1034644e3abd82158c89bbf5157e3 ChangeLog 1148
MD5 894ae022f7765b23ddfce23bc2f91c3e files/digest-checkpassword-0.90-r1 69
MD5 760d73c8b3091ca1cae9a1ae5b6fab8f files/0.90-errno.patch 243
diff --git a/net-mail/checkpassword/checkpassword-0.90-r1.ebuild b/net-mail/checkpassword/checkpassword-0.90-r1.ebuild
index 4e49cd94cf99..55b69c18e83a 100644
--- a/net-mail/checkpassword/checkpassword-0.90-r1.ebuild
+++ b/net-mail/checkpassword/checkpassword-0.90-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r1.ebuild,v 1.3 2003/05/14 03:51:16 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r1.ebuild,v 1.4 2003/05/14 04:39:41 robbat2 Exp $
inherit eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://cr.yp.to/checkpwd.html"
SLOT="0"
LICENSE="as-is"
-KEYWORDS="x86 ppc sparc alpha"
+KEYWORDS="x86 ppc sparc alpha ~mips ~hppa ~arm"
src_unpack() {
unpack ${A}
@@ -19,8 +19,13 @@ src_unpack() {
}
src_compile() {
- echo "gcc ${CFLAGS}" > conf-cc
- make || die
+ # the -s is from the original build
+ LDFLAGS="${LDFLAGS} -s"
+ use pic && CFLAGS="${CFLAGS} -fPIC"
+ use static && LDFLAGS="${LDFLAGS} -static"
+ echo "${CC} ${CFLAGS}" > conf-cc
+ echo "${CC} ${LDFLAGS}" > conf-ld
+ make || die "Error in make"
}
src_install() {