summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-05 16:46:43 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-05 16:46:43 +0000
commitcd8734bedcadee1a22f3c7c9827edd5fd0c52fd0 (patch)
treeb08929ab93061df61543af5b3d40ac143df4160d /net-mail/checkpw
parentAdded an elog to let the user know we need aspell/ispell/enchant for spell ch... (diff)
downloadgentoo-2-cd8734bedcadee1a22f3c7c9827edd5fd0c52fd0.tar.gz
gentoo-2-cd8734bedcadee1a22f3c7c9827edd5fd0c52fd0.tar.bz2
gentoo-2-cd8734bedcadee1a22f3c7c9827edd5fd0c52fd0.zip
Version bumped. Fixed CFLAGS issue, bug #241042. Removed -s, bug #240920.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'net-mail/checkpw')
-rw-r--r--net-mail/checkpw/ChangeLog10
-rw-r--r--net-mail/checkpw/checkpw-1.02.ebuild61
-rw-r--r--net-mail/checkpw/files/checkpw-1.02-qa.patch16
3 files changed, 85 insertions, 2 deletions
diff --git a/net-mail/checkpw/ChangeLog b/net-mail/checkpw/ChangeLog
index f3a5cad9ac05..c7b4221b6f18 100644
--- a/net-mail/checkpw/ChangeLog
+++ b/net-mail/checkpw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/checkpw
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpw/ChangeLog,v 1.6 2007/05/08 23:09:27 genone Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpw/ChangeLog,v 1.7 2008/12/05 16:46:43 matsuu Exp $
+
+*checkpw-1.02 (05 Dec 2008)
+
+ 05 Dec 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/checkpw-1.02-qa.patch, +checkpw-1.02.ebuild:
+ Version bumped. Fixed CFLAGS issue, bug #241042. Removed -s, bug #240920.
08 May 2007; Marius Mauch <genone@gentoo.org> checkpw-1.01.ebuild:
Replacing einfo with elog
diff --git a/net-mail/checkpw/checkpw-1.02.ebuild b/net-mail/checkpw/checkpw-1.02.ebuild
new file mode 100644
index 000000000000..09e7b2e920a8
--- /dev/null
+++ b/net-mail/checkpw/checkpw-1.02.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpw/checkpw-1.02.ebuild,v 1.1 2008/12/05 16:46:43 matsuu Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="an implementation of the checkpassword interface that checks a password"
+HOMEPAGE="http://checkpw.sourceforge.net/checkpw/"
+SRC_URI="mirror://sourceforge/checkpw/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="static"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-qa.patch"
+ sed -i -e 's/head -1/head -n 1/g' Makefile auto_*.do default.do || die
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+ echo ".maildir" > conf-maildir || die
+
+ if [ -z "${QMAIL_HOME}" ]; then
+ QMAIL_HOME="/var/qmail"
+ ewarn "QMAIL_HOME is null! Using default."
+ ewarn "Create the qmail user and set the homedir to your desired location."
+ fi
+ einfo "Using ${QMAIL_HOME} as qmail's default home directory."
+ echo "${QMAIL_HOME}" > conf-qmail || die
+
+ emake || die
+}
+
+src_install() {
+ into /
+ dobin checkpw checkapoppw selectcheckpw loginlog
+ fperms 0700 /bin/checkpw /bin/checkapoppw /bin/selectcheckpw
+
+ dodoc CHANGES README
+ docinto samples
+ dodoc run-{apop,both,multidir,multipw,pop,rules}
+}
+
+pkg_postinst() {
+ elog
+ elog "How to set password:"
+ elog
+ elog " % echo 'YOURPASSWORD' > ~/.maildir/.password"
+ elog " % chmod 600 ~/.maildir/.password"
+ elog
+ elog "Replace YOURPASSWORD with your plain password."
+ elog
+}
diff --git a/net-mail/checkpw/files/checkpw-1.02-qa.patch b/net-mail/checkpw/files/checkpw-1.02-qa.patch
new file mode 100644
index 000000000000..d529ce87b9d4
--- /dev/null
+++ b/net-mail/checkpw/files/checkpw-1.02-qa.patch
@@ -0,0 +1,16 @@
+diff -Naur checkpw-1.02.orig/checkapoppw.c checkpw-1.02/checkapoppw.c
+--- checkpw-1.02.orig/checkapoppw.c 2002-01-07 16:25:10.000000000 +0900
++++ checkpw-1.02/checkapoppw.c 2008-12-06 01:14:38.000000000 +0900
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include <sys/stat.h>
+ #include "error.h"
+ #include "pathexec.h"
+diff -Naur checkpw-1.02.orig/checkpw.c checkpw-1.02/checkpw.c
+--- checkpw-1.02.orig/checkpw.c 2002-01-07 16:23:51.000000000 +0900
++++ checkpw-1.02/checkpw.c 2008-12-06 01:24:07.000000000 +0900
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include <sys/stat.h>
+ #include "error.h"
+ #include "pathexec.h"