summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-09-19 02:16:37 +0000
committerMax Kalika <max@gentoo.org>2003-09-19 02:16:37 +0000
commit7e29fc815d270b524b69cf5238267878c5259ba3 (patch)
treea08e9d228cadeb3012ff723aa2653be729823d78 /net-mail/cyrus-imapd/cyrus-imapd-2.1.14.ebuild
parentbump + close #24591. (diff)
downloadgentoo-2-7e29fc815d270b524b69cf5238267878c5259ba3.tar.gz
gentoo-2-7e29fc815d270b524b69cf5238267878c5259ba3.tar.bz2
gentoo-2-7e29fc815d270b524b69cf5238267878c5259ba3.zip
Remove --with-auth=krb. It is only used for kerberos 4 according to the docs. Only allow gssapi when USE=kerberos. Fix the db4 patch to redefine 3 extra symbols. Bump to version 2.1.15. Fix bugs 24429, 26760, and maybe 27645
Diffstat (limited to 'net-mail/cyrus-imapd/cyrus-imapd-2.1.14.ebuild')
-rw-r--r--net-mail/cyrus-imapd/cyrus-imapd-2.1.14.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-2.1.14.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-2.1.14.ebuild
index 26e3a5941d5e..9b88952bc6f5 100644
--- a/net-mail/cyrus-imapd/cyrus-imapd-2.1.14.ebuild
+++ b/net-mail/cyrus-imapd/cyrus-imapd-2.1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/cyrus-imapd-2.1.14.ebuild,v 1.4 2003/09/18 22:04:33 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/cyrus-imapd-2.1.14.ebuild,v 1.5 2003/09/19 02:16:36 max Exp $
inherit eutils
IPV6_P="${P}-ipv6-20030703"
@@ -70,17 +70,13 @@ src_compile() {
|| myconf="--without-afs"
use snmp && myconf="${myconf} --with-ucdsnmp=/usr" \
- myconf="${myconf} --without-ucdsnmp"
+ || myconf="${myconf} --without-ucdsnmp"
use ssl && myconf="${myconf} --with-openssl=/usr" \
|| myconf="${myconf} --without-openssl"
- # Kerberos IV is not working in cyrus-sasl so it's not enabled here. Only Kerberos V.
- #use kerberos && myconf="${myconf} --with-krb=/usr/athena --with-auth=krb --enable-gssapi" \
- # || myconf="${myconf} --without-krb --with-auth=unix --disable-gssapi"
-
- use kerberos && myconf="${myconf} --with-auth=krb --enable-gssapi" \
- || myconf="${myconf} --without-krb --with-auth=unix --disable-gssapi"
+ use kerberos && myconf="${myconf} --enable-gssapi" \
+ || myconf="${myconf} --disable-gssapi"
econf \
--enable-listext \
@@ -89,6 +85,7 @@ src_compile() {
--with-com_err=yes \
--without-perl \
--disable-cyradm \
+ --with-auth=unix \
--with-libwrap=/usr \
${myconf}