summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-04-30 12:11:33 +0000
committerMarinus Schraal <foser@gentoo.org>2004-04-30 12:11:33 +0000
commit25dedab8012a63de39212cf6efe0e4e286f01666 (patch)
tree99d928bae3d28589b404414a73ef74dc3bcad7d7 /net-mail/evolution
parentVerison bumped. Closes 49352 (Manifest recommit) (diff)
downloadgentoo-2-25dedab8012a63de39212cf6efe0e4e286f01666.tar.gz
gentoo-2-25dedab8012a63de39212cf6efe0e4e286f01666.tar.bz2
gentoo-2-25dedab8012a63de39212cf6efe0e4e286f01666.zip
readd gtk1 evo
Diffstat (limited to 'net-mail/evolution')
-rw-r--r--net-mail/evolution/evolution-1.2.4.ebuild237
-rw-r--r--net-mail/evolution/files/digest-evolution-1.2.416
-rw-r--r--net-mail/evolution/files/evolution-1.1.90-kde.patch23
-rw-r--r--net-mail/evolution/files/evolution-1.1.90-sharedldap.patch11
-rw-r--r--net-mail/evolution/files/evolution-1.1.90-subversion.patch11
5 files changed, 298 insertions, 0 deletions
diff --git a/net-mail/evolution/evolution-1.2.4.ebuild b/net-mail/evolution/evolution-1.2.4.ebuild
new file mode 100644
index 000000000000..4630d6b446f6
--- /dev/null
+++ b/net-mail/evolution/evolution-1.2.4.ebuild
@@ -0,0 +1,237 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.2.4.ebuild,v 1.19 2004/04/30 12:11:33 foser Exp $
+
+IUSE="ssl nls mozilla ldap doc spell pda ipv6 kerberos kde crypt"
+
+#provide Xmake and Xemake
+
+inherit eutils flag-o-matic gnome.org libtool virtualx
+
+DB3="db-3.1.17"
+S="${WORKDIR}/${P}"
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.ximian.com/pub/ximian-evolution/source/${P}.tar.gz
+ http://www.sleepycat.com/update/snapshot/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc ~sparc hppa"
+
+RDEPEND="app-text/scrollkeeper
+ >=gnome-extra/bonobo-conf-0.16
+ >=gnome-base/bonobo-1.0.21
+ >=gnome-base/gnome-common-1.2
+ =gnome-extra/gal-0.24*
+ =gnome-base/gconf-1.0*
+ >=gnome-extra/gtkhtml-1.1.10
+ >=gnome-base/oaf-0.6.10
+ >=gnome-base/ORBit-0.5.12
+ <gnome-base/libglade-2.0
+ >=media-libs/gdk-pixbuf-0.18.0
+ >=dev-libs/libxml-1.8.17
+ =gnome-base/gnome-vfs-1.0*
+ >=gnome-base/gnome-print-0.35
+ =dev-util/gob-1*
+ >=net-libs/soup-0.7.11
+ crypt? ( >=app-crypt/gnupg-1.2.2 )
+ doc? ( >=app-text/scrollkeeper-0.3.10-r1 )
+ ssl? (
+ mozilla? ( >=net-www/mozilla-0.9.9 )
+ !mozilla? ( >=dev-libs/openssl-0.9.5 ) )
+ ldap? ( >=net-nds/openldap-2.0 )
+ pda? ( =app-pda/gnome-pilot-0.1*
+ >=app-pda/pilot-link-0.11.5 )
+ spell? ( <app-text/gnome-spell-1.0 )
+ kerberos? ( app-crypt/mit-krb5 )"
+
+# the pilot-link dep is normally covered by gnome-pilot, but evo
+# requires an higher version then gnome-pilot (bug #10307)
+
+# Added dependency on "dev-util/gob" this should fix a configure bug
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4.1-r1
+ >=sys-apps/sed-4
+ doc? ( dev-util/gtk-doc )
+ nls? ( >=dev-util/intltool-0.20
+ sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S};
+ # Mandrake patches
+ epatch ${FILESDIR}/${PN}-1.1.90-kde.patch
+ epatch ${FILESDIR}/${PN}-1.1.90-subversion.patch
+ epatch ${FILESDIR}/${PN}-1.1.90-sharedldap.patch
+
+ # libtoolize to fix not all libs installing, and buggy .la files.
+ # also add the gnome-pilot.m4 to the macros directory to fix
+ # problems with the pilot conduct
+ cd ${S}; cp -f ltmain.sh ${S}/libical/
+ elibtoolize --reverse-deps
+ aclocal -I macros -I /usr/share/aclocal/gnome-macros
+ autoconf
+ automake --add-missing
+
+ (cd libical ; aclocal -I /usr/share/aclocal/gnome-macros ; autoconf)
+
+ # Fix sandbox errors
+ cd ${S}/default_user
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:-mkdir $(defaultdir:-mkdir $(DESTDIR)$(defaultdir:g' \
+ Makefile.in.orig > Makefile.in
+
+ # Remove unneeded db1 linking for nss/mozilla
+ cd ${S}; sed -i -e "s/-ldb1//" configure.in
+}
+
+src_compile() {
+
+ # *************************************************************
+ #
+ # DB3 compile...
+ #
+ # *************************************************************
+
+ # Rather ugly hack to make sure pthread mutex support are not enabled ...
+ cd ${WORKDIR}/${DB3}/dist
+# cp configure configure.orig
+# awk '!/MUTEX.*THREADS/ { sub("mut_pthread", "mut_fcntl"); print }' \
+# configure.orig > configure
+
+ einfo "Compiling DB3..."
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+
+ if [ "`egrep "^LIBS=[[:space:]]*-lpthread" Makefile`" ]
+ then
+ append-flags "-pthread"
+ fi
+
+ make || die
+ make prefix=${WORKDIR}/db3 install || die
+
+ # *************************************************************
+ #
+ # Evolution compile...
+ #
+ # *************************************************************
+
+ einfo "Compiling Evolution..."
+ cd ${S}
+
+ local myconf=""
+ local MOZILLA="${MOZILLA_FIVE_HOME}"
+
+ if [ -n "`use pda`" ] ; then
+ myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
+ else
+ myconf="${myconf} --enable-pilot-conduits=no"
+ fi
+
+ if [ -n "`use ldap`" ] ; then
+ myconf="${myconf} --with-openldap=yes --with-static-ldap=no"
+ else
+ myconf="${myconf} --with-openldap=no"
+ fi
+
+ if [ -n "`use kerberos`" ]; then
+ myconf="${myconf} --with-krb5=/usr --with-krb4=/usr"
+ else
+ myconf="${myconf} --with-krb5=no --with-krb4=no"
+ fi
+
+ # Use Mozilla NSS libs if 'mozilla' *and* 'ssl' in USE
+ if [ -n "`use ssl`" -a -n "`use mozilla`" ] ; then
+ myconf="${myconf} --enable-nss=yes \
+ --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA} \
+ --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ # Else use OpenSSL if 'mozilla' not in USE ...
+ if [ -n "`use ssl`" -a -z "`use mozilla`" ] ; then
+ myconf="${myconf} --enable-openssl=yes"
+ fi
+
+ if [ -n "`use doc`" ] ; then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6=yes"
+ else
+ myconf="${myconf} --enable-ipv6=no"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} -I/usr/include/libpisock"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-db3=${WORKDIR}/db3 \
+ --disable-python-bindings \
+ ${myconf} || die
+
+ # fix xml-i18n-merge UTF-8 problems
+ export LANG="C"
+
+ #needs to be able to connect to X display to build.
+ Xemake || Xmake || die
+}
+
+src_install() {
+ cd omf-install
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ # Install with $DESTDIR, as in some rare cases $D gets hardcoded
+ # into the binaries (seems like a ccache problem at present),
+ # because everything is recompiled with the "new" PREFIX, if
+ # $DESTDIR is _not_ used.
+ make DESTDIR=${D} \
+ prefix=/usr \
+ mandir=/usr/share/man \
+ infodir=/usr/share/info \
+ datadir=/usr/share \
+ sysconfdir=/etc \
+ localstatedir=/var/lib \
+ KDE_APPLNK_DIR=/usr/share/applnk \
+ install || die
+
+ # remove kde link if USE="-kde"
+ if [ -z "`use kde`" ]; then
+ rm -rf ${D}/usr/share/applnk
+ fi
+
+ dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
diff --git a/net-mail/evolution/files/digest-evolution-1.2.4 b/net-mail/evolution/files/digest-evolution-1.2.4
new file mode 100644
index 000000000000..b3cec260c9c4
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.2.4
@@ -0,0 +1,16 @@
+MD5 dc3bc6e2c133bb380f48f50f4918052e /files/evolution-1.0.2-conduit.patch 308
+MD5 76b7ec4d297cc9e14fd0c348c8449b75 /files/evolution-1.0.2-imapfix.diff 2838
+MD5 53050cb008a2555b215f7401772cfede /files/evolution-1.0.2-kde.patch 656
+MD5 d6c7be2ddd045fb5d487416bd09f1c1b /files/evolution-1.0.3-filter-crash.patch 1202
+MD5 1a2892e6ac519f18f30f5e2aa6508174 /files/evolution-1.0.8-mark-read-crash.patch 2018
+MD5 ecec58337e9c9f9ffb1013c4860fd33c /files/evolution-1.0.8-scrollkeeper.patch 1492
+MD5 c837abd50d990dea46fcea32b8a1b001 /files/evolution-1.1.90-kde.patch 689
+MD5 d2dcad91e6ec97286468eb7d13ceac9b /files/evolution-1.1.90-scrollkeeper.patch 1365
+MD5 8909b7f2d3483d55036f21ca2780e4a3 /files/evolution-1.1.90-sharedldap.patch 370
+MD5 f44bc5e363c1f976a7a72676886b9d13 /files/evolution-1.1.90-subversion.patch 470
+MD5 63d02821e6de8e0129d954d406dc77ae /files/evolution-1.1.90-utf8.patch 726
+MD5 2526fb78fe27dc17b78566860285bff1 /files/evolution-1.2.0-settingscrash.patch 625
+MD5 980771bb5349699c8d8ecd6b6f035b50 /files/gnome-pilot.m4 6452
+MD5 eb3c88124e9daf30ee0f70e4e10ea53d /evolution-1.2.4.ebuild 6239
+MD5 2c525e0d0e570c96e4fb1fd95e46354c evolution-1.2.4.tar.gz 16673251
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117
diff --git a/net-mail/evolution/files/evolution-1.1.90-kde.patch b/net-mail/evolution/files/evolution-1.1.90-kde.patch
new file mode 100644
index 000000000000..af178f1210f5
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.1.90-kde.patch
@@ -0,0 +1,23 @@
+--- evolution-1.1.90/configure.in.kde 2002-11-07 13:07:41.000000000 +0100
++++ evolution-1.1.90/configure.in 2002-11-07 13:12:12.000000000 +0100
+@@ -1196,18 +1196,8 @@
+ if test -z "$with_kde_applnk_path"; then
+ with_kde_applnk_path="$prefix/share/applnk"
+ fi
+- if test -d "$with_kde_applnk_path" ; then
+- AC_DEFINE(HAVE_KDE_APPLNK)
+- KDE_APPLNK_DIR="$with_kde_applnk_path"
+- else
+- AC_PATH_PROG(KDECONFIG, kde-config)
+- if test -n "$KDECONFIG"; then
+- KDE_APPLNK_DIR=`$KDECONFIG --expandvars --install apps`
+- AC_DEFINE(HAVE_KDE_APPLNK)
+- else
+- KDE_APPLNK_DIR=""
+- fi
+- fi
++ AC_DEFINE(HAVE_KDE_APPLNK)
++ KDE_APPLNK_DIR="$with_kde_applnk_path"
+ else
+ KDE_APPLNK_DIR=""
+ fi
diff --git a/net-mail/evolution/files/evolution-1.1.90-sharedldap.patch b/net-mail/evolution/files/evolution-1.1.90-sharedldap.patch
new file mode 100644
index 000000000000..6784aa343848
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.1.90-sharedldap.patch
@@ -0,0 +1,11 @@
+--- evolution-1.1.90/acinclude.m4.orig 2002-09-04 22:28:05.000000000 +0200
++++ evolution-1.1.90/acinclude.m4 2002-11-07 14:03:12.000000000 +0100
+@@ -107,7 +107,7 @@
+
+ case $with_static_ldap in
+ no|"")
+- if test -f $with_openldap/lib/libldap.la; then
++ if test ! -f $with_openldap/lib/libldap.la; then
+ with_static_ldap=yes
+ else
+ with_static_ldap=no
diff --git a/net-mail/evolution/files/evolution-1.1.90-subversion.patch b/net-mail/evolution/files/evolution-1.1.90-subversion.patch
new file mode 100644
index 000000000000..83cb40fd71b0
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.1.90-subversion.patch
@@ -0,0 +1,11 @@
+--- evolution-1.1.90/mail/mail-ops.c.subversion 2002-09-24 19:45:37.000000000 +0200
++++ evolution-1.1.90/mail/mail-ops.c 2002-11-07 13:17:20.000000000 +0100
+@@ -467,7 +467,7 @@
+ int i;
+
+ camel_medium_set_header (CAMEL_MEDIUM (message), "X-Mailer",
+- "Ximian Evolution " VERSION SUB_VERSION " " VERSION_COMMENT);
++ "Ximian Evolution " VERSION "-" SUB_VERSION " " VERSION_COMMENT);
+
+ camel_mime_message_set_date (message, CAMEL_MESSAGE_DATE_CURRENT, 0);
+