summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-17 04:20:40 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-17 04:20:40 +0000
commit33819be044674720bd9af32aaa1080683b493997 (patch)
tree15c43b7f51adfc893014a7b437e55ec6b3c119ac /net-mail/evolution
parentDEPEND enhancement (diff)
downloadgentoo-2-33819be044674720bd9af32aaa1080683b493997.tar.gz
gentoo-2-33819be044674720bd9af32aaa1080683b493997.tar.bz2
gentoo-2-33819be044674720bd9af32aaa1080683b493997.zip
repoman'd
Diffstat (limited to 'net-mail/evolution')
-rw-r--r--net-mail/evolution/evolution-1.0.3-r6.ebuild181
-rw-r--r--net-mail/evolution/evolution-1.0.3-r7.ebuild183
-rw-r--r--net-mail/evolution/evolution-1.0.5-r1.ebuild187
-rw-r--r--net-mail/evolution/evolution-1.0.5-r2.ebuild187
-rw-r--r--net-mail/evolution/evolution-1.0.5-r3.ebuild3
-rw-r--r--net-mail/evolution/evolution-1.0.5.ebuild181
-rw-r--r--net-mail/evolution/evolution-1.0.7.ebuild3
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.3-r62
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.3-r72
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.52
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.5-r12
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.5-r22
12 files changed, 4 insertions, 931 deletions
diff --git a/net-mail/evolution/evolution-1.0.3-r6.ebuild b/net-mail/evolution/evolution-1.0.3-r6.ebuild
deleted file mode 100644
index 0cc73887e862..000000000000
--- a/net-mail/evolution/evolution-1.0.3-r6.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.3-r6.ebuild,v 1.5 2002/07/11 06:30:47 drobbins Exp $
-
-#provide Xmake and Xemake
-
-inherit virtualx
-
-DB3=db-3.1.17
-S=${WORKDIR}/${P}
-DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz
- ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
- http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
- http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
-HOMEPAGE="http://www.ximian.com"
-
-RDEPEND=">=gnome-extra/bonobo-conf-0.14
- >=gnome-base/bonobo-1.0.18
- >=gnome-extra/gal-0.19
- >=gnome-base/gconf-1.0.7
- >=gnome-extra/gtkhtml-1.0.1
- >=gnome-base/oaf-0.6.7
- >=gnome-base/ORBit-0.5.12
- >=gnome-base/libglade-0.17-r1
- >=media-libs/gdk-pixbuf-0.14.0
- >=dev-libs/libxml-1.8.16
- >=gnome-base/gnome-vfs-1.0.2-r1
- >=gnome-base/gnome-print-0.34
- >=app-text/scrollkeeper-0.2
- dev-util/gob
- ssl? ( >=net-www/mozilla-0.9.9 )
- ldap? ( >=net-nds/openldap-2.0 )
- mozilla? ( >=net-www/mozilla-0.9.9 )
- pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )
- spell? ( >=app-text/gnome-spell-0.4.1-r1 )"
-
-# Added dependency on "dev-util/gob" this should fix a configure bug
-
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-1.4.1-r1
- doc? ( dev-util/gtk-doc )
- nls? ( >=dev-util/intltool-0.11
- sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- # Fix the filter crash. This is actually a problem in the add and
- # edit code. Mikael Hallendal originally fixed the bug in the add
- # code. I added the fixes for the edit code.
- #
- # Martin Schlemmer (02 April 2002)
- patch -p0 < ${FILESDIR}/evolution-1.0.3-filter-crash.patch || die
- # add mandrake patches
- # fix KDE detection
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-kde.patch || die
- # call pilot conduit applet (not pilot link applet)
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-conduit.patch || die
- # Patch from Preston A. Elder to resolve bug #1355
- # fix a problem with literal strings and sertain IMAP servers
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-imapfix.diff || die
-
- # lobtoolize to fix not all libs installing, and buggy .la files.
- # also add the gnome-pilot.m4 to the macros directory to fix
- # problems with the pilot conduct
- cd ${S}
- if [ ! -f ${S}/macros/gnome-pilot.m4 ]
- then
- cp -f ${FILESDIR}/gnome-pilot.m4 ${S}/macros || die
- fi
- [ -z "`use pda`" ] && libtoolize --copy --force
- aclocal -I macros
- automake --add-missing
- autoconf
-}
-
-src_compile() {
-
- cd ${WORKDIR}/${DB3}/build_unix
- ../dist/configure --prefix=${WORKDIR}/db3 || die
-
- make || die
- make prefix=${WORKDIR}/db3 install || die
-
- cd ${S}
-
- local myconf=""
-
- MOZILLA=$MOZILLA_FIVE_HOME
-
- if [ -n "`use pda`" ] ; then
- myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
- else
- myconf="${myconf} --enable-pilot-conduits=no"
- fi
-
- if [ -n "`use ldap`" ] ; then
- myconf="${myconf} --with-openldap=yes"
- else
- myconf="${myconf} --with-openldap=no"
- fi
-
- if [ -n "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nspr-libs --without-nspr-includes"
- fi
-
- if [ -n "`use ssl`" ] ; then
- myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
- --with-nss-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nss-libs --without-nss-includes"
- fi
-
- # SSL needs NSPR libs ...
- if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- fi
-
- if [ -n "`use doc`" ] ; then
- myconf="${myconf} --enable-gtk-doc"
- else
- myconf="${myconf} --disable-gtk-doc"
- fi
-
- if [ -z "`use nls`" ] ; then
- myconf="${myconf} --disable-nls"
- fi
-
- CFLAGS="${CFLAGS} -I/usr/include/libpisock"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --with-db3=${WORKDIR}/db3 \
- --disable-python-bindings \
- ${myconf} || die
-
- #needs to be able to connect to X display to build.
- Xemake || Xmake || die
-}
-
-src_install() {
- cd omf-install
- cp Makefile Makefile.old
- sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
- rm Makefile.old
- cd ${S}
-
- # Don't use DESTDIR it violates sandbox // Hallski
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- datadir=${D}/usr/share \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- KDE_APPLNK_DIR=${D}/usr/share/applnk \
- install || die
-
- dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
- dodoc NEWS README
-}
-
-pkg_postinst() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
-pkg_postrm() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
diff --git a/net-mail/evolution/evolution-1.0.3-r7.ebuild b/net-mail/evolution/evolution-1.0.3-r7.ebuild
deleted file mode 100644
index d7732cc61e25..000000000000
--- a/net-mail/evolution/evolution-1.0.3-r7.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.3-r7.ebuild,v 1.3 2002/07/11 06:30:47 drobbins Exp $
-
-#provide Xmake and Xemake
-
-inherit virtualx
-
-DB3=db-3.1.17
-S=${WORKDIR}/${P}
-DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz
- ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
- http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
- http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
-HOMEPAGE="http://www.ximian.com"
-
-RDEPEND=">=gnome-extra/bonobo-conf-0.14
- >=gnome-base/bonobo-1.0.18
- >=gnome-extra/gal-0.19
- >=gnome-base/gconf-1.0.7
- >=gnome-extra/gtkhtml-1.0.1
- >=gnome-base/oaf-0.6.7
- >=gnome-base/ORBit-0.5.12
- >=gnome-base/libglade-0.17-r1
- >=media-libs/gdk-pixbuf-0.14.0
- >=dev-libs/libxml-1.8.16
- >=gnome-base/gnome-vfs-1.0.2-r1
- >=gnome-base/gnome-print-0.34
- >=app-text/scrollkeeper-0.2
- dev-util/gob
- ssl? ( >=net-www/mozilla-0.9.9 )
- ldap? ( >=net-nds/openldap-2.0 )
- mozilla? ( >=net-www/mozilla-0.9.9 )
- pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )
- spell? ( >=app-text/gnome-spell-0.4.1-r1 )"
-
-# Added dependency on "dev-util/gob" this should fix a configure bug
-
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-1.4.1-r1
- doc? ( dev-util/gtk-doc )
- nls? ( >=dev-util/intltool-0.11
- sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- # Fix the filter crash. This is actually a problem in the add and
- # edit code. Mikael Hallendal originally fixed the bug in the add
- # code. I added the fixes for the edit code.
- #
- # Martin Schlemmer (02 April 2002)
- patch -p0 < ${FILESDIR}/evolution-1.0.3-filter-crash.patch || die
- # add mandrake patches
- # fix KDE detection
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-kde.patch || die
- # call pilot conduit applet (not pilot link applet)
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-conduit.patch || die
- # Patch from Preston A. Elder to resolve bug #1355
- # fix a problem with literal strings and sertain IMAP servers
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-imapfix.diff || die
-
- # A fix for a recent security related issue
- patch -d ${S} -p0 < ${FILESDIR}/${PN}-${PV}-24140.patch || die "security-patch failed"
- # lobtoolize to fix not all libs installing, and buggy .la files.
- # also add the gnome-pilot.m4 to the macros directory to fix
- # problems with the pilot conduct
- cd ${S}
- if [ ! -f ${S}/macros/gnome-pilot.m4 ]
- then
- cp -f ${FILESDIR}/gnome-pilot.m4 ${S}/macros || die
- fi
- [ -z "`use pda`" ] && libtoolize --copy --force
- aclocal -I macros
- automake --add-missing
- autoconf
-}
-
-src_compile() {
-
- cd ${WORKDIR}/${DB3}/build_unix
- ../dist/configure --prefix=${WORKDIR}/db3 || die
-
- make || die
- make prefix=${WORKDIR}/db3 install || die
-
- cd ${S}
-
- local myconf=""
-
- MOZILLA=$MOZILLA_FIVE_HOME
-
- if [ -n "`use pda`" ] ; then
- myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
- else
- myconf="${myconf} --enable-pilot-conduits=no"
- fi
-
- if [ -n "`use ldap`" ] ; then
- myconf="${myconf} --with-openldap=yes"
- else
- myconf="${myconf} --with-openldap=no"
- fi
-
- if [ -n "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nspr-libs --without-nspr-includes"
- fi
-
- if [ -n "`use ssl`" ] ; then
- myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
- --with-nss-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nss-libs --without-nss-includes"
- fi
-
- # SSL needs NSPR libs ...
- if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- fi
-
- if [ -n "`use doc`" ] ; then
- myconf="${myconf} --enable-gtk-doc"
- else
- myconf="${myconf} --disable-gtk-doc"
- fi
-
- if [ -z "`use nls`" ] ; then
- myconf="${myconf} --disable-nls"
- fi
-
- CFLAGS="${CFLAGS} -I/usr/include/libpisock"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --with-db3=${WORKDIR}/db3 \
- --disable-python-bindings \
- ${myconf} || die
-
- #needs to be able to connect to X display to build.
- Xemake || Xmake || die
-}
-
-src_install() {
- cd omf-install
- cp Makefile Makefile.old
- sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
- rm Makefile.old
- cd ${S}
-
- # Don't use DESTDIR it violates sandbox // Hallski
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- datadir=${D}/usr/share \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- KDE_APPLNK_DIR=${D}/usr/share/applnk \
- install || die
-
- dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
- dodoc NEWS README
-}
-
-pkg_postinst() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
-pkg_postrm() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
diff --git a/net-mail/evolution/evolution-1.0.5-r1.ebuild b/net-mail/evolution/evolution-1.0.5-r1.ebuild
deleted file mode 100644
index ebf8e85dda97..000000000000
--- a/net-mail/evolution/evolution-1.0.5-r1.ebuild
+++ /dev/null
@@ -1,187 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.5-r1.ebuild,v 1.2 2002/06/09 13:19:18 stroke Exp $
-
-#provide Xmake and Xemake
-
-inherit virtualx
-
-DB3=db-3.1.17
-S=${WORKDIR}/${P}
-DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
- ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
- http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
- http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
-HOMEPAGE="http://www.ximian.com"
-SLOT="0"
-LICENSE="GPL-2"
-
-RDEPEND=">=gnome-extra/bonobo-conf-0.14
- >=gnome-base/bonobo-1.0.18
- >=gnome-extra/gal-0.19.2
- ( >=gnome-base/gconf-1.0.7
- <gnome-base/gconf-1.1 )
- >=gnome-extra/gtkhtml-1.0.1
- >=gnome-base/oaf-0.6.7
- >=gnome-base/ORBit-0.5.12
- ( >=gnome-base/libglade-0.17-r1
- <gnome-base/libglade-2.0 )
- >=media-libs/gdk-pixbuf-0.14.0
- >=dev-libs/libxml-1.8.16
- ( >=gnome-base/gnome-vfs-1.0.2-r2
- <gnome-base/gnome-vfs-1.9 )
- >=gnome-base/gnome-print-0.34
- ( >=app-text/scrollkeeper-0.2
- <app-text/scrollkeeper-0.3 )
- dev-util/gob
- ssl? ( >=net-www/mozilla-0.9.9 )
- ldap? ( >=net-nds/openldap-2.0 )
- mozilla? ( >=net-www/mozilla-0.9.9 )
- pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )
- spell? ( >=app-text/gnome-spell-0.4.1-r1 )"
-
-# Added dependency on "dev-util/gob" this should fix a configure bug
-
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-1.4.1-r1
- doc? ( dev-util/gtk-doc )
- nls? ( >=dev-util/intltool-0.11
- sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- # Fix the filter crash. This is actually a problem in the add and
- # edit code. Mikael Hallendal originally fixed the bug in the add
- # code. I added the fixes for the edit code.
- #
- # Martin Schlemmer (02 April 2002)
- patch -p0 < ${FILESDIR}/evolution-1.0.3-filter-crash.patch || die
- # add mandrake patches
- # fix KDE detection
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-kde.patch || die
- # call pilot conduit applet (not pilot link applet)
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-conduit.patch || die
- # Patch from Preston A. Elder to resolve bug #1355
- # fix a problem with literal strings and sertain IMAP servers
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-imapfix.diff || die
-
- # lobtoolize to fix not all libs installing, and buggy .la files.
- # also add the gnome-pilot.m4 to the macros directory to fix
- # problems with the pilot conduct
- cd ${S}
- if [ ! -f ${S}/macros/gnome-pilot.m4 ]
- then
- cp -f ${FILESDIR}/gnome-pilot.m4 ${S}/macros || die
- fi
- [ -z "`use pda`" ] && libtoolize --copy --force
- aclocal -I macros
- automake --add-missing
- autoconf
-}
-
-src_compile() {
-
- cd ${WORKDIR}/${DB3}/build_unix
- ../dist/configure --prefix=${WORKDIR}/db3 || die
-
- make || die
- make prefix=${WORKDIR}/db3 install || die
-
- cd ${S}
-
- local myconf=""
-
- MOZILLA=$MOZILLA_FIVE_HOME
-
- if [ -n "`use pda`" ] ; then
- myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
- else
- myconf="${myconf} --enable-pilot-conduits=no"
- fi
-
- if [ -n "`use ldap`" ] ; then
- myconf="${myconf} --with-openldap=yes"
- else
- myconf="${myconf} --with-openldap=no"
- fi
-
- if [ -n "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nspr-libs --without-nspr-includes"
- fi
-
- if [ -n "`use ssl`" ] ; then
- myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
- --with-nss-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nss-libs --without-nss-includes"
- fi
-
- # SSL needs NSPR libs ...
- if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- fi
-
- if [ -n "`use doc`" ] ; then
- myconf="${myconf} --enable-gtk-doc"
- else
- myconf="${myconf} --disable-gtk-doc"
- fi
-
- if [ -z "`use nls`" ] ; then
- myconf="${myconf} --disable-nls"
- fi
-
- CFLAGS="${CFLAGS} -I/usr/include/libpisock"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --with-db3=${WORKDIR}/db3 \
- --disable-python-bindings \
- ${myconf} || die
-
- #needs to be able to connect to X display to build.
- Xemake || Xmake || die
-}
-
-src_install() {
- cd omf-install
- cp Makefile Makefile.old
- sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
- rm Makefile.old
- cd ${S}
-
- # Don't use DESTDIR it violates sandbox // Hallski
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- datadir=${D}/usr/share \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- KDE_APPLNK_DIR=${D}/usr/share/applnk \
- install || die
-
- dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
- dodoc NEWS README
-}
-
-pkg_postinst() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
-pkg_postrm() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
diff --git a/net-mail/evolution/evolution-1.0.5-r2.ebuild b/net-mail/evolution/evolution-1.0.5-r2.ebuild
deleted file mode 100644
index f473ae850fa2..000000000000
--- a/net-mail/evolution/evolution-1.0.5-r2.ebuild
+++ /dev/null
@@ -1,187 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.5-r2.ebuild,v 1.1 2002/06/09 19:34:56 azarah Exp $
-
-#provide Xmake and Xemake
-
-inherit virtualx libtool
-
-DB3=db-3.1.17
-S=${WORKDIR}/${P}
-DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
- ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
- http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
- http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
-HOMEPAGE="http://www.ximian.com"
-SLOT="0"
-LICENSE="GPL-2"
-
-RDEPEND=">=gnome-extra/bonobo-conf-0.14
- >=gnome-base/bonobo-1.0.18
- >=gnome-extra/gal-0.19.2
- ( >=gnome-base/gconf-1.0.7
- <gnome-base/gconf-1.1 )
- >=gnome-extra/gtkhtml-1.0.1
- >=gnome-base/oaf-0.6.7
- >=gnome-base/ORBit-0.5.12
- ( >=gnome-base/libglade-0.17-r1
- <gnome-base/libglade-2.0 )
- >=media-libs/gdk-pixbuf-0.14.0
- >=dev-libs/libxml-1.8.16
- ( >=gnome-base/gnome-vfs-1.0.2-r2
- <gnome-base/gnome-vfs-1.9 )
- >=gnome-base/gnome-print-0.34
- ( >=app-text/scrollkeeper-0.2
- <app-text/scrollkeeper-0.3 )
- dev-util/gob
- ssl? ( >=net-www/mozilla-0.9.9 )
- ldap? ( >=net-nds/openldap-2.0 )
- mozilla? ( >=net-www/mozilla-0.9.9 )
- pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )
- spell? ( >=app-text/gnome-spell-0.4.1-r1 )"
-
-# Added dependency on "dev-util/gob" this should fix a configure bug
-
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-1.4.1-r1
- doc? ( dev-util/gtk-doc )
- nls? ( >=dev-util/intltool-0.11
- sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- # Fix the filter crash. This is actually a problem in the add and
- # edit code. Mikael Hallendal originally fixed the bug in the add
- # code. I added the fixes for the edit code.
- #
- # Martin Schlemmer (02 April 2002)
- patch -p0 < ${FILESDIR}/evolution-1.0.3-filter-crash.patch || die
- # add mandrake patches
- # fix KDE detection
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-kde.patch || die
- # call pilot conduit applet (not pilot link applet)
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-conduit.patch || die
- # Patch from Preston A. Elder to resolve bug #1355
- # fix a problem with literal strings and sertain IMAP servers
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-imapfix.diff || die
-
- # lobtoolize to fix not all libs installing, and buggy .la files.
- # also add the gnome-pilot.m4 to the macros directory to fix
- # problems with the pilot conduct
- cd ${S}
- if [ ! -f ${S}/macros/gnome-pilot.m4 ]
- then
- cp -f ${FILESDIR}/gnome-pilot.m4 ${S}/macros || die
- fi
- elibtoolize
- aclocal -I macros
- automake --add-missing
- autoconf
-}
-
-src_compile() {
-
- cd ${WORKDIR}/${DB3}/build_unix
- ../dist/configure --prefix=${WORKDIR}/db3 || die
-
- make || die
- make prefix=${WORKDIR}/db3 install || die
-
- cd ${S}
-
- local myconf=""
-
- MOZILLA=$MOZILLA_FIVE_HOME
-
- if [ -n "`use pda`" ] ; then
- myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
- else
- myconf="${myconf} --enable-pilot-conduits=no"
- fi
-
- if [ -n "`use ldap`" ] ; then
- myconf="${myconf} --with-openldap=yes"
- else
- myconf="${myconf} --with-openldap=no"
- fi
-
- if [ -n "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nspr-libs --without-nspr-includes"
- fi
-
- if [ -n "`use ssl`" ] ; then
- myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
- --with-nss-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nss-libs --without-nss-includes"
- fi
-
- # SSL needs NSPR libs ...
- if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- fi
-
- if [ -n "`use doc`" ] ; then
- myconf="${myconf} --enable-gtk-doc"
- else
- myconf="${myconf} --disable-gtk-doc"
- fi
-
- if [ -z "`use nls`" ] ; then
- myconf="${myconf} --disable-nls"
- fi
-
- CFLAGS="${CFLAGS} -I/usr/include/libpisock"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --with-db3=${WORKDIR}/db3 \
- --disable-python-bindings \
- ${myconf} || die
-
- #needs to be able to connect to X display to build.
- Xemake || Xmake || die
-}
-
-src_install() {
- cd omf-install
- cp Makefile Makefile.old
- sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
- rm Makefile.old
- cd ${S}
-
- # Don't use DESTDIR it violates sandbox // Hallski
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- datadir=${D}/usr/share \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- KDE_APPLNK_DIR=${D}/usr/share/applnk \
- install || die
-
- dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
- dodoc NEWS README
-}
-
-pkg_postinst() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
-pkg_postrm() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
diff --git a/net-mail/evolution/evolution-1.0.5-r3.ebuild b/net-mail/evolution/evolution-1.0.5-r3.ebuild
index 2bcc73f93cf9..e2e4f1ecd045 100644
--- a/net-mail/evolution/evolution-1.0.5-r3.ebuild
+++ b/net-mail/evolution/evolution-1.0.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.5-r3.ebuild,v 1.1 2002/06/12 12:11:26 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.5-r3.ebuild,v 1.2 2002/07/17 04:20:39 seemant Exp $
#provide Xmake and Xemake
@@ -16,6 +16,7 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
HOMEPAGE="http://www.ximian.com"
SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="x86"
RDEPEND=">=gnome-extra/bonobo-conf-0.14
>=gnome-base/bonobo-1.0.18
diff --git a/net-mail/evolution/evolution-1.0.5.ebuild b/net-mail/evolution/evolution-1.0.5.ebuild
deleted file mode 100644
index 2c851af5c52c..000000000000
--- a/net-mail/evolution/evolution-1.0.5.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.5.ebuild,v 1.3 2002/07/11 06:30:47 drobbins Exp $
-
-#provide Xmake and Xemake
-
-inherit virtualx
-
-DB3=db-3.1.17
-S=${WORKDIR}/${P}
-DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
- ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
- http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
- http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
-HOMEPAGE="http://www.ximian.com"
-
-RDEPEND=">=gnome-extra/bonobo-conf-0.14
- >=gnome-base/bonobo-1.0.18
- >=gnome-extra/gal-0.19.2
- >=gnome-base/gconf-1.0.7
- >=gnome-extra/gtkhtml-1.0.1
- >=gnome-base/oaf-0.6.7
- >=gnome-base/ORBit-0.5.12
- >=gnome-base/libglade-0.17-r1
- >=media-libs/gdk-pixbuf-0.14.0
- >=dev-libs/libxml-1.8.16
- >=gnome-base/gnome-vfs-1.0.2-r1
- >=gnome-base/gnome-print-0.34
- >=app-text/scrollkeeper-0.2
- dev-util/gob
- ssl? ( >=net-www/mozilla-0.9.9 )
- ldap? ( >=net-nds/openldap-2.0 )
- mozilla? ( >=net-www/mozilla-0.9.9 )
- pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )
- spell? ( >=app-text/gnome-spell-0.4.1-r1 )"
-
-# Added dependency on "dev-util/gob" this should fix a configure bug
-
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-1.4.1-r1
- doc? ( dev-util/gtk-doc )
- nls? ( >=dev-util/intltool-0.11
- sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- # Fix the filter crash. This is actually a problem in the add and
- # edit code. Mikael Hallendal originally fixed the bug in the add
- # code. I added the fixes for the edit code.
- #
- # Martin Schlemmer (02 April 2002)
- patch -p0 < ${FILESDIR}/evolution-1.0.3-filter-crash.patch || die
- # add mandrake patches
- # fix KDE detection
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-kde.patch || die
- # call pilot conduit applet (not pilot link applet)
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-conduit.patch || die
- # Patch from Preston A. Elder to resolve bug #1355
- # fix a problem with literal strings and sertain IMAP servers
- patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-imapfix.diff || die
-
- # lobtoolize to fix not all libs installing, and buggy .la files.
- # also add the gnome-pilot.m4 to the macros directory to fix
- # problems with the pilot conduct
- cd ${S}
- if [ ! -f ${S}/macros/gnome-pilot.m4 ]
- then
- cp -f ${FILESDIR}/gnome-pilot.m4 ${S}/macros || die
- fi
- [ -z "`use pda`" ] && libtoolize --copy --force
- aclocal -I macros
- automake --add-missing
- autoconf
-}
-
-src_compile() {
-
- cd ${WORKDIR}/${DB3}/build_unix
- ../dist/configure --prefix=${WORKDIR}/db3 || die
-
- make || die
- make prefix=${WORKDIR}/db3 install || die
-
- cd ${S}
-
- local myconf=""
-
- MOZILLA=$MOZILLA_FIVE_HOME
-
- if [ -n "`use pda`" ] ; then
- myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
- else
- myconf="${myconf} --enable-pilot-conduits=no"
- fi
-
- if [ -n "`use ldap`" ] ; then
- myconf="${myconf} --with-openldap=yes"
- else
- myconf="${myconf} --with-openldap=no"
- fi
-
- if [ -n "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nspr-libs --without-nspr-includes"
- fi
-
- if [ -n "`use ssl`" ] ; then
- myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
- --with-nss-libs=${MOZILLA}"
- else
- myconf="${myconf} --without-nss-libs --without-nss-includes"
- fi
-
- # SSL needs NSPR libs ...
- if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
- myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
- --with-nspr-libs=${MOZILLA}"
- fi
-
- if [ -n "`use doc`" ] ; then
- myconf="${myconf} --enable-gtk-doc"
- else
- myconf="${myconf} --disable-gtk-doc"
- fi
-
- if [ -z "`use nls`" ] ; then
- myconf="${myconf} --disable-nls"
- fi
-
- CFLAGS="${CFLAGS} -I/usr/include/libpisock"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --with-db3=${WORKDIR}/db3 \
- --disable-python-bindings \
- ${myconf} || die
-
- #needs to be able to connect to X display to build.
- Xemake || Xmake || die
-}
-
-src_install() {
- cd omf-install
- cp Makefile Makefile.old
- sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
- rm Makefile.old
- cd ${S}
-
- # Don't use DESTDIR it violates sandbox // Hallski
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- datadir=${D}/usr/share \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- KDE_APPLNK_DIR=${D}/usr/share/applnk \
- install || die
-
- dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
- dodoc NEWS README
-}
-
-pkg_postinst() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
-pkg_postrm() {
- echo ">>> Updating Scrollkeeper database..."
- scrollkeeper-update >/dev/null 2>&1
-}
-
diff --git a/net-mail/evolution/evolution-1.0.7.ebuild b/net-mail/evolution/evolution-1.0.7.ebuild
index b4878afbf767..301f3131b4ce 100644
--- a/net-mail/evolution/evolution-1.0.7.ebuild
+++ b/net-mail/evolution/evolution-1.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.7.ebuild,v 1.1 2002/06/15 03:57:23 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.7.ebuild,v 1.2 2002/07/17 04:20:39 seemant Exp $
#provide Xmake and Xemake
@@ -16,6 +16,7 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz
HOMEPAGE="http://www.ximian.com"
SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="x86"
RDEPEND=">=gnome-extra/bonobo-conf-0.14
>=gnome-base/bonobo-1.0.18
diff --git a/net-mail/evolution/files/digest-evolution-1.0.3-r6 b/net-mail/evolution/files/digest-evolution-1.0.3-r6
deleted file mode 100644
index c04a2f7454ba..000000000000
--- a/net-mail/evolution/files/digest-evolution-1.0.3-r6
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 28ffb3911f46a591466a78f5c805c0aa evolution-1.0.3.tar.gz 12908768
-MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117
diff --git a/net-mail/evolution/files/digest-evolution-1.0.3-r7 b/net-mail/evolution/files/digest-evolution-1.0.3-r7
deleted file mode 100644
index c04a2f7454ba..000000000000
--- a/net-mail/evolution/files/digest-evolution-1.0.3-r7
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 28ffb3911f46a591466a78f5c805c0aa evolution-1.0.3.tar.gz 12908768
-MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117
diff --git a/net-mail/evolution/files/digest-evolution-1.0.5 b/net-mail/evolution/files/digest-evolution-1.0.5
deleted file mode 100644
index e66b02a7f198..000000000000
--- a/net-mail/evolution/files/digest-evolution-1.0.5
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 16a67877f63586e3fbd62c4070334cc1 evolution-1.0.5.tar.gz 13077615
-MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117
diff --git a/net-mail/evolution/files/digest-evolution-1.0.5-r1 b/net-mail/evolution/files/digest-evolution-1.0.5-r1
deleted file mode 100644
index e66b02a7f198..000000000000
--- a/net-mail/evolution/files/digest-evolution-1.0.5-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 16a67877f63586e3fbd62c4070334cc1 evolution-1.0.5.tar.gz 13077615
-MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117
diff --git a/net-mail/evolution/files/digest-evolution-1.0.5-r2 b/net-mail/evolution/files/digest-evolution-1.0.5-r2
deleted file mode 100644
index e66b02a7f198..000000000000
--- a/net-mail/evolution/files/digest-evolution-1.0.5-r2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 16a67877f63586e3fbd62c4070334cc1 evolution-1.0.5.tar.gz 13077615
-MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117