summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2001-02-15 20:48:24 +0000
committerJerry Alexandratos <jerry@gentoo.org>2001-02-15 20:48:24 +0000
commit1a4fd6dfedd1c48198d028b43d20582f09681f69 (patch)
treef0dd15de5dfdf27ac4ce2c27f4b7b639e4463afa /net-mail/exim
parentUpdated to latest version. (diff)
downloadgentoo-2-1a4fd6dfedd1c48198d028b43d20582f09681f69.tar.gz
gentoo-2-1a4fd6dfedd1c48198d028b43d20582f09681f69.tar.bz2
gentoo-2-1a4fd6dfedd1c48198d028b43d20582f09681f69.zip
New build files.
Diffstat (limited to 'net-mail/exim')
-rw-r--r--net-mail/exim/exim-3.22.ebuild131
-rw-r--r--net-mail/exim/files/configure419
2 files changed, 550 insertions, 0 deletions
diff --git a/net-mail/exim/exim-3.22.ebuild b/net-mail/exim/exim-3.22.ebuild
new file mode 100644
index 000000000000..9f59f3f7aee0
--- /dev/null
+++ b/net-mail/exim/exim-3.22.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# /home/cvsroot/gentoo-x86/skel.ebuild,v 1.1 2000/10/09 18:00:52 achim Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A highly configurable, drop-in replacement for sendmail"
+SRC_URI="ftp://ftp.exim.org/pub/exim/${A}"
+HOMEPAGE="http://www.exim.org/"
+
+DEPEND=">=net-mail/mailbase-0.00
+ >=sys-libs/glibc-2.1.3
+ >=sys-devel/perl-5.6.0"
+
+TLS_DEP=">=dev-libs/openssl-0.9.6"
+LDAP_DEP=">=net-nds/openldap-2.0.7"
+MYSQL_DEP=">=dev-db/mysql-3.23.28"
+
+if [ -n "`use mta-tls`" ]; then
+ DEPEND="${DEPEND} ${TLS_DEP}"
+fi
+
+if [ -n "`use mta-ldap`" ]; then
+ DEPEND="${DEPEND} ${LDAP_DEP}"
+fi
+
+if [ -n "`use mta-mysql`" ]; then
+ DEPEND="${DEPEND} ${MYSQL_DEP}"
+fi
+
+PROVIDE="virtual/mta"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ mkdir Local
+ sed -e "48i\CFLAGS=${CFLAGS}" \
+ -e "s:# AUTH_CRAM_MD5=yes:AUTH_CRAM_MD5=yes:" \
+ -e "s:# AUTH_PLAINTEXT=yes:AUTH_PLAINTEXT=yes:" \
+ -e "s:BIN_DIRECTORY=/usr/exim/bin:BIN_DIRECTORY=/usr/sbin:" \
+ -e "s:COMPRESS_COMMAND=/opt/gnu/bin/gzip:COMPRESS_COMMAND=/usr/bin/gzip:" \
+ -e "s:ZCAT_COMMAND=/opt/gnu/bin/zcat:ZCAT_COMMAND=/usr/bin/zcat:" \
+ -e "s:CONFIGURE_FILE=/usr/exim/configure:CONFIGURE_FILE=/etc/exim/configure:" \
+ -e "s:EXIM_MONITOR=eximon.bin:# EXIM_MONITOR=eximon.bin:" \
+ -e "s:# EXIM_PERL=perl.o:EXIM_PERL=perl.o:" \
+ -e "s:# LOG_FILE_PATH=syslog:LOG_FILE_PATH=syslog:" \
+ -e "s:# PID_FILE_PATH=/var/lock/exim%s.pid:PID_FILE_PATH=/var/run/exim%s.pid:" \
+ -e "s:# SPOOL_DIRECTORY=/var/spool/exim:SPOOL_DIRECTORY=/var/spool/exim:" \
+ -e "s:# SUPPORT_MAILDIR=yes:SUPPORT_MAILDIR=yes:" \
+ -e "s:# SUPPORT_PAM=yes:SUPPORT_PAM=yes:" \
+ -e "s:# USE_TCP_WRAPPERS=yes:USE_TCP_WRAPPERS=yes\n\EXTRALIBS=-lpam -lwrap:" src/EDITME > Local/Makefile
+ try make
+
+ if [ -n "`use mta-tls`" ]; then
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# SUPPORT_TLS=yes:SUPPORT_TLS=yes:" \
+ -e "s:# TLS_LIBS=-lssl -lcrypto:TLS_LIBS=-lssl -lcrypto:" Local/Makefile.tmp > Local/Makefile
+ fi
+
+ if [ -n "`use mta-ldap`" ]; then
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# LOOKUP_LDAP=yes:LOOKUP_LDAP=yes:" \
+ -e "s:# LOOKUP_INCLUDE=-I /usr/local/ldap/include -I /usr/local/mysql/include -I /usr/local/pgsql/include:LOOKUP_INCLUDE=-I/usr/include/ldap -I/usr/include/mysql:" \
+ -e "s:# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient -lpq:LOOKUP_LIBS=-L/usr/lib -lldap -llber -lmysqlclient -lpq:" \
+ -e "s:# LDAP_LIB_TYPE=OPENLDAP2:LDAP_LIB_TYPE=OPENLDAP2:" Local/Makefile.tmp >| Local/Makefile
+ fi
+
+ if [ -n "`use mta-mysql`" ]; then
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# LOOKUP_MYSQL=yes:LOOKUP_MYSQL=yes:" \
+ -e "s:# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient -lpq:LOOKUP_LIBS=-L/usr/lib -lldap -llber -lmysqlclient -lpq:" Local/Makefile.tmp >| Local/Makefile
+ fi
+}
+
+src_compile() {
+ cd ${S}
+ try make
+}
+
+src_install () {
+ cd ${S}/build-Linux-i386
+ insopts -o root -g root -m 4755
+ insinto /usr/sbin
+ doins exim
+
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosym /usr/sbin/exim /usr/bin/mailq
+ dosym /usr/sbin/exim /usr/bin/newaliases
+ dosym /usr/sbin/exim /usr/bin/mail
+ dosym /usr/sbin/exim /usr/lib/sendmail
+ dosym /usr/sbin/exim /usr/sbin/sendmail
+
+ insopts -o root -g root -m 0755
+ insinto /usr/sbin
+ for i in exicyclog exim_dbmbuild exim_dumpdb exim_fixdb \
+ exim_lock exim_tidydb exinext exiwhat
+ do
+ doins $i
+ done
+
+ cd ${S}/util
+ insopts -o root -g root -m 0755
+ insinto /usr/sbin
+ for i in exigrep eximstats exiqsumm
+ do
+ doins $i
+ done
+
+ dodir /etc/exim /etc/exim/samples
+
+ insopts -o root -g root -m 0644
+ insinto /etc/exim
+ doins ${FILESDIR}/configure
+
+ cd ${S}/src
+ insopts -o root -g root -m 0644
+ insinto /etc/exim/samples
+ doins configure.default
+
+ insopts -o root -g root -m 0755
+ insinto /etc/rc.d/init.d
+ doins ${FILESDIR}/exim
+
+ dodoc ${S}/doc/*
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/rc-update add exim
+}
diff --git a/net-mail/exim/files/configure b/net-mail/exim/files/configure
new file mode 100644
index 000000000000..740da7fc501a
--- /dev/null
+++ b/net-mail/exim/files/configure
@@ -0,0 +1,419 @@
+######################################################################
+# Runtime configuration file for Exim #
+######################################################################
+
+
+# This is a default configuration file which will operate correctly in
+# uncomplicated installations. Please see the manual for a complete list
+# of all the runtime configuration options that can be included in a
+# configuration file. There are many more than are mentioned here. The
+# manual is in the file doc/spec.txt in the Exim distribution as a plain
+# ASCII file. Other formats (PostScript, Texinfo, HTML, PDF) are available
+# from the Exim ftp sites. The manual is also online via the Exim web sites.
+
+
+# This file is divided into several parts, all but the last of which are
+# terminated by a line containing the word "end". The parts must appear
+# in the correct order, and all must be present (even if some of them are
+# in fact empty). Blank lines, and lines starting with # are ignored.
+
+
+############ IMPORTANT ########## IMPORTANT ########### IMPORTANT ############
+# #
+# Whenever you change Exim's configuration file, you *must* remember to HUP #
+# the Exim daemon, because it will not pick up the new configuration until #
+# until you do this. It is usually a good idea to test a new configuration #
+# for syntactic correctness (e.g. using "exim -C /config/file -bV") first. #
+# #
+############ IMPORTANT ########## IMPORTANT ########### IMPORTANT ############
+
+
+
+######################################################################
+# MAIN CONFIGURATION SETTINGS #
+######################################################################
+
+# Specify your host's canonical name here. This should normally be the fully
+# qualified "official" name of your host. If this option is not set, the
+# uname() function is called to obtain the name.
+
+# primary_hostname =
+
+
+# Specify the domain you want to be added to all unqualified addresses
+# here. An unqualified address is one that does not contain an "@" character
+# followed by a domain. For example, "caesar@rome.ex" is a fully qualified
+# address, but the string "caesar" (i.e. just a login name) is an unqualified
+# email address. Unqualified addresses are accepted only from local callers by
+# default. See the receiver_unqualified_{hosts,nets} options if you want
+# to permit unqualified addresses from remote sources. If this option is
+# not set, the primary_hostname value is used for qualification.
+
+# qualify_domain =
+
+
+# If you want unqualified recipient addresses to be qualified with a different
+# domain to unqualified sender addresses, specify the recipient domain here.
+# If this option is not set, the qualify_domain value is used.
+
+# qualify_recipient =
+
+
+# Specify your local domains as a colon-separated list here. If this option
+# is not set (i.e. not mentioned in the configuration file), the
+# qualify_recipient value is used as the only local domain. If you do not want
+# to do any local deliveries, uncomment the following line, but do not supply
+# any data for it. This sets local_domains to an empty string, which is not
+# the same as not mentioning it at all. An empty string specifies that there
+# are no local domains; not setting it at all causes the default value (the
+# setting of qualify_recipient) to be used.
+
+# local_domains =
+
+
+# If you want to accept mail addressed to your host's literal IP address, for
+# example, mail addressed to "user@[111.111.111.111]", then uncomment the
+# following line, or supply the literal domain(s) as part of "local_domains"
+# above. You also need to comment "forbid_domain_literals" below. This is not
+# recommended for today's Internet.
+
+# local_domains_include_host_literals
+
+
+# The following line prevents Exim from recognizing addresses of the form
+# "user@[111.111.111.111]" that is, with a "domain literal" (an IP address)
+# instead of a named domain. The RFCs still require this form, but it makes
+# little sense to permit mail to be sent to specific hosts by their IP address
+# in the modern Internet, and this ancient format has been used by those
+# seeking to abuse hosts by using them for unwanted relaying. If you really
+# do want to support domain literals, remove the following line, and see
+# also the "domain_literal" router below.
+
+forbid_domain_literals
+
+
+# No local deliveries will ever be run under the uids of these users (a colon-
+# separated list). An attempt to do so gets changed so that it runs under the
+# uid of "nobody" instead. This is a paranoic safety catch. Note the default
+# setting means you cannot deliver mail addressed to root as if it were a
+# normal user. This isn't usually a problem, as most sites have an alias for
+# root that redirects such mail to a human administrator.
+
+never_users = root
+
+
+# The use of your host as a mail relay by any host, including the local host
+# calling its own SMTP port, is locked out by default. If you want to permit
+# relaying from the local host, you should set
+#
+# host_accept_relay = localhost
+#
+# If you want to permit relaying through your host from certain hosts or IP
+# networks, you need to set the option appropriately, for example
+#
+# host_accept_relay = my.friends.host : 192.168.0.0/16
+#
+# If you are an MX backup or gateway of some kind for some domains, you must
+# set relay_domains to match those domains. This will allow any host to
+# relay through your host to those domains.
+#
+# relay_domains =
+#
+# See the section of the manual entitled "Control of relaying" for more
+# information.
+
+
+# The setting below causes Exim to do a reverse DNS lookup on all incoming
+# IP calls, in order to get the true host name. If you feel this is too
+# expensive, you can specify the networks for which a lookup is done, or
+# remove the setting entirely.
+
+host_lookup = *
+
+
+# By default, Exim expects all envelope addresses to be fully qualified, that
+# is, they must contain both a local part and a domain. If you want to accept
+# unqualified addresses (just a local part) from certain hosts, you can specify
+# these hosts by setting one or both of
+#
+# receiver_unqualified_hosts =
+# sender_unqualified_hosts =
+#
+# to control sender and receiver addresses, respectively. When this is done,
+# unqualified addresses are qualified using the settings of qualify_domain
+# and/or qualify_recipient (see above).
+
+
+# By default, Exim does not make any checks, other than syntactic ones, on
+# incoming addresses during the SMTP dialogue. This reduces delays in SMTP
+# transactions, but it does mean that you might accept messages with unknown
+# recipients, and/or bad senders.
+
+# Uncomment this line if you want incoming recipient addresses to be verified
+# during the SMTP dialogue. Unknown recipients are then rejected at this stage,
+# and the generation of a failure message is the job of the sending host.
+
+# receiver_verify
+
+# Uncomment this line if you want incoming sender addresses (return-paths) to
+# be verified during the SMTP dialogue. Verification can normally only check
+# that the domain exists.
+
+# sender_verify
+
+
+# Exim contains support for the Realtime Blocking List (RBL) that is being
+# maintained as part of the DNS. See http://maps.vix.com/rbl/ for background.
+# Uncommenting the first line below will make Exim reject mail from any
+# host whose IP address is blacklisted in the RBL at maps.vix.com. Some
+# others have followed the RBL lead and have produced other lists: DUL is
+# a list of dial-up addresses, and ORBS is a list of open relay systems. The
+# second line below checks all three lists.
+
+# rbl_domains = rbl.maps.vix.com
+# rbl_domains = rbl.maps.vix.com:dul.maps.vix.com:relays.orbs.org
+
+
+# If you want Exim to support the "percent hack" for all your local domains,
+# uncomment the following line. This is the feature by which mail addressed
+# to x%y@z (where z is one of your local domains) is locally rerouted to
+# x@y and sent on. Otherwise x%y is treated as an ordinary local part.
+
+# percent_hack_domains = *
+
+
+# When Exim can neither deliver a message nor return it to sender, it "freezes"
+# the delivery error message (aka "bounce message"). There are also other
+# circumstances in which messages get frozen. They will stay on the queue for
+# ever unless one of the following options is set.
+
+# This option unfreezes unfreezes bounce messages after two days, tries
+# once more to deliver them, and ignores any delivery failures.
+
+ignore_errmsg_errors_after = 2d
+
+# This option cancels (removes) frozen messages that are older than a week.
+
+timeout_frozen_after = 7d
+
+end
+
+
+
+######################################################################
+# TRANSPORTS CONFIGURATION #
+######################################################################
+# ORDER DOES NOT MATTER #
+# Only one appropriate transport is called for each delivery. #
+######################################################################
+
+# A transport is used only when referenced from a director or a router that
+# successfully handles an address.
+
+
+# This transport is used for delivering messages over SMTP connections.
+
+remote_smtp:
+ driver = smtp
+
+
+# This transport is used for local delivery to user mailboxes in traditional
+# BSD mailbox format. By default it will be run under the uid and gid of the
+# local user, and requires the sticky bit to be set on the /var/mail directory.
+# Some systems use the alternative approach of running mail deliveries under a
+# particular group instead of using the sticky bit. The commented options below
+# show how this can be done.
+
+local_delivery:
+ driver = appendfile
+# file = /var/mail/$local_part
+ directory = $home/.maildir
+ maildir_format
+ delivery_date_add
+ envelope_to_add
+ return_path_add
+# group = mail
+# mode = 0660
+
+
+# This transport is used for handling pipe deliveries generated by alias
+# or .forward files. If the pipe generates any standard output, it is returned
+# to the sender of the message as a delivery error. Set return_fail_output
+# instead of return_output if you want this to happen only when the pipe fails
+# to complete normally. You can set different transports for aliases and
+# forwards if you want to - see the references to address_pipe in the directors
+# section below.
+
+address_pipe:
+ driver = pipe
+ return_output
+
+
+# This transport is used for handling deliveries directly to files that are
+# generated by aliasing or forwarding.
+
+address_file:
+ driver = appendfile
+ delivery_date_add
+ envelope_to_add
+ return_path_add
+
+
+# This transport is used for handling autoreplies generated by the filtering
+# option of the forwardfile director.
+
+address_reply:
+ driver = autoreply
+
+
+end
+
+
+
+######################################################################
+# DIRECTORS CONFIGURATION #
+# Specifies how local addresses are handled #
+######################################################################
+# ORDER DOES MATTER #
+# A local address is passed to each in turn until it is accepted. #
+######################################################################
+
+# Local addresses are those with a domain that matches some item in the
+# "local_domains" setting above, or those which are passed back from the
+# routers because of a "self=local" setting (not used in this configuration).
+
+
+# This director handles aliasing using a traditional /etc/aliases file.
+# If any of your aliases expand to pipes or files, you will need to set
+# up a user and a group for these deliveries to run under. You can do
+# this by uncommenting the "user" option below (changing the user name
+# as appropriate) and adding a "group" option if necessary. Alternatively, you
+# can specify "user" on the transports that are used. Note that those
+# listed below are the same as are used for .forward files; you might want
+# to set up different ones for pipe and file deliveries from aliases.
+
+system_aliases:
+ driver = aliasfile
+ file = /etc/mail/aliases
+ search_type = lsearch
+# user = exim
+ file_transport = address_file
+ pipe_transport = address_pipe
+
+
+# This director handles forwarding using traditional .forward files.
+# If you want it also to allow mail filtering when a forward file
+# starts with the string "# Exim filter", uncomment the "filter" option.
+
+# The no_verify setting means that this director will be skipped when
+# verifying addresses if sender_verify or receiver_verify is set (though
+# they are not set by default). Similarly, no_expn means that this director
+# will be skipped if smtp_expn_hosts is set to allow any hosts to use the
+# EXPN command.
+
+# The check_ancestor option means that if the forward file generates an
+# address that is an ancestor of the current one, the current one gets
+# passed on instead. This covers the case where A is aliased to B and B
+# has a .forward file pointing to A.
+
+# The three transports specified at the end are those that are used when
+# forwarding generates a direct delivery to a file, or to a pipe, or sets
+# up an auto-reply, respectively.
+
+userforward:
+ driver = forwardfile
+ file = .forward
+ no_verify
+ no_expn
+ check_ancestor
+# filter
+ file_transport = address_file
+ pipe_transport = address_pipe
+ reply_transport = address_reply
+
+
+# This director matches local user mailboxes.
+
+localuser:
+ driver = localuser
+ transport = local_delivery
+
+
+end
+
+
+
+######################################################################
+# ROUTERS CONFIGURATION #
+# Specifies how remote addresses are handled #
+######################################################################
+# ORDER DOES MATTER #
+# A remote address is passed to each in turn until it is accepted. #
+######################################################################
+
+# Remote addresses are those with a domain that does not match any item
+# in the "local_domains" setting above.
+
+
+# This router routes to remote hosts over SMTP using a DNS lookup with
+# default options.
+
+lookuphost:
+ driver = lookuphost
+ transport = remote_smtp
+
+
+# This router routes to remote hosts over SMTP by explicit IP address,
+# when an email address is given in "domain literal" form, for example,
+# <user@[192.168.35.64]>. The RFCs require this facility. However, it is
+# little-known these days, and has been exploited by evil people seeking
+# to abuse SMTP relays. Consequently it is commented out in the default
+# configuration. If you uncomment this router, you also need to comment out
+# "forbid_domain_literals" above, so that Exim can recognize the syntax of
+# domain literal addresses.
+
+# domain_literal:
+# driver = ipliteral
+# transport = remote_smtp
+
+
+end
+
+
+
+######################################################################
+# RETRY CONFIGURATION #
+######################################################################
+
+# This single retry rule applies to all domains and all errors. It specifies
+# retries every 15 minutes for 2 hours, then increasing retry intervals,
+# starting at 1 hour and increasing each time by a factor of 1.5, up to 16
+# hours, then retries every 8 hours until 4 days have passed since the first
+# failed delivery.
+
+# Domain Error Retries
+# ------ ----- -------
+
+* * F,2h,15m; G,16h,1h,1.5; F,4d,8h
+
+end
+
+
+
+######################################################################
+# REWRITE CONFIGURATION #
+######################################################################
+
+# There are no rewriting specifications in this default configuration file.
+
+end
+
+
+
+######################################################################
+# AUTHENTICATION CONFIGURATION #
+######################################################################
+
+# There are no authenticator specifications in this default configuration file.
+
+# End of Exim configuration file