summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-11-14 15:57:23 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-11-14 15:57:23 +0000
commitc154f71805fce97abb61c161c3db1470c1e39868 (patch)
treeb1855dd554bf34a51cbbc5476eec01c71f5ab69f /net-mail/fetchmail/fetchmail-6.2.5.ebuild
parentfix amd64 compile (diff)
downloadgentoo-2-c154f71805fce97abb61c161c3db1470c1e39868.tar.gz
gentoo-2-c154f71805fce97abb61c161c3db1470c1e39868.tar.bz2
gentoo-2-c154f71805fce97abb61c161c3db1470c1e39868.zip
make it compile on amd64
Diffstat (limited to 'net-mail/fetchmail/fetchmail-6.2.5.ebuild')
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.5.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-mail/fetchmail/fetchmail-6.2.5.ebuild b/net-mail/fetchmail/fetchmail-6.2.5.ebuild
index b5af204c3e51..8ba6d5c48c45 100644
--- a/net-mail/fetchmail/fetchmail-6.2.5.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.2.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.5.ebuild,v 1.2 2003/11/12 18:10:36 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.5.ebuild,v 1.3 2003/11/14 15:57:19 aliz Exp $
IUSE="ssl nls ipv6 kerberos krb4"
-inherit eutils
+inherit eutils gnuconfig
DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
HOMEPAGE="http://www.catb.org/~esr/fetchmail/"
@@ -12,7 +12,7 @@ SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2 public-domain"
-KEYWORDS="~x86 -alpha"
+KEYWORDS="~x86 -alpha ~amd64"
DEPEND="virtual/glibc
ssl? ( >=dev-libs/openssl-0.9.6 )
@@ -28,6 +28,8 @@ src_unpack() {
}
src_compile() {
+ use amd64 && gnuconfig_update
+
local myconf
use ssl && myconf="${myconf} --with-ssl"