summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-06-02 08:37:22 +0000
committerTorsten Veller <tove@gentoo.org>2009-06-02 08:37:22 +0000
commit0e36ab1c5673b134bf91e1fa3851e89dad8486f2 (patch)
tree3a1036373593d759f93922fba1cd073bf67e05e1 /net-mail/getmail
parentMake xulrunner optional, now that there is a webkit backend (diff)
downloadgentoo-2-0e36ab1c5673b134bf91e1fa3851e89dad8486f2.tar.gz
gentoo-2-0e36ab1c5673b134bf91e1fa3851e89dad8486f2.tar.bz2
gentoo-2-0e36ab1c5673b134bf91e1fa3851e89dad8486f2.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-mail/getmail')
-rw-r--r--net-mail/getmail/ChangeLog9
-rw-r--r--net-mail/getmail/getmail-4.9.1.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index a04cdf07d8d1..0fd03939c94a 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.162 2009/04/07 05:30:10 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.163 2009/06/02 08:37:22 tove Exp $
+
+*getmail-4.9.1 (02 Jun 2009)
+
+ 02 Jun 2009; Torsten Veller <tove@gentoo.org> +getmail-4.9.1.ebuild:
+ Version bump
*getmail-4.9.0 (07 Apr 2009)
diff --git a/net-mail/getmail/getmail-4.9.1.ebuild b/net-mail/getmail/getmail-4.9.1.ebuild
new file mode 100644
index 000000000000..4bb68d951b15
--- /dev/null
+++ b/net-mail/getmail/getmail-4.9.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.9.1.ebuild,v 1.1 2009/06/02 08:37:22 tove Exp $
+
+inherit distutils
+
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3.3"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # getmail.spec is missing due to upstream packaging mistake
+ sed -i -e '/getmail.spec/d' setup.py || die
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv "${D}"/usr/bin/getmail "${D}"/usr/bin/getmail4
+ mv "${D}"/usr/bin/getmail_maildir "${D}"/usr/bin/getmail_maildir4
+ mv "${D}"/usr/bin/getmail_mbox "${D}"/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ rm "${D}"/usr/share/doc/${P}/COPYING
+ if [ ${P} != ${PF} ]; then
+ mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/${PF}/*.html "${D}"/usr/share/doc/${PF}/*.css "${D}"/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}