summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-10-21 23:59:50 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-10-21 23:59:50 +0000
commit369d660ce23d1dcf3a34416a03789dd397d7164f (patch)
tree299e09f320153e46be6fc97c47a1ac5ce6fc7c5f /net-mail/getmail
parentStable on Alpha + ia64. (diff)
downloadgentoo-2-369d660ce23d1dcf3a34416a03789dd397d7164f.tar.gz
gentoo-2-369d660ce23d1dcf3a34416a03789dd397d7164f.tar.bz2
gentoo-2-369d660ce23d1dcf3a34416a03789dd397d7164f.zip
Version bump.
(Portage version: 2.1.2_pre3-r2)
Diffstat (limited to 'net-mail/getmail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/files/digest-getmail-4.6.53
-rw-r--r--net-mail/getmail/getmail-4.6.5.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index c5b858143b3d..f90bc15df9db 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.132 2006/10/21 03:13:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.133 2006/10/21 23:59:50 ticho Exp $
+
+*getmail-4.6.5 (21 Oct 2006)
+
+ 21 Oct 2006; Andrej Kacian <ticho@gentoo.org> +getmail-4.6.5.ebuild:
+ Version bump.
21 Oct 2006; Aron Griffis <agriffis@gentoo.org> getmail-4.6.2.ebuild:
Mark 4.6.2 stable on alpha
diff --git a/net-mail/getmail/files/digest-getmail-4.6.5 b/net-mail/getmail/files/digest-getmail-4.6.5
new file mode 100644
index 000000000000..13b4c4608100
--- /dev/null
+++ b/net-mail/getmail/files/digest-getmail-4.6.5
@@ -0,0 +1,3 @@
+MD5 bd630fe8b4df3cba78610b46bef99f7c getmail-4.6.5.tar.gz 142473
+RMD160 d419b566fba0e17dc96bad081da0b73714ae9edb getmail-4.6.5.tar.gz 142473
+SHA256 54bbf645be2b878e41c1fa00f5f0e7efdeac39d0d125d40f719878f1db20a5d3 getmail-4.6.5.tar.gz 142473
diff --git a/net-mail/getmail/getmail-4.6.5.ebuild b/net-mail/getmail/getmail-4.6.5.ebuild
new file mode 100644
index 000000000000..8878cd656d8a
--- /dev/null
+++ b/net-mail/getmail/getmail-4.6.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.6.5.ebuild,v 1.1 2006/10/21 23:59:50 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+ mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+ mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ if [ ${P} != ${PF} ]; then
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/*.css ${D}/usr/share/doc/${PF}/html
+ gzip --silent ${D}/usr/share/doc/${PF}/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}