summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2006-12-10 17:24:59 +0000
committerTorsten Veller <tove@gentoo.org>2006-12-10 17:24:59 +0000
commit380bdcd589a1f7e7a2371dccdf9a692d21dc47b1 (patch)
tree7993fcf37f34f6c9a7d38c1e746007584b443c89 /net-mail/lbdb/lbdb-0.34.ebuild
parentfix dev-db/mytop-1.4 - wrong perl-core/Getopt-Long dependency bug #157674, th... (diff)
downloadgentoo-2-380bdcd589a1f7e7a2371dccdf9a692d21dc47b1.tar.gz
gentoo-2-380bdcd589a1f7e7a2371dccdf9a692d21dc47b1.tar.bz2
gentoo-2-380bdcd589a1f7e7a2371dccdf9a692d21dc47b1.zip
Version bump
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'net-mail/lbdb/lbdb-0.34.ebuild')
-rw-r--r--net-mail/lbdb/lbdb-0.34.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-mail/lbdb/lbdb-0.34.ebuild b/net-mail/lbdb/lbdb-0.34.ebuild
new file mode 100644
index 000000000000..0dbe01cd53df
--- /dev/null
+++ b/net-mail/lbdb/lbdb-0.34.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/lbdb-0.34.ebuild,v 1.1 2006/12/10 17:24:59 tove Exp $
+
+inherit eutils
+
+IUSE="pda ldap finger nis abook crypt evo"
+
+MY_P=${P/-/_}
+DESCRIPTION="Little Brother database"
+SRC_URI="http://www.spinnaker.de/debian/${MY_P}.tar.gz"
+HOMEPAGE="http://www.spinnaker.de/lbdb/"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+DEPEND="mail-client/mutt
+ evo? ( mail-client/evolution )
+ finger? ( net-misc/netkit-fingerd )
+ abook? ( app-misc/abook )
+ crypt? ( app-crypt/gnupg )
+ nis? ( net-nds/yp-tools )"
+RDEPEND="${DEPEND}
+ pda? ( dev-perl/p5-Palm )
+ ldap? ( dev-perl/perl-ldap )"
+
+src_compile() {
+ local evoversion
+ local evolution_addressbook_export
+
+ if useq evo ; then
+ evoversion=$(best_version mail-client/evolution)
+ evoversion=${evoversion##mail-client/evolution-}
+ evolution_addressbook_export="/usr/libexec/evolution/${evoversion:0:3}/evolution-addressbook-export"
+ fi
+
+ econf $(use_with finger) \
+ $(use_with abook) \
+ $(use_with nis ypcat) \
+ $(use_with crypt gpg) \
+ $(use_with evo evolution-addressbook-export "${evolution_addressbook_export}" ) \
+ --without-pgp5 --without-pgp \
+ --without-niscat --without-addr-email --with-getent \
+ --libdir=/usr/$(get_libdir)/lbdb || die
+ emake || die
+}
+
+src_install () {
+ emake install_prefix="${D}" install || die
+ dodoc README TODO debian/changelog
+}