summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-06-27 02:08:16 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-06-27 02:08:16 +0000
commitdda5d90f2968cad902200325b85e4a89ad4690b1 (patch)
tree7e4c5b6ee707c69f07c3de9213e634a1570ef1fc /net-mail/mailgraph/mailgraph-1.11-r1.ebuild
parentAdded missing tcsh dependency (bug #73814). (diff)
downloadgentoo-2-dda5d90f2968cad902200325b85e4a89ad4690b1.tar.gz
gentoo-2-dda5d90f2968cad902200325b85e4a89ad4690b1.tar.bz2
gentoo-2-dda5d90f2968cad902200325b85e4a89ad4690b1.zip
revision bump to get the regexp patch
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-mail/mailgraph/mailgraph-1.11-r1.ebuild')
-rw-r--r--net-mail/mailgraph/mailgraph-1.11-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-mail/mailgraph/mailgraph-1.11-r1.ebuild b/net-mail/mailgraph/mailgraph-1.11-r1.ebuild
new file mode 100644
index 000000000000..454f908fdd4d
--- /dev/null
+++ b/net-mail/mailgraph/mailgraph-1.11-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/mailgraph-1.11-r1.ebuild,v 1.1 2005/06/27 02:08:16 halcy0n Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="A mail statistics RRDtool frontend for Postfix"
+HOMEPAGE="http://people.ee.ethz.ch/~dws/software/mailgraph/"
+SRC_URI="http://people.ee.ethz.ch/~dws/software/${PN}/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/File-Tail
+ >=net-analyzer/rrdtool-1.2.2"
+DEPEND=">=sys-apps/sed-4"
+
+pkg_setup() {
+ webapp_pkg_setup
+ built_with_use net-analyzer/rrdtool perl \
+ || die "net-analyzer/rrdtool must be built with USE=perl"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s|\(my \$rrd = '\).*'|\1/var/lib/mailgraph/mailgraph.rrd'|" \
+ -e "s|\(my \$rrd_virus = '\).*'|\1/var/lib/mailgraph/mailgraph_virus.rrd'|" \
+ mailgraph.cgi || die "sed mailgraph.cgi failed"
+ epatch ${FILESDIR}/${P}-regexp.patch
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # for the RRDs
+ keepdir /var/lib/mailgraph
+
+ # mailgraph daemon
+ newbin mailgraph.pl mailgraph
+
+ # mailgraph CGI script
+ exeinto ${MY_CGIBINDIR}
+ doexe mailgraph.cgi
+
+ # init/conf files for mailgraph daemon
+ newinitd ${FILESDIR}/mailgraph.initd mailgraph
+ newconfd ${FILESDIR}/mailgraph.confd mailgraph
+
+ # docs
+ dodoc README CHANGES COPYING
+
+ webapp_src_install
+}