summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-03-20 12:00:34 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-03-20 12:00:34 +0000
commit5c89dbf85b3b475e46f6635f7cb627475b62972f (patch)
tree10123cad3bdc24f82de932f79b18f17f274f07c5 /net-mail/notmuch
parentReverted non maintainer commit that may have broken only stable release, push... (diff)
downloadgentoo-2-5c89dbf85b3b475e46f6635f7cb627475b62972f.tar.gz
gentoo-2-5c89dbf85b3b475e46f6635f7cb627475b62972f.tar.bz2
gentoo-2-5c89dbf85b3b475e46f6635f7cb627475b62972f.zip
net-mail/notmuch: Version bump to 0.12.
Notmuch 0.12 is compatible with both GMime 2.4 and 2.6, but ebuild depends only on >=2.6.7. Python bindings are compatible with Python 3.2. (Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/ChangeLog43
-rw-r--r--net-mail/notmuch/notmuch-0.12.ebuild133
2 files changed, 175 insertions, 1 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index 6a7292a19a90..603b7326c490 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,47 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.35 2012/03/20 08:23:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.36 2012/03/20 12:00:34 aidecoe Exp $
+
+*notmuch-0.12 (20 Mar 2012)
+
+ 20 Mar 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +notmuch-0.12.ebuild:
+ Version bump.
+
+ Notmuch 0.12 is compatible with both GMime 2.4 and 2.6, but ebuild depends
+ only on >=2.6.7. Python bindings are compatible with Python 3.2.
+
+ NEWS
+ ~~~~
+ (Extracted headlines from NEWS file. See it for details.)
+
+ Command-Line Interface
+ - Reply to sender (ability to create a reply template just to the sender)
+ - Mail store folder/file ignore
+ - Unified help and manual pages
+ - Manual page for notmuch configuration options
+
+ Emacs Interface
+ - Reply to sender
+ - More flexible and consistent tagging operations
+ - Refreshing the show view ('=' by default) no longer opens or closes
+ messages
+ - Attachment buttons can be used to view or save attachments.
+ - New functions
+ - Fix MML tag quoting in replies
+ - Show view archiving key binding changes
+ - Support text/calendar MIME type
+ - Generate inline patch fake attachment file names from message subject
+ - Enable `notmuch-search-line-faces' by default
+
+ Library changes
+ - New functions
+
+ Python bindings changes
+ - Python 3.2 compatibility
+ - Added missing unicode conversions
+
+ Build fixes
+ - Compatibility with GMime 2.6 (>=2.6.7)
20 Mar 2012; Agostino Sarubbo <ago@gentoo.org> notmuch-0.11.1-r2.ebuild:
Stable for amd64, wrt bug #408577
diff --git a/net-mail/notmuch/notmuch-0.12.ebuild b/net-mail/notmuch/notmuch-0.12.ebuild
new file mode 100644
index 000000000000..82fee4dad92a
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.12.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.12.ebuild,v 1.1 2012/03/20 12:00:34 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.1"
+
+inherit elisp-common distutils
+
+DESCRIPTION="The mail indexer"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="test? ( crypt emacs python )"
+IUSE="bash-completion crypt debug doc emacs nmbug python test vim
+ zsh-completion"
+
+CDEPEND="
+ >=dev-libs/glib-2.22
+ >=dev-libs/gmime-2.6.7
+ dev-libs/xapian
+ doc? ( python? ( dev-python/sphinx ) )
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ vim? ( || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 ) )
+ "
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ test? ( app-misc/dtach sys-devel/gdb )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git virtual/perl-File-Temp virtual/perl-PodParser )
+ zsh-completion? ( app-shells/zsh )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+
+bindings() {
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ $@
+ popd || die
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ default
+ bindings python distutils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="${ROOT}/usr/share/bash-completion"
+ --emacslispdir="${ROOT}/${SITELISP}/${PN}"
+ --emacsetcdir="${ROOT}/${SITEETC}/${PN}"
+ --zshcompletiondir="${ROOT}/usr/share/zsh/site-functions"
+ $(use_with bash-completion)
+ $(use_with emacs)
+ $(use_with zsh-completion)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ bindings python distutils_src_compile
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ mv html ../python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin contrib/nmbug
+ fi
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/plugin vim/syntax
+ fi
+
+ DOCS="" bindings python distutils_src_install
+
+ if use doc; then
+ bindings python dohtml -r python
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postrm
+}