summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2004-01-16 16:44:03 +0000
committerMax Kalika <max@gentoo.org>2004-01-16 16:44:03 +0000
commitaa33a0b01978c34614127f135b30f2e92e26841f (patch)
treed41a7b2f0f5dce29edd17f7d019201c4aa82d0c6 /net-mail/postfix
parentCleanup. (diff)
downloadgentoo-2-aa33a0b01978c34614127f135b30f2e92e26841f.tar.gz
gentoo-2-aa33a0b01978c34614127f135b30f2e92e26841f.tar.bz2
gentoo-2-aa33a0b01978c34614127f135b30f2e92e26841f.zip
Provide proper include path for PostgreSQL depending on which version is installed. Fixes bug #38401.
Diffstat (limited to 'net-mail/postfix')
-rw-r--r--net-mail/postfix/ChangeLog6
-rw-r--r--net-mail/postfix/postfix-2.0.16-r1.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/net-mail/postfix/ChangeLog b/net-mail/postfix/ChangeLog
index 24616b6ba504..527ab4734fbb 100644
--- a/net-mail/postfix/ChangeLog
+++ b/net-mail/postfix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/postfix
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.101 2004/01/14 20:38:12 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.102 2004/01/16 16:44:03 max Exp $
+
+ 16 Jan 2004; Max Kalika <max@gentoo.org> postfix-2.0.16-r1.ebuild:
+ Provide proper include path for PostgreSQL depending on which version is
+ installed. Fixes bug #38401.
14 Jan 2004; Max Kalika <max@gentoo.org> postfix-1.1.11.20020917-r1.ebuild,
postfix-1.1.11.20020917.ebuild, postfix-2.0.10-r1.ebuild,
diff --git a/net-mail/postfix/postfix-2.0.16-r1.ebuild b/net-mail/postfix/postfix-2.0.16-r1.ebuild
index 3878b7ccec2f..25c0c3237d4d 100644
--- a/net-mail/postfix/postfix-2.0.16-r1.ebuild
+++ b/net-mail/postfix/postfix-2.0.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.16-r1.ebuild,v 1.10 2004/01/14 20:38:12 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.16-r1.ebuild,v 1.11 2004/01/16 16:44:03 max Exp $
inherit eutils ssl-cert
@@ -109,7 +109,11 @@ src_compile() {
mylibs="${mylibs} -lmysqlclient -lm -lz"
fi
if [ "`use postgres`" ] ; then
- mycc="${mycc} -DHAS_PGSQL -I/usr/include/postgresql"
+ if [ "`best_version '=dev-db/postgresql-7.3*'`" ] ; then
+ mycc="${mycc} -DHAS_PGSQL -I/usr/include/postgresql"
+ else
+ mycc="${mycc} -DHAS_PGSQL -I/usr/include/postgresql/pgsql"
+ fi
mylibs="${mylibs} -lpq"
fi
if [ "`use ssl`" ] ; then