summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2005-08-06 21:19:05 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2005-08-06 21:19:05 +0000
commita121a204849e5ffe651bb452d34f10c11ca138d6 (patch)
tree1c6400e1ba58026ce6dc36a6244941d6c20919d6 /net-mail/qtools/qtools-0.56.ebuild
parentFixes for ccache dir on ppc-macos. (diff)
downloadgentoo-2-a121a204849e5ffe651bb452d34f10c11ca138d6.tar.gz
gentoo-2-a121a204849e5ffe651bb452d34f10c11ca138d6.tar.bz2
gentoo-2-a121a204849e5ffe651bb452d34f10c11ca138d6.zip
Added "head -1"-patch from bug 84458, set conf-cc before compiling.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-mail/qtools/qtools-0.56.ebuild')
-rw-r--r--net-mail/qtools/qtools-0.56.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-mail/qtools/qtools-0.56.ebuild b/net-mail/qtools/qtools-0.56.ebuild
index a0b11a7c9415..59063d1b78e4 100644
--- a/net-mail/qtools/qtools-0.56.ebuild
+++ b/net-mail/qtools/qtools-0.56.ebuild
@@ -1,19 +1,14 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qtools/qtools-0.56.ebuild,v 1.7 2004/07/15 02:00:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qtools/qtools-0.56.ebuild,v 1.8 2005/08/06 21:19:05 hansmi Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Several utilities for use with qmail, typically as part of .qmail command processing"
-
HOMEPAGE="http://www.superscript.com/qtools/intro.html"
-
SRC_URI="http://www.superscript.com/qtools/${P}.tar.gz"
-
LICENSE="as-is"
-
SLOT="0"
-
KEYWORDS="x86 ~mips ~hppa alpha ~ppc ~sparc"
IUSE="static"
@@ -23,10 +18,12 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-errno.patch
+ epatch ${FILESDIR}/${P}-head.patch
}
src_compile() {
use static && LDFLAGS="${LDFLAGS} -static"
+ export CC="$(tc-getCC)"
echo "${CC} ${CFLAGS}" > conf-cc
echo "${CC} ${LDFLAGS}" > conf-ld
echo "/usr" > conf-home