summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-08-11 10:10:54 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-08-11 10:10:54 +0000
commite4359733ccdadf5d787b0efa25586eab04af9b5b (patch)
treef10f0c8fdd9490c346875c09137d158e0d1b69e9 /net-mail/razor
parentSerious version bump - bug 18858 (diff)
downloadgentoo-2-e4359733ccdadf5d787b0efa25586eab04af9b5b.tar.gz
gentoo-2-e4359733ccdadf5d787b0efa25586eab04af9b5b.tar.bz2
gentoo-2-e4359733ccdadf5d787b0efa25586eab04af9b5b.zip
Serious version bump - bug 18858
Diffstat (limited to 'net-mail/razor')
-rw-r--r--net-mail/razor/ChangeLog7
-rw-r--r--net-mail/razor/Manifest4
-rw-r--r--net-mail/razor/files/digest-razor-2.361
-rw-r--r--net-mail/razor/razor-2.36.ebuild72
4 files changed, 81 insertions, 3 deletions
diff --git a/net-mail/razor/ChangeLog b/net-mail/razor/ChangeLog
index 220a393c7ce7..7c02691ae926 100644
--- a/net-mail/razor/ChangeLog
+++ b/net-mail/razor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/razor
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/ChangeLog,v 1.7 2003/02/12 08:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/ChangeLog,v 1.8 2003/08/11 10:10:46 mcummings Exp $
+
+*razor-2.36 (11 Aug 2003)
+
+ 11 Aug 2003; Michael Cummings <mcummings@gentoo.org> razor-2.36.ebuild:
+ Serious version bump - bug 18858
*razor-2.20
diff --git a/net-mail/razor/Manifest b/net-mail/razor/Manifest
index 5b35c548d5a7..8d8bf32ef6c6 100644
--- a/net-mail/razor/Manifest
+++ b/net-mail/razor/Manifest
@@ -1,9 +1,9 @@
-MD5 0c7db5930668b1a5c82bb30feb831820 ChangeLog 929
+MD5 85b0cb3f51ce59110b1ccaee69a0bc7d ChangeLog 1069
MD5 b1cdf5d490653ecd10e6fa862f6b82d8 razor-2.12.ebuild 661
MD5 3711bc99b49a9da3020a98a0531845f3 razor-2.14.ebuild 664
MD5 391b226212a3f7baf9e89d34d3032e1a razor-2.20.ebuild 2669
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
-MD5 391b226212a3f7baf9e89d34d3032e1a razor-2.36.ebuild 2669
+MD5 5704a1f685ee1ed70b906272816aaf2a razor-2.36.ebuild 2690
MD5 d0a8bbc852b9805e6d3d8538a26e890e files/digest-razor-2.12 68
MD5 1f098b2f3af4b936a9abf9b3ff35f5d9 files/digest-razor-2.14 68
MD5 e384efda6a508c06a7ce0c4b196d2fb9 files/digest-razor-2.20 68
diff --git a/net-mail/razor/files/digest-razor-2.36 b/net-mail/razor/files/digest-razor-2.36
new file mode 100644
index 000000000000..1f6263834c7d
--- /dev/null
+++ b/net-mail/razor/files/digest-razor-2.36
@@ -0,0 +1 @@
+MD5 5deaae3ea2300bf480b6904f8a69a7f1 razor-agents-2.36.tar.gz 78709
diff --git a/net-mail/razor/razor-2.36.ebuild b/net-mail/razor/razor-2.36.ebuild
new file mode 100644
index 000000000000..4cac2e8d0a41
--- /dev/null
+++ b/net-mail/razor/razor-2.36.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/razor-2.36.ebuild,v 1.1 2003/08/11 10:10:47 mcummings Exp $
+
+inherit perl-module
+
+S="${WORKDIR}/razor-agents-${PV}"
+
+DESCRIPTION="Vipul's Razor is a distributed, collaborative spam detection and filtering network"
+HOMEPAGE="http://razor.sourceforge.net"
+SRC_URI="mirror://sourceforge/razor/razor-agents-${PV}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+RDEPEND="dev-lang/perl
+ dev-perl/Net-DNS
+ dev-perl/net-ping
+ dev-perl/Time-HiRes
+ dev-perl/Digest-SHA1
+ dev-perl/URI
+ dev-perl/Digest-Nilsimsa"
+
+src_install() {
+
+ patch -p1 < ${FILESDIR}/razor_uninstall.patch
+
+ perl-module_src_install
+}
+
+pkg_postinst() {
+
+# insures appropriate symlinks have been created
+ /usr/bin/razor-client
+
+einfo "Run 'razor-admin -create' to create a default config file in your"
+einfo "home directory under /home/user/.razor. (Remember to change user to"
+einfo "your username from root before running razor-admin)"
+einfo ""
+einfo "Razor v2 requires reporters to be registered so their reputations can"
+einfo "be computed over time and they can participate in the revocation"
+einfo "mechanism. Registration is done with razor-admin -register. It has to be"
+einfo "manually invoked in either of the following ways:"
+einfo ""
+einfo "To register user foo with 's1kret' as password: "
+einfo ""
+einfo "razor-admin -register -user=foo -pass=s1kr3t"
+einfo ""
+einfo "To register with an email address and have the password assigned:"
+einfo ""
+einfo "razor-admin -register -user=foo@bar.com "
+einfo ""
+einfo "To have both (random) username and password assgined: "
+einfo ""
+einfo "razor-admin -register "
+einfo ""
+einfo "razor-admin -register negotiates a registration with the Nomination Server"
+einfo "and writes the identity information in"
+einfo "/home/user/.razor/identity-username, or /etc/razor/identity-username"
+einfo "when invoked as root."
+einfo ""
+einfo "You can edit razor-agent.conf to change the defaults. Config options"
+einfo "and their values are defined in the razor-agent.conf(5) manpage."
+
+einfo "The next step is to integrate razor-check, razor-report and"
+einfo "razor-revoke in your mail system. If you are running Razor v1, the"
+einfo "change will be transparent, new versions of razor agents will overwrite"
+einfo "the old ones. You would still need to plugin razor-revoke in your MUA,"
+einfo "since it's a new addition in Razor v2. If you are not running Razor v1,"
+einfo "refer to manpages of razor-check(1), razor-report(1), and"
+einfo "razor-revoke(1) for integration instructions."
+}