summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-22 12:32:02 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-22 12:32:02 +0000
commite408e1dca063b976a14417cd1c42308ec588a67f (patch)
tree756e87535267fe6ea8bc6a2385502ba1bf74924d /net-mail/spruce
parentFixed nls data installation added USE gpg and gnome (diff)
downloadgentoo-2-e408e1dca063b976a14417cd1c42308ec588a67f.tar.gz
gentoo-2-e408e1dca063b976a14417cd1c42308ec588a67f.tar.bz2
gentoo-2-e408e1dca063b976a14417cd1c42308ec588a67f.zip
Added USE nls
Diffstat (limited to 'net-mail/spruce')
-rw-r--r--net-mail/spruce/spruce-0.7.6.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-mail/spruce/spruce-0.7.6.ebuild b/net-mail/spruce/spruce-0.7.6.ebuild
index 5a76ad6638b9..0bc97a03cc7d 100644
--- a/net-mail/spruce/spruce-0.7.6.ebuild
+++ b/net-mail/spruce/spruce-0.7.6.ebuild
@@ -7,19 +7,25 @@ DESCRIPTION="Gtk email client"
SRC_URI="ftp://spruce.sourceforge.net/pub/spruce/devel/${P}.tar.gz"
HOMEPAGE="http://spruce.sourceforge.net/"
-DEPEND=">=x11-libs/gtk+-1.2.6
+RDEPEND=">=x11-libs/gtk+-1.2.6
gnome-base/libglade
ssl? ( >=dev-libs/openssl-0.9.6 )
gpg? ( app-crypt/gnupg )
gnome? ( gnome-base/gnome-print )"
+
+DEPEND="$RDEPEND nls? ( sys-devel/gettext )"
+
# Doesn't work? Please test =)
src_compile() {
local myopts
+ if [ -z "`use nls`" ]; then
+ myopts="--disable-nls"
+ fi
if [ "`use ssl`" ]; then
echo "SSL does not work"
- # myopts="--with-ssl"
+ # myopts="$myopts --with-ssl"
fi
if [ "`use gpg`" ] ; then
myopts="$myopts --enable-pgp"