summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-06-24 14:09:33 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-06-24 14:09:33 +0000
commit094bc2545b62adb5b5e7cc76ee22ef8e7d330085 (patch)
treebad5aba350f86f41cfbb562e02139ddae4aff406 /net-mail
parentCleaning up - 1.05 had problems in the weak ref support (diff)
downloadgentoo-2-094bc2545b62adb5b5e7cc76ee22ef8e7d330085.tar.gz
gentoo-2-094bc2545b62adb5b5e7cc76ee22ef8e7d330085.tar.bz2
gentoo-2-094bc2545b62adb5b5e7cc76ee22ef8e7d330085.zip
Version bump.
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/files/digest-getmail-4.6.33
-rw-r--r--net-mail/getmail/getmail-4.6.3.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index a3da2f698362..379f5207c093 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.126 2006/06/10 09:27:36 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.127 2006/06/24 14:09:33 ticho Exp $
+
+*getmail-4.6.3 (24 Jun 2006)
+
+ 24 Jun 2006; Andrej Kacian <ticho@gentoo.org> +getmail-4.6.3.ebuild:
+ Version bump.
10 Jun 2006; Michael Hanselmann <hansmi@gentoo.org> getmail-4.6.0.ebuild:
Stable on ppc.
diff --git a/net-mail/getmail/files/digest-getmail-4.6.3 b/net-mail/getmail/files/digest-getmail-4.6.3
new file mode 100644
index 000000000000..61605eb7fcb4
--- /dev/null
+++ b/net-mail/getmail/files/digest-getmail-4.6.3
@@ -0,0 +1,3 @@
+MD5 41d26d81d3e546161bda3530e0e836de getmail-4.6.3.tar.gz 140105
+RMD160 bfa6b27b67d456ee48f9592e24f4d214c810a1c7 getmail-4.6.3.tar.gz 140105
+SHA256 20932e4bc5183faec6389baeb662971365875f906d51e231c07af17b864357ab getmail-4.6.3.tar.gz 140105
diff --git a/net-mail/getmail/getmail-4.6.3.ebuild b/net-mail/getmail/getmail-4.6.3.ebuild
new file mode 100644
index 000000000000..e765137763bc
--- /dev/null
+++ b/net-mail/getmail/getmail-4.6.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.6.3.ebuild,v 1.1 2006/06/24 14:09:33 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+ mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+ mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ if [ ${P} != ${PF} ]; then
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/*.css ${D}/usr/share/doc/${PF}/html
+ gzip --silent ${D}/usr/share/doc/${PF}/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}