summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-07-24 20:34:31 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-07-24 20:34:31 +0000
commit21bdf6737cc7564b280f0d63d36d9946b00bbe07 (patch)
tree33681d022e43524484143cef0c3ee99e47f2e854 /net-mail
parentRemove --enable-{info,man} since these are unconditionally enabled now (bug #... (diff)
downloadgentoo-2-21bdf6737cc7564b280f0d63d36d9946b00bbe07.tar.gz
gentoo-2-21bdf6737cc7564b280f0d63d36d9946b00bbe07.tar.bz2
gentoo-2-21bdf6737cc7564b280f0d63d36d9946b00bbe07.zip
version bump (bug 153281), thanks to Target <target@targ.dyndns.org> for ebuild submission and testing; also fixing quoting and license; thanks to dertobi123 for approval for this commit
(Portage version: 2.2_rc3/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/uw-mailutils/ChangeLog12
-rw-r--r--net-mail/uw-mailutils/uw-mailutils-2007b.ebuild48
2 files changed, 58 insertions, 2 deletions
diff --git a/net-mail/uw-mailutils/ChangeLog b/net-mail/uw-mailutils/ChangeLog
index 470a51534a0a..8b46a1e7d5aa 100644
--- a/net-mail/uw-mailutils/ChangeLog
+++ b/net-mail/uw-mailutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/uw-mailutils
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/ChangeLog,v 1.14 2007/08/02 17:34:12 uberlord Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/ChangeLog,v 1.15 2008/07/24 20:34:31 hoffie Exp $
+
+*uw-mailutils-2007b (24 Jul 2008)
+
+ 24 Jul 2008; Christian Hoffmann <hoffie@gentoo.org>
+ +uw-mailutils-2007b.ebuild:
+ version bump (bug 153281), thanks to Target <target@targ.dyndns.org> for
+ ebuild submission and testing; also fixing quoting and license; thanks to
+ dertobi123 for approval for this commit
02 Aug 2007; Roy Marples <uberlord@gentoo.org> uw-mailutils-2004g.ebuild:
Fix compile on FreeBSD and add ~x86-fbsd keyword, #104760.
diff --git a/net-mail/uw-mailutils/uw-mailutils-2007b.ebuild b/net-mail/uw-mailutils/uw-mailutils-2007b.ebuild
new file mode 100644
index 000000000000..7098c42e0cc1
--- /dev/null
+++ b/net-mail/uw-mailutils/uw-mailutils-2007b.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/uw-mailutils-2007b.ebuild,v 1.1 2008/07/24 20:34:31 hoffie Exp $
+
+inherit eutils flag-o-matic
+
+MY_P="imap-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Mail utilities from the UW"
+HOMEPAGE="http://www.washington.edu/imap/"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/libc
+ !<net-mail/uw-imap-${PV}
+ !<mail-client/pine-4.64-r1"
+
+src_unpack() {
+ unpack ${A}
+ chmod -R ug+w "${S}"
+
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-2004g.patch" || die "epatch failed"
+
+ sed -i -e "s|\`cat \$C/CFLAGS\`|${CFLAGS}|g" \
+ src/mailutil/Makefile \
+ src/mtest/Makefile || die "sed failed patching Makefile CFLAGS."
+
+ append-flags -fPIC
+}
+
+src_compile() {
+ local port=slx
+ use elibc_FreeBSD && port=bsf
+ yes | make "${port}" EXTRACFLAGS="${CFLAGS}" SSLTYPE=none || die
+}
+
+src_install() {
+ into /usr
+ dobin mailutil/mailutil mtest/mtest
+ doman src/mailutil/mailutil.1
+}