summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-03-05 12:03:53 +0000
committerTorsten Veller <tove@gentoo.org>2010-03-05 12:03:53 +0000
commit2a1c5d16ab605e51abd95ae0828d295deb9afb93 (patch)
treeb85facc4a2b1905fee4a978ab76da012e8ba320d /net-mail
parentFixes load_plugin error via Moose::Meta::Class (#307869). Thanks to Jason Mills (diff)
downloadgentoo-2-2a1c5d16ab605e51abd95ae0828d295deb9afb93.tar.gz
gentoo-2-2a1c5d16ab605e51abd95ae0828d295deb9afb93.tar.bz2
gentoo-2-2a1c5d16ab605e51abd95ae0828d295deb9afb93.zip
Version bump. Thanks to Peter Gantner (#306981)
(Portage version: 2.2_rc64/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/topal/ChangeLog10
-rw-r--r--net-mail/topal/files/64-Makefile.patch3
-rw-r--r--net-mail/topal/files/72-Makefile.patch79
-rw-r--r--net-mail/topal/topal-72.ebuild41
4 files changed, 130 insertions, 3 deletions
diff --git a/net-mail/topal/ChangeLog b/net-mail/topal/ChangeLog
index e5121970198f..a4d613ac8abc 100644
--- a/net-mail/topal/ChangeLog
+++ b/net-mail/topal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/topal
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/topal/ChangeLog,v 1.4 2009/11/07 22:18:37 volkmar Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/topal/ChangeLog,v 1.5 2010/03/05 12:03:53 tove Exp $
+
+*topal-72 (05 Mar 2010)
+
+ 05 Mar 2010; Torsten Veller <tove@gentoo.org> files/64-Makefile.patch,
+ +topal-72.ebuild, +files/72-Makefile.patch:
+ Version bump. Thanks to Peter Gantner (#306981)
07 Nov 2009; Mounir Lamouri <volkmar@gentoo.org> topal-64.ebuild:
Keywording for ppc, bug 267299
diff --git a/net-mail/topal/files/64-Makefile.patch b/net-mail/topal/files/64-Makefile.patch
index 694a06539e8d..834b75b750c6 100644
--- a/net-mail/topal/files/64-Makefile.patch
+++ b/net-mail/topal/files/64-Makefile.patch
@@ -20,12 +20,13 @@ diff -Naur topal-64.orig/MIME-tool/Makefile topal-64/MIME-tool/Makefile
diff -Naur topal-64.orig/Makefile topal-64/Makefile
--- topal-64.orig/Makefile 2008-10-24 12:16:45.000000000 +0200
+++ topal-64/Makefile 2009-04-22 09:37:18.000000000 +0200
-@@ -36,26 +36,28 @@
+@@ -36,26 +36,29 @@
INSTALLPATHDOC ?= $(INSTALLPATH)/share/doc/topal
INSTALLPATHPATCHES ?= $(INSTALLPATH)/share/topal/patches
+CC=gcc
+CFLAGS=-Wall -O2
++LDFLAGS=
+
# The default action.
all: topal mime-tool README.txt
diff --git a/net-mail/topal/files/72-Makefile.patch b/net-mail/topal/files/72-Makefile.patch
new file mode 100644
index 000000000000..d517913d0863
--- /dev/null
+++ b/net-mail/topal/files/72-Makefile.patch
@@ -0,0 +1,79 @@
+diff -uraN topal-72-orig/MIME-tool/Makefile topal-72/MIME-tool/Makefile
+--- topal-72-orig/MIME-tool/Makefile 2010-02-25 21:28:39.000000000 +0100
++++ topal-72/MIME-tool/Makefile 2010-03-04 13:24:53.691055969 +0100
+@@ -1,10 +1,14 @@
+ .PHONY: all clean realclean distrib
+
++CC=gcc
++CFLAGS=-Wall -O2
++LDFLAGS=
++
++
+ all: mime-tool
+
+ mime-tool: mime.c
+- gcc -Wall -O2 -o mime-tool mime.c
+- -strip mime-tool
++ $(CC) $(CFLAGS) $(LDFLAGS) -o mime-tool mime.c
+
+ realclean: clean
+ -rm mime-tool
+diff -uraN topal-72-orig/Makefile topal-72/Makefile
+--- topal-72-orig/Makefile 2010-02-25 21:28:39.000000000 +0100
++++ topal-72/Makefile 2010-03-04 13:44:58.220101516 +0100
+@@ -15,6 +15,10 @@
+
+ .PHONY: all clean realclean distclean package install distrib all2 FORCE
+
++CC=gcc
++CFLAGS=-Wall -O2
++LDFLAGS=
++
+ RELEASECODE=$(shell grep '^<dt>' README.html | tail -1 | sed 's/.* release //; sx</a>.*$$xx')
+ BUILDDATE=$(shell date '+%Y-%m-%dT%H%M%S%Z')
+
+@@ -42,20 +46,19 @@
+ all2: package distrib
+
+ ada-readline-c.o: ada-readline-c.c
+- gcc -c -Wall -O2 $(TOPALDEBUG) ada-readline-c.c
++ $(CC) -c $(CFLAGS) $(TOPALDEBUG) ada-readline-c.c
+
+ ada-echo-c.o: ada-echo-c.c
+- gcc -c -Wall -O2 $(TOPALDEBUG) ada-echo-c.c
++ $(CC) -c $(CFLAGS) $(TOPALDEBUG) ada-echo-c.c
+
+ externals-c.o: externals-c.c
+- gcc -c -Wall -O2 $(TOPALDEBUG) externals-c.c
++ $(CC) -c $(CFLAGS) $(TOPALDEBUG) externals-c.c
+
+ mime-tool:
+- make -C MIME-tool
++ $(MAKE) -C MIME-tool
+
+ topal: $(TOPALDEPS)
+- gnatmake -gnatwa -gnato -O2 $(TOPALDEBUG) topal
+- -strip topal
++ gnatmake -gnatwa -gnato -O2 $(TOPALDEBUG) topal -largs "$(LDFLAGS)"
+
+ topal.gz: topal
+ gzip -c9 topal > topal.gz
+@@ -85,13 +88,13 @@
+ README.txt: README.html
+ lynx -dont_wrap_pre -underscore -nolist -dump README.html > README.txt
+
+-install: all
++install:
+ install -d $(INSTALLPATHBIN) $(INSTALLPATHDOC) $(INSTALLPATHMAN)/man1 $(INSTALLPATHPATCHES)
+- install -m 755 -s topal $(INSTALLPATHBIN)
+- install -m 644 README.html README.txt COPYING $(INSTALLPATHDOC)
++ install -m 755 topal $(INSTALLPATHBIN)
++ install -m 644 README.txt $(INSTALLPATHDOC)
+ install -m 644 topal.man $(INSTALLPATHMAN)/man1/topal.1
+- install -m 644 pine-*.patch alpine-*.patch alpine-*.patch-* $(INSTALLPATHPATCHES)
+- install -m 755 -s MIME-tool/mime-tool $(INSTALLPATHBIN)
++ install -m 644 alpine-*.patch alpine-*.patch-* $(INSTALLPATHPATCHES)
++ install -m 755 MIME-tool/mime-tool $(INSTALLPATHBIN)
+ install -m 644 MIME-tool/mime-tool.man $(INSTALLPATHMAN)/man1/mime-tool.1
+
+ clean:
diff --git a/net-mail/topal/topal-72.ebuild b/net-mail/topal/topal-72.ebuild
new file mode 100644
index 000000000000..43907f534571
--- /dev/null
+++ b/net-mail/topal/topal-72.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/topal/topal-72.ebuild,v 1.1 2010/03/05 12:03:53 tove Exp $
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Topal is a 'glue' program that links GnuPG and Pine/Alpine."
+HOMEPAGE="http://homepage.ntlworld.com/phil.brooke/topal/"
+SRC_URI="http://homepage.ntlworld.com/phil.brooke/topal/rel-${PV}/topal-package-${PV}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=app-crypt/gnupg-2.0.7-r1
+ || ( net-mail/metamail app-misc/run-mailcap )
+ || ( app-text/dos2unix app-text/hd2u )
+ sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ virtual/ada"
+
+src_prepare() {
+ rm "${S}"/MIME-tool/mime-tool || die
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "make failed"
+}
+
+src_install() {
+ emake install \
+ INSTALLPATH="${D}"/usr \
+ INSTALLPATHDOC="${D}"/usr/share/doc/${PF} \
+ || die "make install failed"
+ dohtml "${S}"/README.html || die
+}