summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerrya@gentoo.org>2001-12-19 07:40:39 +0000
committerJerry Alexandratos <jerrya@gentoo.org>2001-12-19 07:40:39 +0000
commit30968b60ac337a547212d5900d7160653e60b822 (patch)
tree30ef7448b32e368e0eb9458f7f271ec291e6d4c7 /net-mail
parentUpdate to the latest version. Added an ebuild for xvile. (diff)
downloadgentoo-2-30968b60ac337a547212d5900d7160653e60b822.tar.gz
gentoo-2-30968b60ac337a547212d5900d7160653e60b822.tar.bz2
gentoo-2-30968b60ac337a547212d5900d7160653e60b822.zip
Updated to latest version.
Cleaned up ebuild to new format. Moved old version to the Attic.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/maildrop/files/digest-maildrop-1.3.61
-rw-r--r--net-mail/maildrop/maildrop-1.3.6.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/maildrop/files/digest-maildrop-1.3.6 b/net-mail/maildrop/files/digest-maildrop-1.3.6
new file mode 100644
index 000000000000..fc67ba06fa93
--- /dev/null
+++ b/net-mail/maildrop/files/digest-maildrop-1.3.6
@@ -0,0 +1 @@
+MD5 e38432ab43d6a4affa3b7ae61a13f3e7 maildrop-1.3.6.tar.gz 606208
diff --git a/net-mail/maildrop/maildrop-1.3.6.ebuild b/net-mail/maildrop/maildrop-1.3.6.ebuild
new file mode 100644
index 000000000000..aec6bea35878
--- /dev/null
+++ b/net-mail/maildrop/maildrop-1.3.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry A! <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/maildrop/maildrop-1.3.6.ebuild,v 1.1 2001/12/19 07:40:39 jerrya Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Mail delivery agent/filter"
+SRC_URI="http://download.sourceforge.net/courier/${P}.tar.gz"
+
+HOMEPAGE="http://www.flounder.net/~mrsam/maildrop/index.html"
+
+DEPEND=">=sys-libs/gdbm-1.8.0
+ virtual/glibc
+ sys-devel/perl"
+
+PROVIDE="virtual/mda"
+
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-etcdir=/etc/maildrop \
+ --with-default-maildrop=./.maildir/ \
+ --disable-tempdir --enable-syslog=1 \
+ --enable-maildirquota \
+ --enable-userdb || die
+
+ make || die
+}
+
+src_install() {
+ make install prefix=${D} bindir=${D}/usr/bin \
+ mandir=${D}/usr/share/man htmldir=${D}/usr/doc/${P} || die
+
+ dodir /etc/maildrop
+}