summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Knight <tomk@gentoo.org>2004-08-07 11:15:46 +0000
committerTom Knight <tomk@gentoo.org>2004-08-07 11:15:46 +0000
commit41d86e80682d6b9acad3fd8ce976df226b8d18f1 (patch)
tree1dd1083a0fc8d49e73298616c4aa0367007e01ca /net-mail
parent~amd64 closes bug #58432 (Manifest recommit) (diff)
downloadgentoo-2-41d86e80682d6b9acad3fd8ce976df226b8d18f1.tar.gz
gentoo-2-41d86e80682d6b9acad3fd8ce976df226b8d18f1.tar.bz2
gentoo-2-41d86e80682d6b9acad3fd8ce976df226b8d18f1.zip
Added fetchmail-6.2.5-fetchsizelimit.patch to fix bug #40126
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/ChangeLog6
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.5.ebuild4
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.2.5-fetchsizelimit.patch15
3 files changed, 23 insertions, 2 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index edbc793b8e33..0236718aac96 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.51 2004/07/01 22:31:31 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.52 2004/08/07 11:15:46 tomk Exp $
+
+ 07 Aug 2004; Tom Knight <tomk@gentoo.org>
+ +files/fetchmail-6.2.5-fetchsizelimit.patch, fetchmail-6.2.5.ebuild:
+ Added fetchmail-6.2.5-fetchsizelimit.patch to fix bug #40126
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
fetchmail-5.9.14.ebuild, fetchmail-6.2.1-r1.ebuild,
diff --git a/net-mail/fetchmail/fetchmail-6.2.5.ebuild b/net-mail/fetchmail/fetchmail-6.2.5.ebuild
index e71ec97e2a73..217d1f279027 100644
--- a/net-mail/fetchmail/fetchmail-6.2.5.ebuild
+++ b/net-mail/fetchmail/fetchmail-6.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.5.ebuild,v 1.16 2004/07/15 01:47:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.5.ebuild,v 1.17 2004/08/07 11:15:46 tomk Exp $
IUSE="ssl nls ipv6 kerberos krb4"
@@ -27,6 +27,8 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PN}-6.2.0-gentoo.diff || die
epatch ${FILESDIR}/${P}-kerberos.patch
+ # patch fixes bug #40126 (tomk@gentoo.org 2004-08-07)
+ epatch ${FILESDIR}/${P}-fetchsizelimit.patch || die
}
src_compile() {
diff --git a/net-mail/fetchmail/files/fetchmail-6.2.5-fetchsizelimit.patch b/net-mail/fetchmail/files/fetchmail-6.2.5-fetchsizelimit.patch
new file mode 100644
index 000000000000..54f0042d4db4
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.2.5-fetchsizelimit.patch
@@ -0,0 +1,15 @@
+--- driver.c 2003-10-16 00:52:31 +0530
++++ driver.c 2003-10-17 11:24:27 +0530
+@@ -429,8 +429,11 @@
+ /* for POP3, we can get the size of one mail only! Unfortunately, this
+ * protocol specific test cannot be done elsewhere as the protocol
+ * could be "auto". */
+- if (ctl->server.protocol == P_POP3)
++ switch (ctl->server.protocol)
++ {
++ case P_POP3: case P_APOP: case P_RPOP:
+ fetchsizelimit = 1;
++ }
+
+ /* Time to allocate memory to store the sizes */
+ xalloca(msgsizes, int *, sizeof(int) * fetchsizelimit);