summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-06-06 19:50:05 +0000
committerEray Aslan <eras@gentoo.org>2011-06-06 19:50:05 +0000
commit545573e52f0b35cc772ed4eec2a561becce310b4 (patch)
treec794cece182368b792e4118eddb7aaf7a4e0113a /net-mail
parentUpdate live ebuild to sync latest ebuild changes, fixes bug #369027 (diff)
downloadgentoo-2-545573e52f0b35cc772ed4eec2a561becce310b4.tar.gz
gentoo-2-545573e52f0b35cc772ed4eec2a561becce310b4.tar.bz2
gentoo-2-545573e52f0b35cc772ed4eec2a561becce310b4.zip
Respect LDFLAGS - bug #336565. Remove old. EAPI bump.
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/uw-mailutils/ChangeLog6
-rw-r--r--net-mail/uw-mailutils/uw-mailutils-2007b.ebuild48
-rw-r--r--net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild16
3 files changed, 12 insertions, 58 deletions
diff --git a/net-mail/uw-mailutils/ChangeLog b/net-mail/uw-mailutils/ChangeLog
index c0c9ef45755f..c706d7eea74f 100644
--- a/net-mail/uw-mailutils/ChangeLog
+++ b/net-mail/uw-mailutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/uw-mailutils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/ChangeLog,v 1.31 2011/05/06 21:00:09 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/ChangeLog,v 1.32 2011/06/06 19:50:05 eras Exp $
+
+ 06 Jun 2011; Eray Aslan <eras@gentoo.org> -uw-mailutils-2007b.ebuild,
+ uw-mailutils-2007e-r1.ebuild:
+ Respect LDFLAGS - bug #336565. Remove old. EAPI bump.
*uw-mailutils-2007e-r1 (06 May 2011)
diff --git a/net-mail/uw-mailutils/uw-mailutils-2007b.ebuild b/net-mail/uw-mailutils/uw-mailutils-2007b.ebuild
deleted file mode 100644
index 629b83102196..000000000000
--- a/net-mail/uw-mailutils/uw-mailutils-2007b.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/uw-mailutils-2007b.ebuild,v 1.9 2009/09/23 19:15:01 patrick Exp $
-
-inherit eutils flag-o-matic
-
-MY_P="imap-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Mail utilities from the UW"
-HOMEPAGE="http://www.washington.edu/imap/"
-SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="!<mail-client/pine-4.64-r1"
-RDEPEND="${DEPEND}
- !<net-mail/uw-imap-${PV}"
-
-src_unpack() {
- unpack ${A}
- chmod -R ug+w "${S}"
-
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-2004g.patch" || die "epatch failed"
-
- sed -i -e "s|\`cat \$C/CFLAGS\`|${CFLAGS}|g" \
- src/mailutil/Makefile \
- src/mtest/Makefile || die "sed failed patching Makefile CFLAGS."
-
- append-flags -fPIC
-}
-
-src_compile() {
- local port=slx
- use elibc_FreeBSD && port=bsf
- yes | make "${port}" EXTRACFLAGS="${CFLAGS}" SSLTYPE=none || die
-}
-
-src_install() {
- into /usr
- dobin mailutil/mailutil mtest/mtest
- doman src/mailutil/mailutil.1
-}
diff --git a/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild b/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild
index 9976006ced2a..755a3643e126 100644
--- a/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild
+++ b/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild,v 1.1 2011/05/06 21:00:09 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild,v 1.2 2011/06/06 19:50:05 eras Exp $
+
+EAPI=4
inherit eutils flag-o-matic
@@ -22,14 +24,11 @@ DEPEND="!<mail-client/pine-4.64-r1
RDEPEND="${DEPEND}
!<net-mail/uw-imap-${PV}"
-src_unpack() {
- unpack ${A}
+src_prepare() {
chmod -R ug+w "${S}"
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-2004g.patch" || die "epatch failed"
- epatch "${FILESDIR}/${PN}-ssl.patch" || die "epatch failed"
+ epatch "${FILESDIR}/${PN}-2004g.patch"
+ epatch "${FILESDIR}/${PN}-ssl.patch"
sed -i -e "s|\`cat \$C/CFLAGS\`|${CFLAGS}|g" \
src/mailutil/Makefile \
@@ -44,11 +43,10 @@ src_compile() {
use pam && port=lnp
local ssltype=none
use ssl && ssltype=nopwd
- yes | make "${port}" EXTRACFLAGS="${CFLAGS}" SSLTYPE="${ssltype}" || die
+ emake -j1 "${port}" EXTRACFLAGS="${CFLAGS}" EXTRALDFLAGS="${LDFLAGS}" SSLTYPE="${ssltype}"
}
src_install() {
- into /usr
dobin mailutil/mailutil mtest/mtest
doman src/mailutil/mailutil.1
}