summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2009-02-13 14:10:35 +0000
committerWolfram Schlich <wschlich@gentoo.org>2009-02-13 14:10:35 +0000
commit8d9a2d3026db050a5668ab33d9299c5ee73bc8a1 (patch)
tree88e543991d2f7542e6766f596e842a8599934e12 /net-mail
parentVersion bumps (diff)
downloadgentoo-2-8d9a2d3026db050a5668ab33d9299c5ee73bc8a1.tar.gz
gentoo-2-8d9a2d3026db050a5668ab33d9299c5ee73bc8a1.tar.bz2
gentoo-2-8d9a2d3026db050a5668ab33d9299c5ee73bc8a1.zip
added upstream patches
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog12
-rw-r--r--net-mail/dovecot/dovecot-1.1.11-r1.ebuild (renamed from net-mail/dovecot/dovecot-1.1.11.ebuild)6
-rw-r--r--net-mail/dovecot/files/dovecot-1.1.11-11112baa8592.patch31
-rw-r--r--net-mail/dovecot/files/dovecot-1.1.11-4736327a8740.patch20
-rw-r--r--net-mail/dovecot/files/dovecot-1.1.11-bdc5391e52df.patch49
-rw-r--r--net-mail/dovecot/files/dovecot-1.1.11-c08c602ca0dc.patch26
6 files changed, 142 insertions, 2 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index 17c0b7a9d3af..eafb71802d62 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-mail/dovecot
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.199 2009/02/07 15:35:47 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.200 2009/02/13 14:10:35 wschlich Exp $
+
+*dovecot-1.1.11-r1 (13 Feb 2009)
+
+ 13 Feb 2009; Wolfram Schlich <wschlich@gentoo.org>
+ +files/dovecot-1.1.11-11112baa8592.patch,
+ +files/dovecot-1.1.11-4736327a8740.patch,
+ +files/dovecot-1.1.11-bdc5391e52df.patch,
+ +files/dovecot-1.1.11-c08c602ca0dc.patch, -dovecot-1.1.11.ebuild,
+ +dovecot-1.1.11-r1.ebuild:
+ added upstream patches
*dovecot-1.1.11 (05 Feb 2009)
diff --git a/net-mail/dovecot/dovecot-1.1.11.ebuild b/net-mail/dovecot/dovecot-1.1.11-r1.ebuild
index f1306b735082..3abe996d473d 100644
--- a/net-mail/dovecot/dovecot-1.1.11.ebuild
+++ b/net-mail/dovecot/dovecot-1.1.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.1.11.ebuild,v 1.1 2009/02/07 15:35:47 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.1.11-r1.ebuild,v 1.1 2009/02/13 14:10:35 wschlich Exp $
inherit autotools eutils ssl-cert versionator
@@ -52,6 +52,10 @@ src_unpack() {
epatch "${WORKDIR}"/${MY_P}-${MANAGESIEVE_PATCH}.diff
eautoreconf
fi
+ epatch "${FILESDIR}"/${P}-4736327a8740.patch
+ epatch "${FILESDIR}"/${P}-11112baa8592.patch
+ epatch "${FILESDIR}"/${P}-bdc5391e52df.patch
+ epatch "${FILESDIR}"/${P}-c08c602ca0dc.patch
}
pkg_setup() {
diff --git a/net-mail/dovecot/files/dovecot-1.1.11-11112baa8592.patch b/net-mail/dovecot/files/dovecot-1.1.11-11112baa8592.patch
new file mode 100644
index 000000000000..cd7c72a32c98
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.1.11-11112baa8592.patch
@@ -0,0 +1,31 @@
+
+# HG changeset patch
+# User Timo Sirainen <tss@iki.fi>
+# Date 1233768235 18000
+# Node ID 11112baa8592f5be016ea748ff4601c7b3c1e3b9
+# Parent eb9c1c78e91950557d4c9fd525b5dcc7a56cb23c
+auth_debug_passwords=yes: Log password for PAM lookups.
+
+--- a/src/auth/passdb-pam.c Tue Feb 03 18:44:31 2009 -0500
++++ b/src/auth/passdb-pam.c Wed Feb 04 12:23:55 2009 -0500
+@@ -175,11 +175,15 @@ static int try_pam_auth(struct auth_requ
+ /* log this as error, since it probably is */
+ str = t_strdup_printf("%s (%s missing?)", str, path);
+ auth_request_log_error(request, "pam", "%s", str);
++ } else if (status == PAM_AUTH_ERR) {
++ str = t_strconcat(str, " (password mismatch?)", NULL);
++ if (request->auth->verbose_debug_passwords) {
++ str = t_strconcat(str, " (given password: ",
++ request->mech_password,
++ ")", NULL);
++ }
++ auth_request_log_info(request, "pam", "%s", str);
+ } else {
+- if (status == PAM_AUTH_ERR) {
+- str = t_strconcat(str, " (password mismatch?)",
+- NULL);
+- }
+ auth_request_log_info(request, "pam", "%s", str);
+ }
+ return status;
+
diff --git a/net-mail/dovecot/files/dovecot-1.1.11-4736327a8740.patch b/net-mail/dovecot/files/dovecot-1.1.11-4736327a8740.patch
new file mode 100644
index 000000000000..7f0418e682e1
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.1.11-4736327a8740.patch
@@ -0,0 +1,20 @@
+
+# HG changeset patch
+# User Timo Sirainen <tss@iki.fi>
+# Date 1233868321 18000
+# Node ID 4736327a8740579e7c89a8b386de9af0266b07fa
+# Parent 7d175e4ea57d21162abbf43a61c5305cfe1995b3
+Maildir: Fix to earlier >26 keywords handling change.
+
+--- a/src/lib-storage/index/maildir/maildir-sync-index.c Wed Feb 04 17:44:01 2009 -0500
++++ b/src/lib-storage/index/maildir/maildir-sync-index.c Thu Feb 05 16:12:01 2009 -0500
+@@ -336,7 +336,7 @@ maildir_sync_mail_keywords(struct maildi
+ ones. we can get these lists easily by removing common elements
+ from old and new keywords. */
+ new_indexes = array_get_modifiable(&ctx->keywords, &new_count);
+- for (i = 0; i < old_count && j < new_count; ) {
++ for (i = j = 0; i < old_count && j < new_count; ) {
+ diff = (int)old_indexes[i] - (int)new_indexes[j];
+ if (diff == 0) {
+ array_delete(&ctx->keywords, j, 1);
+
diff --git a/net-mail/dovecot/files/dovecot-1.1.11-bdc5391e52df.patch b/net-mail/dovecot/files/dovecot-1.1.11-bdc5391e52df.patch
new file mode 100644
index 000000000000..ac1dc25989c1
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.1.11-bdc5391e52df.patch
@@ -0,0 +1,49 @@
+
+# HG changeset patch
+# User Timo Sirainen <tss@iki.fi>
+# Date 1234226629 18000
+# Node ID bdc5391e52dfe4590e9e291eba2603ed87caef57
+# Parent 4ddf36b9ee8182f10d8d69af6577b677cda282a0
+master: Don't crash if auth process dies too early.
+
+--- a/src/master/auth-process.c Thu Feb 05 18:29:06 2009 -0500
++++ b/src/master/auth-process.c Mon Feb 09 19:43:49 2009 -0500
+@@ -353,7 +353,7 @@ static void auth_process_destroy(struct
+
+ if (!p->initialized && io_loop_is_running(ioloop) && !p->external) {
+ /* log the process exit and kill ourself */
+- child_processes_deinit();
++ child_processes_flush();
+ log_deinit();
+ i_fatal("Auth process died too early - shutting down");
+ }
+--- a/src/master/child-process.c Thu Feb 05 18:29:06 2009 -0500
++++ b/src/master/child-process.c Mon Feb 09 19:43:49 2009 -0500
+@@ -219,10 +219,15 @@ void child_processes_init(void)
+ lib_signals_set_handler(SIGCHLD, TRUE, sigchld_handler, NULL);
+ }
+
+-void child_processes_deinit(void)
++void child_processes_flush(void)
+ {
+ /* make sure we log if child processes died unexpectedly */
+ sigchld_handler(SIGCHLD, NULL);
++}
++
++void child_processes_deinit(void)
++{
++ child_processes_flush();
+ lib_signals_unset_handler(SIGCHLD, sigchld_handler, NULL);
+ hash_destroy(&processes);
+ }
+--- a/src/master/child-process.h Thu Feb 05 18:29:06 2009 -0500
++++ b/src/master/child-process.h Mon Feb 09 19:43:49 2009 -0500
+@@ -40,6 +40,7 @@ void child_process_set_destroy_callback(
+ child_process_destroy_callback_t *cb);
+
+ void child_processes_init(void);
++void child_processes_flush(void);
+ void child_processes_deinit(void);
+
+ #endif
+
diff --git a/net-mail/dovecot/files/dovecot-1.1.11-c08c602ca0dc.patch b/net-mail/dovecot/files/dovecot-1.1.11-c08c602ca0dc.patch
new file mode 100644
index 000000000000..17ce27051548
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.1.11-c08c602ca0dc.patch
@@ -0,0 +1,26 @@
+
+# HG changeset patch
+# User Timo Sirainen <tss@iki.fi>
+# Date 1234481874 18000
+# Node ID c08c602ca0dcbc137a4ca965b3722953cabfa4fc
+# Parent 4044df5a4d12fef4086d7e604444467eb105f348
+"Maildir filename has wrong W value" error was missing new/cur directory in the middle.
+
+--- a/src/lib-storage/index/maildir/maildir-mail.c Tue Feb 10 12:19:05 2009 -0500
++++ b/src/lib-storage/index/maildir/maildir-mail.c Thu Feb 12 18:37:54 2009 -0500
+@@ -485,8 +485,12 @@ static void maildir_mail_set_cache_corru
+ _mail->uid, &flags);
+ if (maildir_filename_get_size(fname, MAILDIR_EXTRA_VIRTUAL_SIZE,
+ &size)) {
+- i_error("Maildir filename has wrong W value: %s/%s",
+- mbox->path, fname);
++ const char *subdir =
++ (flags & MAILDIR_UIDLIST_REC_FLAG_NEW_DIR) != 0 ?
++ "new" : "cur";
++ mail_storage_set_critical(_mail->box->storage,
++ "Maildir filename has wrong W value: %s/%s/%s",
++ mbox->path, subdir, fname);
+ } else if (maildir_uidlist_lookup_ext(mbox->uidlist, _mail->uid,
+ MAILDIR_UIDLIST_REC_EXT_VSIZE) != NULL) {
+ maildir_uidlist_set_ext(mbox->uidlist, _mail->uid,
+