summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-21 16:27:10 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-21 16:27:10 +0000
commitaa89f29d13ab5a9cb352c40c8ae6d4f3e9861021 (patch)
tree3396f42d380b68286892f036e1705af3f72183a6 /net-mail
parentbootstrap use var (diff)
downloadgentoo-2-aa89f29d13ab5a9cb352c40c8ae6d4f3e9861021.tar.gz
gentoo-2-aa89f29d13ab5a9cb352c40c8ae6d4f3e9861021.tar.bz2
gentoo-2-aa89f29d13ab5a9cb352c40c8ae6d4f3e9861021.zip
Version upgrade
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mutt/ChangeLog14
-rw-r--r--net-mail/mutt/files/digest-mutt-1.3.281
-rw-r--r--net-mail/mutt/mutt-1.3.28.ebuild45
3 files changed, 59 insertions, 1 deletions
diff --git a/net-mail/mutt/ChangeLog b/net-mail/mutt/ChangeLog
index e2f1c704e4a2..dca8d8f30a30 100644
--- a/net-mail/mutt/ChangeLog
+++ b/net-mail/mutt/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-mail/mutt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.1 2002/02/01 21:53:34 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.2 2002/03/21 16:27:10 seemant Exp $
+
+*mutt-1.3.28 (21 Mar 2002)
+
+ 21 Mar 2002; Seemant Kulleen <seemant@gentoo.org> mutt-1.3.28.ebuild :
+
+ Version upgrade to release candidate version. Copied over the .25 ebuild.
+
+*mutt-1.3.25 (21 Mar 2002)
+
+ 21 Mar 2002; Seemant Kulleen <seemant@gentoo.org> mutt-1.3.25.ebuild :
+
+ HTML documentation need not be gzipped.
*mutt-1.3.25 (1 Feb 2002)
diff --git a/net-mail/mutt/files/digest-mutt-1.3.28 b/net-mail/mutt/files/digest-mutt-1.3.28
new file mode 100644
index 000000000000..f6aa8f4cd3d3
--- /dev/null
+++ b/net-mail/mutt/files/digest-mutt-1.3.28
@@ -0,0 +1 @@
+MD5 eba9bd09853ff7e441712e2d10d8632b mutt-1.3.28i.tar.gz 2546513
diff --git a/net-mail/mutt/mutt-1.3.28.ebuild b/net-mail/mutt/mutt-1.3.28.ebuild
new file mode 100644
index 000000000000..5e4bd7963929
--- /dev/null
+++ b/net-mail/mutt/mutt-1.3.28.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Server Team <server@gentoo.org>
+# Maintainers: Daniel Robbins <drobbins@gentoo.org>, Aron Griffis <agriffis@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/net-mail/mutt/mutt-1.3.22.1.ebuild,v 1.1 2001/09/26 12:06:29 agriffis Exp
+
+S=$WORKDIR/$P
+DESCRIPTION="a small but very powerful text-based mail client"
+SRC_URI="ftp://ftp.mutt.org/pub/mutt/mutt-${PV}i.tar.gz"
+HOMEPAGE="http://www.mutt.org"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.2
+ slang? ( >=sys-libs/slang-1.4.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+ local myconf
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+ use ssl && myconf="$myconf --with-ssl" \
+ || myconf="$myconf --without-ssl"
+ # --without-slang doesn't work;
+ # specify --with-curses if you don't want slang
+ # (26 Sep 2001 agriffis)
+ use slang && myconf="$myconf --with-slang" \
+ || myconf="$myconf --with-curses"
+ ./configure --host=$CHOST \
+ --prefix=/usr --sysconfdir=/etc/mutt \
+ --mandir=/usr/share/man --with-docdir=/usr/share/doc/mutt-$PVR \
+ --with-regex --enable-pop --enable-imap --enable-nfs-fix \
+ --with-homespool=Maildir $myconf
+ assert "./configure failed (myconf=$myconf)"
+ cp doc/Makefile doc/Makefile.orig
+ sed 's/README.UPGRADE//' doc/Makefile.orig > doc/Makefile
+ make || die "make failed (myconf=$myconf)"
+}
+
+src_install () {
+ make DESTDIR=$D install || die
+ find $D/usr/share/doc -type f |grep -v html | xargs gzip
+ insinto /etc/mutt
+ doins $FILESDIR/Muttrc
+}