summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-04-13 10:31:42 +0000
committerThilo Bangert <bangert@gentoo.org>2010-04-13 10:31:42 +0000
commitb22b6108f12fe659ae306cabd454f4f4c19e9b0b (patch)
tree43f79c2990706018a87e99fa337399d527c9d7c1 /net-mail
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-b22b6108f12fe659ae306cabd454f4f4c19e9b0b.tar.gz
gentoo-2-b22b6108f12fe659ae306cabd454f4f4c19e9b0b.tar.bz2
gentoo-2-b22b6108f12fe659ae306cabd454f4f4c19e9b0b.zip
version bump - fix install location of header files
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailfront/ChangeLog7
-rw-r--r--net-mail/mailfront/mailfront-1.16.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-mail/mailfront/ChangeLog b/net-mail/mailfront/ChangeLog
index ae3932843400..3e86e59d5ae6 100644
--- a/net-mail/mailfront/ChangeLog
+++ b/net-mail/mailfront/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mailfront
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/ChangeLog,v 1.26 2010/02/12 09:52:13 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/ChangeLog,v 1.27 2010/04/13 10:31:42 bangert Exp $
+
+*mailfront-1.16 (13 Apr 2010)
+
+ 13 Apr 2010; Thilo Bangert <bangert@gentoo.org> +mailfront-1.16.ebuild:
+ version bump - fix install location of header files
*mailfront-1.12 (12 Feb 2010)
diff --git a/net-mail/mailfront/mailfront-1.16.ebuild b/net-mail/mailfront/mailfront-1.16.ebuild
new file mode 100644
index 000000000000..3439220c08b9
--- /dev/null
+++ b/net-mail/mailfront/mailfront-1.16.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-1.16.ebuild,v 1.1 2010/04/13 10:31:42 bangert Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Mail server network protocol front-ends"
+HOMEPAGE="http://untroubled.org/mailfront/"
+SRC_URI="http://untroubled.org/mailfront/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/bglibs-1.106
+ >=net-libs/cvm-0.81"
+
+RDEPEND="${DEPEND}
+ virtual/qmail
+ net-libs/cvm"
+
+src_configure() {
+ echo "/usr/include/bglibs/" > conf-bgincs
+ echo "/usr/$(get_libdir)/bglibs/" > conf-bglibs
+ echo "/var/qmail" > conf-qmail
+ echo "/var/qmail/bin" > conf-bin
+ echo "/usr/$(get_libdir)/mailfront" > conf-modules
+ echo "/usr/include" > conf-include
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${CFLAGS} -fPIC -shared" > conf-ccso
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ #dodir /var/qmail/bin
+ emake install install_prefix="${D}" || die "install failed"
+ exeinto /var/qmail/supervise/qmail-smtpd
+ newexe "${FILESDIR}"/run-smtpfront run.mailfront
+ exeinto /var/qmail/supervise/qmail-pop3d
+ newexe "${FILESDIR}"/run-pop3front run.mailfront
+
+ dodoc ANNOUNCEMENT ChangeLog NEWS README VERSION
+ dohtml *.html
+}
+
+pkg_config() {
+ cd "${ROOT}"/var/qmail/supervise/qmail-smtpd/
+ cp run run.qmail-smtpd.`date +%Y%m%d%H%M%S` && cp run.mailfront run
+ cd "${ROOT}"/var/qmail/supervise/qmail-pop3d/
+ cp run run.qmail-pop3d.`date +%Y%m%d%H%M%S` && cp run.mailfront run
+}
+
+pkg_postinst() {
+ echo
+ elog "Run"
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog "to update your run files (backups are created) in"
+ elog " /var/qmail/supervise/qmail-pop3d and"
+ elog " /var/qmail/supervise/qmail-smtpd"
+ echo
+}