summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-02-21 20:39:05 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-02-21 20:39:05 +0000
commitc3e9e0f28e1bb1e3be61eea5e43fdf5993dd9b90 (patch)
tree390551824ad6b8f817dbe7eb7adbe53112de4513 /net-mail
parentPax mark m main binary wrt bug 365359 by Nikoli <nikoli@lavabit.com> (diff)
downloadgentoo-2-c3e9e0f28e1bb1e3be61eea5e43fdf5993dd9b90.tar.gz
gentoo-2-c3e9e0f28e1bb1e3be61eea5e43fdf5993dd9b90.tar.bz2
gentoo-2-c3e9e0f28e1bb1e3be61eea5e43fdf5993dd9b90.zip
net-mail/notmuch-0.11.1: Added 'nmbug' USE flag. Revbump to -r1.
(Portage version: 2.1.10.47/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog8
-rw-r--r--net-mail/notmuch/metadata.xml3
-rw-r--r--net-mail/notmuch/notmuch-0.11.1-r1.ebuild159
3 files changed, 169 insertions, 1 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index a483dc9a04db..65a144fbfcaa 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.22 2012/02/15 12:45:19 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.23 2012/02/21 20:39:05 aidecoe Exp $
+
+*notmuch-0.11.1-r1 (21 Feb 2012)
+
+ 21 Feb 2012; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +notmuch-0.11.1-r1.ebuild, metadata.xml:
+ Added 'nmbug' USE flag.
*notmuch-0.11.1 (15 Feb 2012)
diff --git a/net-mail/notmuch/metadata.xml b/net-mail/notmuch/metadata.xml
index fd29f9393040..f6acb7d04b1b 100644
--- a/net-mail/notmuch/metadata.xml
+++ b/net-mail/notmuch/metadata.xml
@@ -10,6 +10,9 @@
<flag name="crypt">Support decryption and verification of PGP/MIME
messages and in Emacs UI - encryption</flag>
<flag name="emacs">Install Notmuch client for Emacs (main client)</flag>
+ <flag name="nmbug">Install Experimental Tag Sharing /
+ Pseudo-Bug-Tracking for Notmuch
+ (http://notmuchmail.org/nmbug/)</flag>
<flag name="vim">Install Notmuch client for Vim (experimental)</flag>
</use>
<longdescription lang="en">
diff --git a/net-mail/notmuch/notmuch-0.11.1-r1.ebuild b/net-mail/notmuch/notmuch-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..2189e85067c0
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.11.1-r1.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.11.1-r1.ebuild,v 1.1 2012/02/21 20:39:05 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.*"
+RUBY="/usr/bin/ruby18"
+RDOC="/usr/bin/rdoc18"
+
+inherit elisp-common distutils
+
+DESCRIPTION="The mail indexer"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="test? ( crypt emacs )"
+IUSE="bash-completion crypt debug doc emacs nmbug python ruby test vim
+ zsh-completion"
+
+CDEPEND="
+ >=dev-libs/glib-2.14
+ dev-libs/gmime:2.4
+ dev-libs/xapian
+ doc? ( python? ( dev-python/sphinx ) )
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ ruby? ( dev-lang/ruby:1.8 )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ vim? ( || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 ) )
+ "
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ test? ( app-misc/dtach sys-devel/gdb )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git virtual/perl-File-Temp virtual/perl-PodParser )
+ zsh-completion? ( app-shells/zsh )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+
+bindings() {
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ $@
+ popd || die
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ default
+ bindings python distutils_src_prepare
+
+ r_fix() {
+ local pattern="\(find_library('notmuch', '[^']*', '\)\([^']*\)\(')\)"
+ local replace="\1${WORKDIR}/${PF}_build/lib\3"
+
+ sed -i "s|$pattern|$replace|" extconf.rb || die
+ }
+ bindings ruby r_fix
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="${ROOT}/usr/share/bash-completion"
+ --emacslispdir="${ROOT}/${SITELISP}/${PN}"
+ --emacsetcdir="${ROOT}/${SITEETC}/${PN}"
+ --zshcompletiondir="${ROOT}/usr/share/zsh/site-functions"
+ $(use_with bash-completion)
+ $(use_with emacs)
+ $(use_with zsh-completion)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ bindings python distutils_src_compile
+
+ r_make() {
+ ${RUBY} extconf.rb || die
+ emake
+ }
+ bindings ruby r_make
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ mv html ../python || die
+ popd || die
+ }
+
+ rdocs() {
+ ${RDOC} --main 'Notmuch' --title 'Notmuch Ruby API' --op ruby *.c
+ }
+
+ LD_LIBRARY_PATH="${WORKDIR}/${PF}_build/lib" bindings python pydocs
+ bindings ruby rdocs
+ fi
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin contrib/nmbug
+ fi
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/plugin vim/syntax
+ fi
+
+ DOCS="" bindings python distutils_src_install
+ bindings ruby emake DESTDIR="'${D}'" install
+
+ if use doc; then
+ bindings python dohtml -r python
+ bindings ruby dohtml -r ruby
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postinst
+
+ if use python; then
+ echo
+ elog "Python API documentation is also available online at:"
+ elog " http://packages.python.org/notmuch/"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use python && distutils_pkg_postrm
+}