summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-02-05 21:13:39 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-02-05 21:13:39 +0000
commit5a06abe26a134a4f16a5a81a01cd07721f3bd3f9 (patch)
tree67a0c9b646ff2ec70f1c35464302bf6e27965360 /net-misc/aria2
parentAllow freebsd-usbin as traceroute provider (diff)
downloadgentoo-2-5a06abe26a134a4f16a5a81a01cd07721f3bd3f9.tar.gz
gentoo-2-5a06abe26a134a4f16a5a81a01cd07721f3bd3f9.tar.bz2
gentoo-2-5a06abe26a134a4f16a5a81a01cd07721f3bd3f9.zip
Version bump.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/aria2')
-rw-r--r--net-misc/aria2/ChangeLog11
-rw-r--r--net-misc/aria2/aria2-1.1.2.ebuild (renamed from net-misc/aria2/aria2-1.0.0.ebuild)13
-rw-r--r--net-misc/aria2/files/1.1.2-testRetrieveCookie-testfix.patch13
3 files changed, 27 insertions, 10 deletions
diff --git a/net-misc/aria2/ChangeLog b/net-misc/aria2/ChangeLog
index 7bbb2c3dd56b..93f019385907 100644
--- a/net-misc/aria2/ChangeLog
+++ b/net-misc/aria2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/aria2
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.37 2008/12/02 13:54:13 dev-zero Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/ChangeLog,v 1.38 2009/02/05 21:13:39 dev-zero Exp $
+
+*aria2-1.1.2 (05 Feb 2009)
+
+ 05 Feb 2009; Tiziano Müller <dev-zero@gentoo.org>
+ +files/1.1.2-testRetrieveCookie-testfix.patch, -aria2-1.0.0.ebuild,
+ +aria2-1.1.2.ebuild:
+ Version bump.
*aria2-1.0.1 (02 Dec 2008)
diff --git a/net-misc/aria2/aria2-1.0.0.ebuild b/net-misc/aria2/aria2-1.1.2.ebuild
index bc117982459f..18e148754cbb 100644
--- a/net-misc/aria2/aria2-1.0.0.ebuild
+++ b/net-misc/aria2/aria2-1.1.2.ebuild
@@ -1,16 +1,14 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.0.0.ebuild,v 1.2 2008/12/31 03:40:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aria2/aria2-1.1.2.ebuild,v 1.1 2009/02/05 21:13:39 dev-zero Exp $
EAPI="2"
inherit eutils
-MY_P="aria2c-${PV/_p/+}"
-
DESCRIPTION="A download utility with resuming and segmented downloading with HTTP/HTTPS/FTP/BitTorrent support."
HOMEPAGE="http://aria2.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
SLOT="0"
@@ -35,9 +33,8 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
nls? ( virtual/libiconv virtual/libintl )"
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
+ epatch "${FILESDIR}/${PV}-testRetrieveCookie-testfix.patch"
sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
}
@@ -71,6 +68,6 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
rm -rf "${D}/usr/share/doc/aria2c"
- dodoc ChangeLog README AUTHORS TODO NEWS
+ dodoc ChangeLog README AUTHORS NEWS
dohtml README.html doc/aria2c.1.html
}
diff --git a/net-misc/aria2/files/1.1.2-testRetrieveCookie-testfix.patch b/net-misc/aria2/files/1.1.2-testRetrieveCookie-testfix.patch
new file mode 100644
index 000000000000..154aad7488af
--- /dev/null
+++ b/net-misc/aria2/files/1.1.2-testRetrieveCookie-testfix.patch
@@ -0,0 +1,13 @@
+Index: test/HttpResponseTest.cc
+===================================================================
+--- test/HttpResponseTest.cc (revision 957)
++++ test/HttpResponseTest.cc (revision 958)
+@@ -479,7 +479,7 @@
+
+ httpHeader->put("Set-Cookie", "k1=v1; expires=Sun, 10-Jun-2007 11:00:00 GMT;"
+ "path=/; domain=.aria2.org;");
+- httpHeader->put("Set-Cookie", "k2=v2; expires=Sun, 01-Jan-09 00:00:00 GMT;"
++ httpHeader->put("Set-Cookie", "k2=v2; expires=Sun, 01-Jan-38 00:00:00 GMT;"
+ "path=/; domain=.aria2.org;");
+ httpHeader->put("Set-Cookie", "k3=v3;");
+