summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2006-03-02 00:24:07 +0000
committerStefan Knoblich <stkn@gentoo.org>2006-03-02 00:24:07 +0000
commit8d75c57efde9cef7d2c55ac2d6ca51b9d3012e9f (patch)
treef3918f7df374d92c6070c0ad8fe4ce93d6b00fa8 /net-misc/asterisk-app_rtxfax
parentcorrecting bug #118123 (diff)
downloadgentoo-2-8d75c57efde9cef7d2c55ac2d6ca51b9d3012e9f.tar.gz
gentoo-2-8d75c57efde9cef7d2c55ac2d6ca51b9d3012e9f.tar.bz2
gentoo-2-8d75c57efde9cef7d2c55ac2d6ca51b9d3012e9f.zip
Version bump, copied from gentoo-voip overlay.
(Portage version: 2.0.53)
Diffstat (limited to 'net-misc/asterisk-app_rtxfax')
-rw-r--r--net-misc/asterisk-app_rtxfax/ChangeLog11
-rw-r--r--net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre25.ebuild43
-rw-r--r--net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre25-gentoo.diff78
-rw-r--r--net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre253
4 files changed, 133 insertions, 2 deletions
diff --git a/net-misc/asterisk-app_rtxfax/ChangeLog b/net-misc/asterisk-app_rtxfax/ChangeLog
index b9ab02e610dd..d240c23ccc77 100644
--- a/net-misc/asterisk-app_rtxfax/ChangeLog
+++ b/net-misc/asterisk-app_rtxfax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/asterisk-app_rtxfax
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_rtxfax/ChangeLog,v 1.5 2005/09/08 00:41:30 stkn Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_rtxfax/ChangeLog,v 1.6 2006/03/02 00:24:07 stkn Exp $
+
+*asterisk-app_rtxfax-0.0.2_pre25 (02 Mar 2006)
+
+ 02 Mar 2006; Stefan Knoblich <stkn@gentoo.org>
+ +files/app_rtxfax-0.0.2_pre25-gentoo.diff,
+ +asterisk-app_rtxfax-0.0.2_pre25.ebuild:
+ Version bump.
*asterisk-app_rtxfax-0.0.2_pre20 (08 Sep 2005)
diff --git a/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre25.ebuild b/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre25.ebuild
new file mode 100644
index 000000000000..b597d0f01c27
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre25.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre25.ebuild,v 1.1 2006/03/02 00:24:07 stkn Exp $
+
+IUSE=""
+
+inherit eutils
+
+MY_PN="app_rtxfax"
+
+DESCRIPTION="Asterisk applications for sending and receiving faxes"
+HOMEPAGE="http://www.soft-switch.org/"
+#SRC_URI="mirror://gentoo/${P}.tar.bz2"
+SRC_URI="http://www.netdomination.org/pub/asterisk/${P}.tar.bz2"
+
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=media-libs/spandsp-0.0.2_pre20
+ >=net-misc/asterisk-1.0.5-r1"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # use asterisk-config...
+ epatch ${FILESDIR}/${MY_PN}-0.0.2_pre25-gentoo.diff
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc README
+}
diff --git a/net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre25-gentoo.diff b/net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre25-gentoo.diff
new file mode 100644
index 000000000000..6d681e334977
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre25-gentoo.diff
@@ -0,0 +1,78 @@
+--- /dev/null 1970-01-01 01:00:00.000000000 +0100
++++ Makefile 2005-09-05 23:59:22.000000000 +0200
+@@ -0,0 +1,27 @@
++.EXPORT_ALL_VARIABLES:
++
++CC=cc
++INSTALL=install
++AST_CFG=/usr/bin/asterisk-config
++
++AST_INCLUDE_DIR=/usr/include/asterisk
++AST_CONFIG_DIR=/etc/asterisk
++AST_MODULES_DIR=/usr/lib/asterisk/modules
++
++TARGETS:=app_rxfax.so app_txfax.so
++
++CFLAGS=$(shell $(AST_CFG) --cflags)
++SOLINK=$(shell $(AST_CFG) --solink)
++LIBS=-lspandsp -ltiff
++
++SUBDIR=$(shell [ -f $(AST_INCLUDE_DIR)/channel_pvt.h ] && echo "asterisk-1.0.x" || echo "asterisk-1.2.x")
++
++.PHONY: all install $(SUBDIR)
++
++all: $(SUBDIR)
++
++$(SUBDIR):
++ $(MAKE) -C $(SUBDIR) all
++
++install:
++ $(MAKE) -C $(SUBDIR) install
+--- /dev/null 1970-01-01 01:00:00.000000000 +0100
++++ asterisk-1.0.x/Makefile 2005-09-06 00:00:05.000000000 +0200
+@@ -0,0 +1,10 @@
++all: $(TARGETS)
++
++$(TARGETS): $(patsubst %.so,%.c,$(TARGETS))
++ $(CC) $(CFLAGS) $(SOLINK) -fPIC -o app_rxfax.so app_rxfax.c $(LIBS)
++ $(CC) $(CFLAGS) $(SOLINK) -fPIC -o app_txfax.so app_txfax.c $(LIBS)
++
++install:
++ for x in $(TARGETS); do \
++ $(INSTALL) -D -m 755 $$x $(DESTDIR)$(AST_MODULES_DIR)/$$x; \
++ done
+--- /dev/null 1970-01-01 01:00:00.000000000 +0100
++++ asterisk-1.2.x/Makefile 2005-09-06 00:00:37.000000000 +0200
+@@ -0,0 +1,10 @@
++all: $(TARGETS)
++
++$(TARGETS): $(patsubst %.so,%.c,$(TARGETS))
++ $(CC) $(CFLAGS) $(SOLINK) -fPIC -o app_rxfax.so app_rxfax.c $(LIBS)
++ $(CC) $(CFLAGS) $(SOLINK) -fPIC -o app_txfax.so app_txfax.c $(LIBS)
++
++install:
++ for x in $(TARGETS); do \
++ $(INSTALL) -D -m 755 $$x $(DESTDIR)$(AST_MODULES_DIR)/$$x; \
++ done
+--- asterisk-1.2.x/app_rxfax.c.orig 2006-01-15 16:45:53.000000000 +0100
++++ asterisk-1.2.x/app_rxfax.c 2006-01-15 16:49:56.000000000 +0100
+@@ -21,7 +21,7 @@
+
+ #include <spandsp.h>
+
+-#include "asterisk.h"
++#include "asterisk/asterisk.h"
+
+ ASTERISK_FILE_VERSION(__FILE__, "$Revision: 1.1 $")
+
+--- asterisk-1.2.x/app_txfax.c.orig 2006-01-15 16:45:59.000000000 +0100
++++ asterisk-1.2.x/app_txfax.c 2006-01-15 16:50:04.000000000 +0100
+@@ -21,7 +21,7 @@
+
+ #include <spandsp.h>
+
+-#include "asterisk.h"
++#include "asterisk/asterisk.h"
+
+ ASTERISK_FILE_VERSION(__FILE__, "$Revision: 1.1 $")
+
diff --git a/net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre25 b/net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre25
new file mode 100644
index 000000000000..f8f240b365bf
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre25
@@ -0,0 +1,3 @@
+MD5 20afc89b75ad6d8eabadbe5ae5464e5d asterisk-app_rtxfax-0.0.2_pre25.tar.bz2 6532
+RMD160 fa8934079372b525ff285d11ebf95498cb08878e asterisk-app_rtxfax-0.0.2_pre25.tar.bz2 6532
+SHA256 6307197cd45bec6caf4785918285a47c372fddd08cb94888512f100108404729 asterisk-app_rtxfax-0.0.2_pre25.tar.bz2 6532