summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-07-29 03:03:25 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-07-29 03:03:25 +0000
commit899a4e2b2fe91f720c61c95437b4ba4a6dad7e60 (patch)
treefcec16f2e064d07d0f51d19713499c22ee087bf1 /net-misc/asterisk-chan_sccp
parentDropped 0.26, 0.29 (diff)
downloadgentoo-2-899a4e2b2fe91f720c61c95437b4ba4a6dad7e60.tar.gz
gentoo-2-899a4e2b2fe91f720c61c95437b4ba4a6dad7e60.tar.bz2
gentoo-2-899a4e2b2fe91f720c61c95437b4ba4a6dad7e60.zip
Version bump of asterisk-sccp, renamed package to match asterisk plugin naming scheme in portage
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/asterisk-chan_sccp')
-rw-r--r--net-misc/asterisk-chan_sccp/ChangeLog11
-rw-r--r--net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20050725.ebuild54
-rw-r--r--net-misc/asterisk-chan_sccp/files/chan_sccp-20050725-gentoo.diff69
-rw-r--r--net-misc/asterisk-chan_sccp/files/digest-asterisk-chan_sccp-0.0.200507251
-rw-r--r--net-misc/asterisk-chan_sccp/metadata.xml8
5 files changed, 143 insertions, 0 deletions
diff --git a/net-misc/asterisk-chan_sccp/ChangeLog b/net-misc/asterisk-chan_sccp/ChangeLog
new file mode 100644
index 000000000000..6d590d694de4
--- /dev/null
+++ b/net-misc/asterisk-chan_sccp/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/asterisk-chan_sccp
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-chan_sccp/ChangeLog,v 1.1 2005/07/29 03:03:25 stkn Exp $
+
+*asterisk-chan_sccp-0.0.20050725 (29 Jul 2005)
+
+ 29 Jul 2005; <stkn@gentoo.org> +files/chan_sccp-20050725-gentoo.diff,
+ +metadata.xml, +asterisk-chan_sccp-0.0.20050725.ebuild:
+ Version bump of asterisk-sccp, renamed package to match asterisk plugin
+ naming scheme in portage.
+
diff --git a/net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20050725.ebuild b/net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20050725.ebuild
new file mode 100644
index 000000000000..62c63e371af9
--- /dev/null
+++ b/net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20050725.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-chan_sccp/asterisk-chan_sccp-0.0.20050725.ebuild,v 1.1 2005/07/29 03:03:25 stkn Exp $
+
+inherit eutils
+
+IUSE="debug"
+
+MY_P="chan_sccp-${PV/0.0./}"
+
+DESCRIPTION="SCCP channel plugin for the Asterisk soft PBX"
+HOMEPAGE="http://chan-sccp.berlios.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/chan-sccp/${MY_P}.tar.bz2"
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+DEPEND=">=net-misc/asterisk-1.0.5-r2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${MY_P}-gentoo.diff
+
+ if ! use debug; then
+ sed -i -e "s:^\(DEBUG=.*\):#\1:" Makefile
+ fi
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ emake INSTALL_PREFIX=${D} install || die
+
+ dodoc conf/* contrib/*
+
+ # fix permissions
+ if [[ -n "$(egetent group asterisk)" ]]; then
+ einfo "Fixing permissions..."
+ chown -R root:asterisk ${D}etc/asterisk
+ chmod -R u=rwX,g=rX,o= ${D}etc/asterisk
+ fi
+}
+
+pkg_postinst() {
+ ewarn "You have to disable asterisk's chan_skinny to use this module!"
+ einfo "Add \"noload => chan_skinny.so\" to ${ROOT}etc/asterisk/modules.conf"
+}
diff --git a/net-misc/asterisk-chan_sccp/files/chan_sccp-20050725-gentoo.diff b/net-misc/asterisk-chan_sccp/files/chan_sccp-20050725-gentoo.diff
new file mode 100644
index 000000000000..8676ff77c86f
--- /dev/null
+++ b/net-misc/asterisk-chan_sccp/files/chan_sccp-20050725-gentoo.diff
@@ -0,0 +1,69 @@
+--- chan_sccp-20050725/Makefile.orig 2005-07-29 04:55:59.000000000 +0000
++++ chan_sccp-20050725/Makefile 2005-07-29 04:56:21.000000000 +0000
+@@ -1,24 +1,16 @@
+ INSTALL_PREFIX=
+-ASTERISK_HEADER_DIR=$(INSTALL_PREFIX)/usr/include
++ASTERISK_HEADER_DIR=/usr/include
+
+ # Location asterisk modules install to
+-AST_MODULES_DIR=/usr/lib/asterisk/modules/
++AST_MODULES_DIR=/usr/lib/asterisk/modules
+
+ PROC=$(shell uname -m)
+
+ DEBUG=-ggdb
+
+-DEFINE=-Iinclude -I$(ASTERISK_SOURCE)/include -D_REENTRANT -D_GNU_SOURCE -O -DCRYPTO -fPIC -DASTERISK_VERSION_$(ASTERISK_VERSION)
++DEFINE=-Iinclude -D_REENTRANT -D_GNU_SOURCE -DCRYPTO -fPIC
+ CFLAG= -pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+-CFLAG+=$(shell if $(CC) -march=$(PROC) -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo " -march=$(PROC)"; fi)
+ CFLAG+=$(shell if uname -m | grep -q ppc; then echo " -fsigned-char"; fi)
+-#CFLAG+= -pedantic
+-#CFLAG+= -W
+-#CFLAG+= -Wpointer-arith
+-#CFLAG+= -Wcast-qual
+-#CFLAG+= -Wwrite-strings
+-#CFLAG+= -Wconversion
+-#CFLAG+= -Wredundant-decls # Useless as too many false positives from asterisk source
+ CFLAG+= -Wnested-externs
+ CFLAG+= -Wlong-long
+ CFLAG+= $(DEBUG)
+@@ -41,26 +33,31 @@
+ FLS+=sccp_socket
+ FLS+=sccp_indicate
+
+-CFLAGS+=$(DEFINE) $(CFLAG) -I$(ASTERISK_SOURCE)
++CFLAGS+=$(DEFINE) $(CFLAG)
+ HEADERS=$(shell for i in $(FLS) ; do echo $$i.h ; done)
+ OBJECTS=$(shell for i in $(FLS) ; do echo .tmp/$$i.o ; done)
+ SOURCES=$(shell for i in $(FLS) ; do echo $$i.c ; done)
+
++all: chan_sccp.so
++
+ chan_sccp.so: .config .tmp $(OBJECTS) $(HEADERS) $(SOURCES)
+ @echo "Linking chan_sccp.so"
+ @$(CC) -shared -Xlinker -x -o chan_sccp.so $(OBJECTS)
+
+ .tmp/%.o: $(HEADERS)
+ @printf "Now compiling .... %-15s\t%s lines \n" $*.c "`wc -l <$*.c`"
+- @$(CC) -I/usr/include/ $(CFLAGS) -I$(ASTERISK_SOURCE) $(DEFINE) -c $*.c -o .tmp/$*.o
++ @$(CC) $(CFLAGS) -c $*.c -o .tmp/$*.o
+
+-install: chan_sccp.so
++install:
+ @echo "Now Installing chan_sccp.so"
+- @install -m 755 chan_sccp.so $(AST_MODULES_DIR);
+- @if ! [ -f /etc/asterisk/sccp.conf ]; then \
+- echo "Installing config file /etc/asterisk/sccp.conf"; \
+- cp conf/sccp.conf /etc/asterisk/; \
++ @if ! [ -d $(INSTALL_PREFIX)$(AST_MODULES_DIR) ]; then \
++ mkdir -p -m775 $(INSTALL_PREFIX)$(AST_MODULES_DIR); \
++ fi
++ @install -m 755 chan_sccp.so $(INSTALL_PREFIX)$(AST_MODULES_DIR);
++ @if ! [ -d $(INSTALL_PREFIX)/etc/asterisk ]; then \
++ mkdir -p -m750 $(INSTALL_PREFIX)/etc/asterisk; \
+ fi
++ @install -m 640 conf/sccp.conf $(INSTALL_PREFIX)/etc/asterisk
+ @echo "Chan_sccp is now installed"
+ @echo "Remember to disable chan_skinny by adding the following"
+ @echo "line to /etc/asterisk/modules.conf:"
diff --git a/net-misc/asterisk-chan_sccp/files/digest-asterisk-chan_sccp-0.0.20050725 b/net-misc/asterisk-chan_sccp/files/digest-asterisk-chan_sccp-0.0.20050725
new file mode 100644
index 000000000000..142070fb2f06
--- /dev/null
+++ b/net-misc/asterisk-chan_sccp/files/digest-asterisk-chan_sccp-0.0.20050725
@@ -0,0 +1 @@
+MD5 96c2d6388bd5b6f9ed7488c667f4713b chan_sccp-20050725.tar.bz2 54381
diff --git a/net-misc/asterisk-chan_sccp/metadata.xml b/net-misc/asterisk-chan_sccp/metadata.xml
new file mode 100644
index 000000000000..a3cddc42f9cc
--- /dev/null
+++ b/net-misc/asterisk-chan_sccp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+</maintainer>
+</pkgmetadata>