summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-03-29 15:09:44 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-03-29 15:09:44 +0000
commita3706e076e276071365b44a83a7807d5d6d892c9 (patch)
treee83a11e98291c482a4a21f597ef6384b7d567f9d /net-misc/asterisk-chan_unistim
parentversion bump (diff)
downloadgentoo-2-a3706e076e276071365b44a83a7807d5d6d892c9.tar.gz
gentoo-2-a3706e076e276071365b44a83a7807d5d6d892c9.tar.bz2
gentoo-2-a3706e076e276071365b44a83a7807d5d6d892c9.zip
Initial import.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/asterisk-chan_unistim')
-rw-r--r--net-misc/asterisk-chan_unistim/ChangeLog10
-rw-r--r--net-misc/asterisk-chan_unistim/asterisk-chan_unistim-0.9.2.ebuild46
-rw-r--r--net-misc/asterisk-chan_unistim/files/chan_unistim-0.9.2-gentoo.diff33
-rw-r--r--net-misc/asterisk-chan_unistim/files/digest-asterisk-chan_unistim-0.9.21
-rw-r--r--net-misc/asterisk-chan_unistim/metadata.xml9
5 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/asterisk-chan_unistim/ChangeLog b/net-misc/asterisk-chan_unistim/ChangeLog
new file mode 100644
index 000000000000..de8828660e68
--- /dev/null
+++ b/net-misc/asterisk-chan_unistim/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/asterisk-chan_unistim
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-chan_unistim/ChangeLog,v 1.1 2005/03/29 15:09:44 stkn Exp $
+
+*asterisk-chan_unistim-0.9.2 (29 Mar 2005)
+
+ 29 Mar 2005; Stefan Knoblich <stkn@gentoo.org> +metadata.xml,
+ +files/chan_unistim-0.9.2-gentoo.diff, +asterisk-chan_unistim-0.9.2.ebuild:
+ Initial import.
+
diff --git a/net-misc/asterisk-chan_unistim/asterisk-chan_unistim-0.9.2.ebuild b/net-misc/asterisk-chan_unistim/asterisk-chan_unistim-0.9.2.ebuild
new file mode 100644
index 000000000000..c8f7babe32e4
--- /dev/null
+++ b/net-misc/asterisk-chan_unistim/asterisk-chan_unistim-0.9.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-chan_unistim/asterisk-chan_unistim-0.9.2.ebuild,v 1.1 2005/03/29 15:09:44 stkn Exp $
+
+inherit eutils
+
+MY_PN="chan_unistim"
+
+DESCRIPTION="Unistim channel module for Asterisk"
+HOMEPAGE="http://mlkj.net/UNISTIM/"
+SRC_URI="http://mlkj.net/asterisk/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=net-misc/asterisk-1.0.5-r1"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${MY_PN}-${PV}-gentoo.diff
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ make INSTALL_PREFIX=${D} install config || die "make install failed"
+
+ dodoc README unistim.conf
+}
+
+pkg_postinst() {
+ einfo "For more information about this module:"
+ einfo ""
+ einfo "http://www.voip-info.org/wiki-Asterisk+UNISTIM+channels"
+ einfo ""
+ einfo "http://www.voip-info.org/wiki-Nortel+Phones"
+}
diff --git a/net-misc/asterisk-chan_unistim/files/chan_unistim-0.9.2-gentoo.diff b/net-misc/asterisk-chan_unistim/files/chan_unistim-0.9.2-gentoo.diff
new file mode 100644
index 000000000000..662416f41067
--- /dev/null
+++ b/net-misc/asterisk-chan_unistim/files/chan_unistim-0.9.2-gentoo.diff
@@ -0,0 +1,33 @@
+--- chan_unistim-0.9.2/Makefile.orig 2005-03-29 14:56:16.634635584 +0000
++++ chan_unistim-0.9.2/Makefile 2005-03-29 15:02:37.375754136 +0000
+@@ -7,15 +7,14 @@
+ INSTALL_PREFIX=
+ ASTERISK_HEADER_DIR=$(INSTALL_PREFIX)/usr/include
+
+-MODULES_DIR=$(INSTALL_PREFIX)/usr/lib/asterisk/modules
++MODULES_DIR=$(INSTALL_PREFIX)$(shell /usr/bin/asterisk-config --modulesdir)
++ETC_DIR=$(INSTALL_PREFIX)$(shell /usr/bin/asterisk-config --sysconfdir)
+
+ PROC=$(shell uname -m)
+
+ DEBUG=-g #-pg
+ INCLUDE=-I$(ASTERISK_HEADER_DIR)
+-CFLAGS=-pipe -Wall -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE
+-CFLAGS+=-O6
+-CFLAGS+=$(shell if $(CC) -march=$(PROC) -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-march=$(PROC)"; fi)
++CFLAGS+=-pipe -fPIC -DPIC -Wall -Wmissing-prototypes -Wmissing-declarations $(DEBUG) $(INCLUDE) -D_REENTRANT -D_GNU_SOURCE
+ CFLAGS+=$(shell if uname -m | grep -q ppc; then echo "-fsigned-char"; fi)
+
+ LIBS=-ldl -lpthread -lm
+@@ -40,8 +39,10 @@
+ $(CC) -shared -Xlinker -x -o $@ chan_unistim.o
+
+ install: all
++ if [ ! -d $(MODULES_DIR) ]; then mkdir -m 755 -p $(MODULES_DIR) ; fi
+ for x in $(SHAREDOS); do $(INSTALL) -m 755 $$x $(MODULES_DIR) ; done
+
+ config: all
+- cp unistim.conf $(INSTALL_PREFIX)/etc/asterisk/
++ if [ ! -d $(ETC_DIR) ]; then mkdir -m 755 -p $(ETC_DIR) ; fi
++ cp unistim.conf $(ETC_DIR)
+
diff --git a/net-misc/asterisk-chan_unistim/files/digest-asterisk-chan_unistim-0.9.2 b/net-misc/asterisk-chan_unistim/files/digest-asterisk-chan_unistim-0.9.2
new file mode 100644
index 000000000000..88af2837c529
--- /dev/null
+++ b/net-misc/asterisk-chan_unistim/files/digest-asterisk-chan_unistim-0.9.2
@@ -0,0 +1 @@
+MD5 54a01ead2678c013ec2caa0b36a8045c chan_unistim-0.9.2.tar.bz2 25452
diff --git a/net-misc/asterisk-chan_unistim/metadata.xml b/net-misc/asterisk-chan_unistim/metadata.xml
new file mode 100644
index 000000000000..10f27dc5e06a
--- /dev/null
+++ b/net-misc/asterisk-chan_unistim/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+ <name>Stefan Knoblich</name>
+</maintainer>
+</pkgmetadata>