summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-08-20 23:12:51 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-08-20 23:12:51 +0000
commit995815f5fe8ad9be62afbca1c56d9d854885f5ad (patch)
treeac0c85a91f0b24556ebcadd28cfee9b6d1a5e413 /net-misc/asterisk-core-sounds
parentleave -g as it is (diff)
downloadgentoo-2-995815f5fe8ad9be62afbca1c56d9d854885f5ad.tar.gz
gentoo-2-995815f5fe8ad9be62afbca1c56d9d854885f5ad.tar.bz2
gentoo-2-995815f5fe8ad9be62afbca1c56d9d854885f5ad.zip
Initial commit, ebuild by Jaco Kroon. For bug #328513.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/asterisk-core-sounds')
-rw-r--r--net-misc/asterisk-core-sounds/ChangeLog10
-rw-r--r--net-misc/asterisk-core-sounds/asterisk-core-sounds-1.4.19.ebuild67
-rw-r--r--net-misc/asterisk-core-sounds/metadata.xml20
3 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/asterisk-core-sounds/ChangeLog b/net-misc/asterisk-core-sounds/ChangeLog
new file mode 100644
index 000000000000..52b626d10c68
--- /dev/null
+++ b/net-misc/asterisk-core-sounds/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/asterisk-core-sounds
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-core-sounds/ChangeLog,v 1.1 2010/08/20 23:12:51 chainsaw Exp $
+
+*asterisk-core-sounds-1.4.19 (20 Aug 2010)
+
+ 20 Aug 2010; <chainsaw@gentoo.org> +asterisk-core-sounds-1.4.19.ebuild,
+ +metadata.xml:
+ Initial commit, ebuild by Jaco Kroon. For bug #328513.
+
diff --git a/net-misc/asterisk-core-sounds/asterisk-core-sounds-1.4.19.ebuild b/net-misc/asterisk-core-sounds/asterisk-core-sounds-1.4.19.ebuild
new file mode 100644
index 000000000000..46bde511381d
--- /dev/null
+++ b/net-misc/asterisk-core-sounds/asterisk-core-sounds-1.4.19.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-core-sounds/asterisk-core-sounds-1.4.19.ebuild,v 1.1 2010/08/20 23:12:51 chainsaw Exp $
+
+EAPI="2"
+
+DESCRIPTION="Core sounds for asterisk"
+HOMEPAGE="http://www.asterisk.org/"
+LINGUAS="^en fr" # ^ is used to indicate to the loops below to NOT set this as an optional
+CODECS="alaw g722 g729 +gsm siren7 siren14 sln16 ulaw wav"
+
+SRC_URI=""
+IUSE="${CODECS}"
+for l in ${LINGUAS}; do
+ [[ "${l}" != ^* ]] && IUSE+=" linguas_${l}" && SRC_URI+=" linguas_${l}? ("
+ for c in ${CODECS}; do
+ SRC_URI+=" ${c#+}? ( http://downloads.asterisk.org/pub/telephony/sounds/releases/${PN}-${l#^}-${c#+}-${PV}.tar.gz )"
+ done
+ [[ "${l}" = ^* ]] || SRC_URI+=" )"
+done
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-misc/asterisk-1.6.2.11-r1"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local ar
+
+ for ar in ${A}; do
+ l="${ar#${PN}-}"
+ l=${l%%-*}
+ echo ">>> Unpacking $ar to ${WORKDIR}/${l}"
+ [ -d "${WORKDIR}/${l}" ] || mkdir "${WORKDIR}/${l}" || die "Error creating unpack directory"
+ tar xf "${DISTDIR}/${ar}" -C "${WORKDIR}/${l}" || die "Error unpacking ${ar}"
+ done
+}
+
+src_install() {
+ for l in ${LINGUAS}; do
+ if [[ "${l}" = ^* ]] || use linguas_${l}; then
+ l="${l#^}"
+ dodoc ${l}/CHANGES-${PN%-sounds}-${l}-${PV} ${l}/${PN#asterisk-}-${l}.txt
+ rm ${l}/CHANGES-${PN%-sounds}-${l}-${PV} ${l}/${PN#asterisk-}-${l}.txt
+ fi
+ done
+
+ diropts -m 0770 -o asterisk -g asterisk
+ insopts -m 0660 -o asterisk -g asterisk
+
+ dodir /var/lib/asterisk/sounds
+ insinto /var/lib/asterisk/sounds
+ doins -r .
+}
+
+pkg_postinst() {
+ local c has_once_codec=
+
+ for c in ${CODECS}; do
+ use ${c#+} && has_one_codec=1
+ done
+
+ [ -n "${has_one_codec}" ] || ewarn "You have none of the codec use flags (${CODECS}) set. You need to have at least one set in order for this package to be useful."
+}
diff --git a/net-misc/asterisk-core-sounds/metadata.xml b/net-misc/asterisk-core-sounds/metadata.xml
new file mode 100644
index 000000000000..639419ffc299
--- /dev/null
+++ b/net-misc/asterisk-core-sounds/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>voip</herd>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <use>
+ <flag name="alaw">Install the sounds files for the alaw codec.</flag>
+ <flag name="g722">Install the sounds files for the g722 codec.</flag>
+ <flag name="g729">Install the sounds files for the g729 codec.</flag>
+ <flag name="gsm">Install the sounds files for the +gsm codec.</flag>
+ <flag name="siren7">Install the sounds files for the siren7 codec.</flag>
+ <flag name="siren14">Install the sounds files for the siren14 codec.</flag>
+ <flag name="sln16">Install the sounds files for the sln16 codec.</flag>
+ <flag name="ulaw">Install the sounds files for the ulaw codec.</flag>
+ <flag name="wav">Install the sounds files for the wav codec.</flag>
+ </use>
+</pkgmetadata>