summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2014-02-10 11:34:11 +0000
committerTony Vroon <chainsaw@gentoo.org>2014-02-10 11:34:11 +0000
commit45a333a8382587501588428aa57c45652f5ddc7d (patch)
treebb64b2b816dccd9ce3d4ec326979aa8b747b5c61 /net-misc/astmanproxy
parentVersion bump on both 1.8 & 11 branches, as requested by Jaco Kroon in bug #50... (diff)
downloadgentoo-2-45a333a8382587501588428aa57c45652f5ddc7d.tar.gz
gentoo-2-45a333a8382587501588428aa57c45652f5ddc7d.tar.bz2
gentoo-2-45a333a8382587501588428aa57c45652f5ddc7d.zip
Peruse active fork by davies147 instead of official github (stalled in 2008) or patching snapshot (stalled in 2005). LDFLAGS respect instilled by Michael "iamnr3" Mair-Keimberger, closes bug #335326. Gave up on the makefile in order to install in parallel properly, fixes bug #298092 by Diego Elio Pettenò.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-misc/astmanproxy')
-rw-r--r--net-misc/astmanproxy/ChangeLog14
-rw-r--r--net-misc/astmanproxy/astmanproxy-1.28.2.ebuild49
-rw-r--r--net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff39
3 files changed, 100 insertions, 2 deletions
diff --git a/net-misc/astmanproxy/ChangeLog b/net-misc/astmanproxy/ChangeLog
index 0869bccebf97..c19e796e53a3 100644
--- a/net-misc/astmanproxy/ChangeLog
+++ b/net-misc/astmanproxy/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-misc/astmanproxy
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/astmanproxy/ChangeLog,v 1.9 2013/10/27 09:49:49 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/astmanproxy/ChangeLog,v 1.10 2014/02/10 11:34:11 chainsaw Exp $
+
+*astmanproxy-1.28.2 (10 Feb 2014)
+
+ 10 Feb 2014; Tony Vroon <chainsaw@gentoo.org> +astmanproxy-1.28.2.ebuild,
+ +files/astmanproxy-1.28.2-gentoo.diff:
+ Peruse active fork by davies147 instead of official github (stalled in 2008)
+ or patching snapshot (stalled in 2005). LDFLAGS respect instilled by Michael
+ "iamnr3" Mair-Keimberger, closes bug #335326. Gave up on the makefile in
+ order to install in parallel properly, fixes bug #298092 by Diego Elio
+ Pettenò.
27 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due voip herd removal:
diff --git a/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild b/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
new file mode 100644
index 000000000000..a859b8712509
--- /dev/null
+++ b/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild,v 1.1 2014/02/10 11:34:11 chainsaw Exp $
+
+EAPI=5
+inherit base multilib toolchain-funcs
+
+DESCRIPTION="Proxy for the Asterisk manager interface"
+HOMEPAGE="https://github.com/davies147/astmanproxy/"
+SRC_URI="https://github.com/davies147/${PN}/archive/${PV}.tar.gz"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=""
+PATCHES=( "${FILESDIR}/${P}-gentoo.diff" )
+
+src_prepare() {
+ base_src_prepare
+
+ # Fix multilib
+ sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" "${S}/Makefile" \
+ || die "multilib sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}" \
+ LD="$(tc-getLD)" \
+ RAWLDFLAGS="$(raw-ldflags)"
+}
+
+src_install() {
+ dosbin astmanproxy
+
+ dodoc README VERSIONS
+
+ docinto samples
+ dodoc samples/*
+
+ insinto /etc/asterisk
+ doins configs/astmanproxy.conf
+ doins configs/astmanproxy.users
+
+ newinitd "${FILESDIR}"/astmanproxy.rc6 astmanproxy
+}
diff --git a/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff b/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
new file mode 100644
index 000000000000..68534cd61086
--- /dev/null
+++ b/net-misc/astmanproxy/files/astmanproxy-1.28.2-gentoo.diff
@@ -0,0 +1,39 @@
+diff -uNr astmanproxy-1.28.2.ORIG/Makefile astmanproxy-1.28.2/Makefile
+--- astmanproxy-1.28.2.ORIG/Makefile 2014-02-10 11:18:06.027132570 +0000
++++ astmanproxy-1.28.2/Makefile 2014-02-10 11:21:07.382135291 +0000
+@@ -17,7 +17,7 @@
+
+ CC := gcc
+ INCLUDES :=
+-PREFIX:= /usr/local
++PREFIX:= /usr
+ BINDIR := $(DESTDIR)$(PREFIX)/sbin
+
+ # For compilation dependencies
+@@ -27,7 +27,7 @@
+ LIBS := -lssl
+
+ # Add -g below for debug/GDB symbols
+-CFLAGS:=-Wall -O2 -D_REENTRANT -D_GNU_SOURCE -fPIC -Isrc/include -I/usr/include/openssl
++CFLAGS += -Wall -O2 -D_REENTRANT -D_GNU_SOURCE -fPIC -Isrc/include -I/usr/include/openssl
+
+ ifeq (${OSARCH},Darwin)
+ LIBS+=-lresolv
+@@ -62,7 +62,7 @@
+ DEFINES+='-DMDIR="$(MODDIR)"' '-DPDIR="$(PERMDIR)"' '-DPFILE="$(PERMFILE)"'
+
+ PROXYCERT := $(CERTDIR)/proxy-server.pem
+-PROXYSSLCONF := $(CONFDIR)/proxy-ssl.conf
++PROXYSSLCONF := $(DESTDIR)$(CONFDIR)/proxy-ssl.conf
+
+ CFLAGS += $(DEFINES)
+
+@@ -76,7 +76,7 @@
+ SRCS := $(MODS:%=src/%.c)
+ HDRS := src/include/astmanproxy.h
+
+-all: astmanproxy cert
++all: astmanproxy
+
+ astmanproxy: $(OBJS) $(SOBJS)
+ $(CC) $(CFLAGS) -o $@ $(ASTLINK) $(OBJS) $(LIBS)