summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-05-30 20:30:14 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-05-30 20:30:14 +0000
commitc39ffe7e9b41c84e046d2be7656d00abefe28541 (patch)
tree2bba9c1fa4ac7d370ad70520157547ee8b418b0d /net-misc/autossh/autossh-1.2f.ebuild
parentwhitespace cleanup. (Manifest recommit) (diff)
downloadgentoo-2-c39ffe7e9b41c84e046d2be7656d00abefe28541.tar.gz
gentoo-2-c39ffe7e9b41c84e046d2be7656d00abefe28541.tar.bz2
gentoo-2-c39ffe7e9b41c84e046d2be7656d00abefe28541.zip
Closing #52351.
Diffstat (limited to 'net-misc/autossh/autossh-1.2f.ebuild')
-rw-r--r--net-misc/autossh/autossh-1.2f.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/autossh/autossh-1.2f.ebuild b/net-misc/autossh/autossh-1.2f.ebuild
new file mode 100644
index 000000000000..f9f0a1cb80e8
--- /dev/null
+++ b/net-misc/autossh/autossh-1.2f.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/autossh-1.2f.ebuild,v 1.1 2004/05/30 20:30:14 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Automatically restart SSH sessions and tunnels"
+HOMEPAGE="http://www.harding.motd.ca/autossh/"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~alpha ~ia64 amd64"
+SRC_URI="http://www.harding.motd.ca/autossh/${P}.tgz"
+SLOT="0"
+
+DEPEND="virtual/glibc sys-apps/sed"
+RDEPEND="virtual/glibc net-misc/openssh"
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+ sed -i "s|CFLAGS=|CFLAGS=${CFLAGS}|g" Makefile.linux
+}
+
+src_compile() {
+ emake -f Makefile.linux || die "make failed"
+}
+
+src_install() {
+ dobin autossh
+ dodoc CHANGES README autossh.host rscreen
+ doman autossh.1
+}
+