summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-03 18:18:40 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-03 18:18:40 +0000
commit631cff3cda4de7ce1ff57cb2c98ad01995134969 (patch)
tree1c37ba3df64843595844e52f0d75ed184cd437ba /net-misc/autossh
parentVersion bump. Bug #330375: CONFIG_SYSVIPC is required for udev sync code. (diff)
downloadgentoo-2-631cff3cda4de7ce1ff57cb2c98ad01995134969.tar.gz
gentoo-2-631cff3cda4de7ce1ff57cb2c98ad01995134969.tar.bz2
gentoo-2-631cff3cda4de7ce1ff57cb2c98ad01995134969.zip
Respect CC and LDFLAGS wrt bug 331103. Thanks to Olivier Huber <oli.huber@gmail.com> for patch.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/autossh')
-rw-r--r--net-misc/autossh/ChangeLog7
-rw-r--r--net-misc/autossh/autossh-1.2g.ebuild12
-rw-r--r--net-misc/autossh/autossh-1.4b.ebuild8
3 files changed, 21 insertions, 6 deletions
diff --git a/net-misc/autossh/ChangeLog b/net-misc/autossh/ChangeLog
index 7f1d4e1b4b2b..52e844071f42 100644
--- a/net-misc/autossh/ChangeLog
+++ b/net-misc/autossh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/autossh
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/ChangeLog,v 1.25 2010/01/07 15:45:55 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/ChangeLog,v 1.26 2010/08/03 18:18:40 xarthisius Exp $
+
+ 03 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org> autossh-1.2g.ebuild,
+ autossh-1.4b.ebuild:
+ Respect CC and LDFLAGS wrt bug 331103. Thanks to Olivier Huber
+ <oli.huber@gmail.com> for patch.
07 Jan 2010; Christian Faulhammer <fauli@gentoo.org> autossh-1.4b.ebuild:
Transfer Prefix keywords
diff --git a/net-misc/autossh/autossh-1.2g.ebuild b/net-misc/autossh/autossh-1.2g.ebuild
index ebdd789d79b6..3879927efcde 100644
--- a/net-misc/autossh/autossh-1.2g.ebuild
+++ b/net-misc/autossh/autossh-1.2g.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/autossh-1.2g.ebuild,v 1.5 2009/09/23 19:34:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/autossh-1.2g.ebuild,v 1.6 2010/08/03 18:18:40 xarthisius Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Automatically restart SSH sessions and tunnels"
HOMEPAGE="http://www.harding.motd.ca/autossh/"
@@ -14,11 +16,13 @@ DEPEND="sys-apps/sed"
RDEPEND="net-misc/openssh"
src_unpack() {
- unpack ${A} && cd ${S}
- sed -i "s|CFLAGS=|CFLAGS=${CFLAGS}|g" Makefile.linux
+ unpack ${A} && cd "${S}"
+ sed -i -e "s|CFLAGS=|CFLAGS=${CFLAGS}|g" \
+ -e "s:\$(CC):& \$(LDFLAGS):" Makefile.linux || die
}
src_compile() {
+ tc-export CC
emake -f Makefile.linux || die "make failed"
}
diff --git a/net-misc/autossh/autossh-1.4b.ebuild b/net-misc/autossh/autossh-1.4b.ebuild
index 6816fe938ebf..1a444c47400f 100644
--- a/net-misc/autossh/autossh-1.4b.ebuild
+++ b/net-misc/autossh/autossh-1.4b.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/autossh-1.4b.ebuild,v 1.2 2010/01/07 15:45:55 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/autossh-1.4b.ebuild,v 1.3 2010/08/03 18:18:40 xarthisius Exp $
+
+EAPI=2
DESCRIPTION="Automatically restart SSH sessions and tunnels"
HOMEPAGE="http://www.harding.motd.ca/autossh/"
@@ -13,6 +15,10 @@ IUSE=""
RDEPEND="net-misc/openssh"
+src_prepare() {
+ sed -i -e "s:\$(CC):& \$(LDFLAGS):" Makefile.in || die
+}
+
src_install() {
dobin autossh
dodoc CHANGES README autossh.host rscreen