summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-08-19 23:28:47 +0000
committerMichael Weber <xmw@gentoo.org>2012-08-19 23:28:47 +0000
commit6036914f51724a4f007d964d59f62ca1fe885149 (patch)
tree57f23cec98e95399a99cff973852159dd1337d4c /net-misc/batctl
parentVersion bump (bug 431994). (diff)
downloadgentoo-2-6036914f51724a4f007d964d59f62ca1fe885149.tar.gz
gentoo-2-6036914f51724a4f007d964d59f62ca1fe885149.tar.bz2
gentoo-2-6036914f51724a4f007d964d59f62ca1fe885149.zip
Version bump (bug 431996).
(Portage version: 2.1.11.10/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/batctl')
-rw-r--r--net-misc/batctl/ChangeLog8
-rw-r--r--net-misc/batctl/batctl-2012.3.0.ebuild36
2 files changed, 42 insertions, 2 deletions
diff --git a/net-misc/batctl/ChangeLog b/net-misc/batctl/ChangeLog
index 4e79f5628444..35f90e1f9474 100644
--- a/net-misc/batctl/ChangeLog
+++ b/net-misc/batctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/batctl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/ChangeLog,v 1.7 2012/06/13 22:24:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/ChangeLog,v 1.8 2012/08/19 23:28:47 xmw Exp $
+
+*batctl-2012.3.0 (19 Aug 2012)
+
+ 19 Aug 2012; Michael Weber <xmw@gentoo.org> +batctl-2012.3.0.ebuild:
+ Version bump (bug 431996).
*batctl-2012.2.0 (13 Jun 2012)
@@ -36,4 +41,3 @@
+metadata.xml:
Initial import, thanks to Emil Langrock for the report (bug 368213) and s3d
for the initial ebuild.
-
diff --git a/net-misc/batctl/batctl-2012.3.0.ebuild b/net-misc/batctl/batctl-2012.3.0.ebuild
new file mode 100644
index 000000000000..c826d38e2036
--- /dev/null
+++ b/net-misc/batctl/batctl-2012.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/batctl-2012.3.0.ebuild,v 1.1 2012/08/19 23:28:47 xmw Exp $
+
+EAPI=4
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="http://www.open-mesh.org/"
+SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ if ( linux_config_exists && linux_chkconfig_present BATMAN_ADV ) \
+ || ! has_version net-misc/batman-adv ; then
+ ewarn "You need the batman-adv kernel module,"
+ ewarn "either from the kernel tree or via net-misc/batman-adv"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 REVISION=gentoo-"${PVR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README
+}