summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-10-19 13:59:21 +0000
committerYixun Lan <dlan@gentoo.org>2014-10-19 13:59:21 +0000
commit31e49c2117a64399321dcdba4fb0f329d7d3bebc (patch)
treeff2c53e38ceb32f9a627f185556d6db03baa71e6 /net-misc/connman
parentStable on arm, ppc and ppc64. Bug #525842 (diff)
downloadgentoo-2-31e49c2117a64399321dcdba4fb0f329d7d3bebc.tar.gz
gentoo-2-31e49c2117a64399321dcdba4fb0f329d7d3bebc.tar.bz2
gentoo-2-31e49c2117a64399321dcdba4fb0f329d7d3bebc.zip
version bump, bug 525756
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/ChangeLog7
-rw-r--r--net-misc/connman/connman-1.26.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-misc/connman/ChangeLog b/net-misc/connman/ChangeLog
index 69625ad0dc0c..17ce96de69f9 100644
--- a/net-misc/connman/ChangeLog
+++ b/net-misc/connman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/connman
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.87 2014/09/23 09:52:09 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.88 2014/10/19 13:59:21 dlan Exp $
+
+*connman-1.26 (19 Oct 2014)
+
+ 19 Oct 2014; Yixun Lan <dlan@gentoo.org> +connman-1.26.ebuild:
+ version bump, bug 525756
*connman-1.25 (23 Sep 2014)
diff --git a/net-misc/connman/connman-1.26.ebuild b/net-misc/connman/connman-1.26.ebuild
new file mode 100644
index 000000000000..9dea002f232e
--- /dev/null
+++ b/net-misc/connman/connman-1.26.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.26.ebuild,v 1.1 2014/10/19 13:59:21 dlan Exp $
+
+EAPI="5"
+inherit base systemd
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet ofono openvpn openconnect policykit tools vpnc +wifi"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=net-firewall/iptables-1.4.8
+ net-libs/gnutls
+ bluetooth? ( net-wireless/bluez )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+PATCHES=( "${FILESDIR}/${PN}-1.16-execinfo-assumptions.patch" )
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable debug) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dobin client/connmanctl || die "client installation failed"
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit "${FILESDIR}"/connman.service
+}