summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-04-26 07:47:29 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-04-26 07:47:29 +0000
commit8edab3d05b5cb00c8b19cbc24304b5f8c32f89ab (patch)
tree7d565db7aeb71544d1c2957244a3d178c5469278 /net-misc/curl/curl-7.11.1.ebuild
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-8edab3d05b5cb00c8b19cbc24304b5f8c32f89ab.tar.gz
gentoo-2-8edab3d05b5cb00c8b19cbc24304b5f8c32f89ab.tar.bz2
gentoo-2-8edab3d05b5cb00c8b19cbc24304b5f8c32f89ab.zip
version bump (#48792)
Diffstat (limited to 'net-misc/curl/curl-7.11.1.ebuild')
-rw-r--r--net-misc/curl/curl-7.11.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/curl/curl-7.11.1.ebuild b/net-misc/curl/curl-7.11.1.ebuild
new file mode 100644
index 000000000000..6ec9b7a23f16
--- /dev/null
+++ b/net-misc/curl/curl-7.11.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.11.1.ebuild,v 1.1 2004/04/26 07:47:29 liquidx Exp $
+
+DESCRIPTION="A Client that groks URLs"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+HOMEPAGE="http://curl.haxx.se/"
+
+SLOT="0"
+LICENSE="MIT X11"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ppc64 ~mips"
+IUSE="ssl ipv6 ldap"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6a )
+ ldap? ( net-nds/openldap )"
+
+src_compile() {
+ local myconf="--with-gnu-ld --enable-http --enable-ftp --enable-gopher
+ --enable-file --enable-dict --enable-manual
+ --enable-telnet --enable-nonblocking --enable-largefile"
+
+ econf ${myconf} \
+ `use_enable ipv6` \
+ `use_enable ldap` \
+ `use_with ssl` || die
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc LEGAL CHANGES README
+ dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}