summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-12-13 19:53:22 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-12-13 19:53:22 +0000
commit6528b65587e63d60130787318937bc73de95cb28 (patch)
tree7197dfa0d953edb8ae9e151e204a7a0c864148ab /net-misc/curl
parentVersion bump; cleanup (diff)
downloadgentoo-2-6528b65587e63d60130787318937bc73de95cb28.tar.gz
gentoo-2-6528b65587e63d60130787318937bc73de95cb28.tar.bz2
gentoo-2-6528b65587e63d60130787318937bc73de95cb28.zip
overzealous pruning - depended on by pycurl - thanks MrBones
(Portage version: 2.0.53)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog6
-rw-r--r--net-misc/curl/Manifest4
-rw-r--r--net-misc/curl/curl-7.13.1.ebuild47
-rw-r--r--net-misc/curl/curl-7.13.2.ebuild94
-rw-r--r--net-misc/curl/files/digest-curl-7.13.11
-rw-r--r--net-misc/curl/files/digest-curl-7.13.22
6 files changed, 153 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 426390a9c2c5..3adfb87b93c1 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.60 2005/12/13 19:08:25 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.61 2005/12/13 19:53:22 dragonheart Exp $
+
+ 13 Dec 2005; Daniel Black <dragonheart@gentoo.org> +curl-7.13.1.ebuild,
+ +curl-7.13.2.ebuild:
+ overzealous pruning - depended on by pycurl - thanks MrBones
13 Dec 2005; Michael Hanselmann <hansmi@gentoo.org> curl-7.15.1.ebuild:
Stable on hppa, ppc. See bug #114710.
diff --git a/net-misc/curl/Manifest b/net-misc/curl/Manifest
index 15f2f13d8e22..21235a99d843 100644
--- a/net-misc/curl/Manifest
+++ b/net-misc/curl/Manifest
@@ -1,7 +1,11 @@
MD5 f89a2edae94aca75a1da139c7fc36089 ChangeLog 11966
+MD5 79b7fd0dcd4776ca1851d30a45275e78 curl-7.13.1.ebuild 1140
+MD5 c6b9b093ceb98fd1efbc9ca3700888ec curl-7.13.2.ebuild 2392
MD5 89d2021f8afb5ff760a8ff36d99a8c39 curl-7.15.0.ebuild 2484
MD5 d43b27f94f20e1b2e7630e04e6d9a116 curl-7.15.1.ebuild 2238
MD5 3f45a8aa13637f8147adfe79b8cd522b files/curl-7.15.0-versionnumber.patch 550
+MD5 159b437588320b2a3f726d3aa55890e5 files/digest-curl-7.13.1 65
+MD5 71c346cc704727e0bdaef7333521adeb files/digest-curl-7.13.2 130
MD5 7bcded56c13b85b72508c00b8d3d7e73 files/digest-curl-7.15.0 65
MD5 27ebd18a112cd03c0e1e3e3bf1e13ff5 files/digest-curl-7.15.1 65
MD5 8f906ffe0aa837e5e26fe03af3043461 metadata.xml 219
diff --git a/net-misc/curl/curl-7.13.1.ebuild b/net-misc/curl/curl-7.13.1.ebuild
new file mode 100644
index 000000000000..f9a5cb96b2ba
--- /dev/null
+++ b/net-misc/curl/curl-7.13.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.13.1.ebuild,v 1.16 2005/12/13 19:53:22 dragonheart Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit eutils
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 s390 sparc x86"
+IUSE="ssl ipv6 ldap"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6a )
+ ldap? ( net-nds/openldap )"
+
+src_compile() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_with ssl) \
+ --enable-http \
+ --enable-ftp \
+ --enable-gopher \
+ --enable-file \
+ --enable-dict \
+ --enable-manual \
+ --enable-telnet \
+ --enable-nonblocking \
+ --enable-largefile \
+ || die
+ emake || die
+}
+src_test() {
+ return
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-misc/curl/curl-7.13.2.ebuild b/net-misc/curl/curl-7.13.2.ebuild
new file mode 100644
index 000000000000..0b469163ec22
--- /dev/null
+++ b/net-misc/curl/curl-7.13.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.13.2.ebuild,v 1.12 2005/12/13 19:53:22 dragonheart Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit eutils
+
+# NOTE: To prevent breakages when upgrading, we compile all the prev
+# versions we know. We can't slot them because only the libraries
+# have versioning, all the binaries, manpages don't have versions.
+
+OLD_PV=7.11.2
+OLD_PV_LIB=libcurl.so.2
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${PN}-${OLD_PV}.tar.bz2
+http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc-macos ppc64 s390 sparc x86"
+IUSE="ssl ipv6 ldap ares"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6a )
+ ldap? ( net-nds/openldap )
+ x86? ( ares? ( net-dns/c-ares ) )"
+
+_curl_has_old_ver() {
+ if test -s ${ROOT}/usr/$(get_libdir)/${OLD_PV_LIB}; then
+ return 0 # /bin/true
+ else
+ return 1
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epunt_cxx
+}
+
+src_compile() {
+
+ myconf="$(use_enable ldap)
+ $(use_with ssl)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-nonblocking
+ --enable-largefile"
+
+ if use ipv6 && use ares; then
+ ewarn "c-ares support disabled because it is incompatible with ipv6."
+ ewarn "To enable ares support, emerge with USE='-ipv6'."
+ myconf="${myconf} $(use_enable ipv6)"
+ else
+ if use x86; then
+ myconf="${myconf} $(use_enable ipv6) $(use_enable ares)"
+ fi
+ fi
+
+ if _curl_has_old_ver; then
+ einfo "Detected old version of curl - installing compat libs"
+ cd ${WORKDIR}/${PN}-${OLD_PV}
+ econf ${myconf}
+ emake || die "make for old version failed"
+ fi
+
+ cd ${S}
+ econf ${myconf}
+ emake || die "install failed for current version"
+}
+
+src_install() {
+ if _curl_has_old_ver; then
+ cd ${WORKDIR}/${PN}-${OLD_PV}/lib
+ make DESTDIR=${D} install-libLTLIBRARIES || die "install failed for old version"
+ fi
+
+ cd ${S}
+ make DESTDIR="${D}" install || die "installed failed for current version"
+
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-misc/curl/files/digest-curl-7.13.1 b/net-misc/curl/files/digest-curl-7.13.1
new file mode 100644
index 000000000000..1ac48c652545
--- /dev/null
+++ b/net-misc/curl/files/digest-curl-7.13.1
@@ -0,0 +1 @@
+MD5 d673f68dbab2553acdbfb5435bd1cd48 curl-7.13.1.tar.bz2 1860688
diff --git a/net-misc/curl/files/digest-curl-7.13.2 b/net-misc/curl/files/digest-curl-7.13.2
new file mode 100644
index 000000000000..833fa116dd4b
--- /dev/null
+++ b/net-misc/curl/files/digest-curl-7.13.2
@@ -0,0 +1,2 @@
+MD5 542fbdafd2fb051477fa544770b566de curl-7.11.2.tar.bz2 1141204
+MD5 5916bb359223800afa234a1cf5145b78 curl-7.13.2.tar.bz2 1891406