summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-24 17:49:38 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-24 17:49:38 +0000
commit6aa0bd227ef284f47dee9fe334b6d3e36c44d12f (patch)
tree43326504608ffe6807013cb69e8643356e22ad7e /net-misc/curl
parentAdd new snapshot, support firefox as alternative dependency. Remove old. (diff)
downloadgentoo-2-6aa0bd227ef284f47dee9fe334b6d3e36c44d12f.tar.gz
gentoo-2-6aa0bd227ef284f47dee9fe334b6d3e36c44d12f.tar.bz2
gentoo-2-6aa0bd227ef284f47dee9fe334b6d3e36c44d12f.zip
Version bump, organize configure options
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog7
-rw-r--r--net-misc/curl/curl-7.25.0.ebuild138
2 files changed, 144 insertions, 1 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 38fe0d5dffd2..3d3c5379716d 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.206 2012/03/24 16:08:45 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.207 2012/03/24 17:49:38 blueness Exp $
+
+*curl-7.25.0 (24 Mar 2012)
+
+ 24 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +curl-7.25.0.ebuild:
+ Version bump, organize configure options
24 Mar 2012; Greg Kroah-Hartman <gregkh@gentoo.org> metadata.xml:
add me as co-maintainer
diff --git a/net-misc/curl/curl-7.25.0.ebuild b/net-misc/curl/curl-7.25.0.ebuild
new file mode 100644
index 000000000000..2409f8047be8
--- /dev/null
+++ b/net-misc/curl/curl-7.25.0.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.25.0.ebuild,v 1.1 2012/03/24 17:49:38 blueness Exp $
+
+EAPI="4"
+
+inherit autotools eutils prefix
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ares gnutls idn ipv6 kerberos ldap nss ssh ssl static-libs test threads"
+
+RDEPEND="ldap? ( net-nds/openldap )
+ gnutls? ( net-libs/gnutls dev-libs/libgcrypt app-misc/ca-certificates )
+ ssl? ( !gnutls? ( dev-libs/openssl ) )
+ nss? ( !gnutls? ( !ssl? ( dev-libs/nss app-misc/ca-certificates ) ) )
+ idn? ( net-dns/libidn )
+ ares? ( >=net-dns/c-ares-1.6 )
+ kerberos? ( virtual/krb5 )
+ ssh? ( net-libs/libssh2 )
+ sys-libs/zlib"
+
+# rtmpdump ( media-video/rtmpdump ) / --with-librtmp
+# fbopenssl (not in gentoo) --with-spnego
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ sys-apps/ed
+ dev-util/pkgconfig
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+
+# ares must be disabled for threads and both can be disabled
+# one can use wether gnutls or nss if ssl is enabled
+REQUIRED_USE="threads? ( !ares )
+ nss? ( !gnutls )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-7.19.7-test241.patch \
+ "${FILESDIR}"/${PN}-7.18.2-prefix.patch \
+ "${FILESDIR}"/${PN}-respect-cflags-3.patch
+ sed -i '/LD_LIBRARY_PATH=/d' configure.ac || die #382241
+
+ eprefixify curl-config.in
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+
+ if use gnutls; then
+ myconf+=( --without-ssl --with-gnutls --without-nss )
+ myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
+ elif use ssl; then
+ myconf+=( --with-ssl --without-gnutls --without-nss )
+ myconf+=( --without-ca-bundle --with-ca-path="${EPREFIX}"/etc/ssl/certs )
+ elif use nss; then
+ myconf+=( --without-ssl --without-gnutls --with-nss )
+ myconf+=( --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
+ else
+ myconf+=( --without-ssl --without-gnutls --without-nss )
+ fi
+
+ # These configuration options are organized alphabetically
+ # within each category. This should make it easier if we ever
+ # decide to make any of these contingent on USE flags.
+ # 1) protocols first. To see them all do
+ # 'grep SUPPORT_PROTOCOLS configure.ac'
+ # 2) --enable/disable options second.
+ # 'grep -- --enable configure | grep Check | awk '{ print $4 }' | sort
+ # 3) --with/without options third.
+ # grep -- --with configure | grep Check | awk '{ print $4 }' | sort
+ econf \
+ --enable-dict \
+ --enable-file \
+ --enable-ftp \
+ --enable-gopher \
+ --enable-http \
+ --enable-imap \
+ $(use_enable ldap) \
+ $(use_enable ldap ldaps) \
+ --enable-pop3 \
+ --without-librtmp \
+ --enable-rtsp \
+ $(use_with ssh libssh2) \
+ --enable-smtp \
+ --enable-telnet \
+ --enable-tftp \
+ $(use_enable ares) \
+ --enable-cookies \
+ --enable-hidden-symbols \
+ $(use_enable ipv6) \
+ --enable-largefile \
+ --enable-manual \
+ --enable-nonblocking \
+ --enable-proxy \
+ --enable-soname-bump \
+ --disable-sspi \
+ $(use_enable static-libs static) \
+ $(use_enable threads threaded-resolver) \
+ --enable-versioned-symbols \
+ $(use_with idn libidn) \
+ $(use_with kerberos gssapi "${EPREFIX}"/usr) \
+ --without-krb4 \
+ --without-spnego \
+ --with-zlib \
+ "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ ed - lib/curl_config.h < "${FILESDIR}"/config.h.ed || die
+ ed - src/curl_config.h < "${FILESDIR}"/config.h.ed || die
+ ed - include/curl/curlbuild.h < "${FILESDIR}"/curlbuild.h.ed || die
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+ rm -rf "${ED}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INTERNALS
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}