summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-07-28 11:40:09 +0000
committerRoy Marples <uberlord@gentoo.org>2005-07-28 11:40:09 +0000
commit813d5e59ed55f6cc280871c546972d64eb1b7152 (patch)
tree3c2d2fcdfed86af0f3012544e9ae3754a012e5dd /net-misc/dhcpcd/dhcpcd-2.0.0.ebuild
parentmask kde 3.4.2 ebuilds - a WIP (diff)
downloadgentoo-2-813d5e59ed55f6cc280871c546972d64eb1b7152.tar.gz
gentoo-2-813d5e59ed55f6cc280871c546972d64eb1b7152.tar.bz2
gentoo-2-813d5e59ed55f6cc280871c546972d64eb1b7152.zip
New upstream version.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/dhcpcd/dhcpcd-2.0.0.ebuild')
-rw-r--r--net-misc/dhcpcd/dhcpcd-2.0.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-2.0.0.ebuild b/net-misc/dhcpcd/dhcpcd-2.0.0.ebuild
new file mode 100644
index 000000000000..917e22372563
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-2.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-2.0.0.ebuild,v 1.1 2005/07/28 11:40:09 uberlord Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A DHCP client only"
+HOMEPAGE="http://developer.berlios.de/projects/dhcpcd/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="build debug static"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix compiling on gcc2
+ epatch "${FILESDIR}/${P}-gcc2.patch"
+
+ # Redefine the location of ntp.drift
+ sed -i 's:/etc/ntp\.drift:/var/lib/ntp/ntp.drift:' src/dhcpconfig.c
+}
+
+src_compile() {
+ local myconf="$( use_enable debug )"
+ use static && append-flags -static
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ into /
+ dosbin src/dhcpcd || die
+
+ if ! use build ; then
+ dodoc AUTHORS ChangeLog NEWS README
+ doman src/dhcpcd.8
+ fi
+}