summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-01-04 23:13:45 +0000
committerWilliam Hubbs <williamh@gentoo.org>2011-01-04 23:13:45 +0000
commit002ad4cc23161ceeb64fd6ef8a564a9264188f0e (patch)
treed29c398ae36e7c4a85b754ec22a1e6a0c9ad21ff /net-misc/dhcpcd
parentStable on amd64 wrt bug #350446 (diff)
downloadgentoo-2-002ad4cc23161ceeb64fd6ef8a564a9264188f0e.tar.gz
gentoo-2-002ad4cc23161ceeb64fd6ef8a564a9264188f0e.tar.bz2
gentoo-2-002ad4cc23161ceeb64fd6ef8a564a9264188f0e.zip
fix the libdir on non-multilib systems for bug #350511.
Thanks to Jory Pratt for the patch. (Portage version: 2.2.0_alpha12/cvs/Linux i686)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog8
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.2.10-r1.ebuild90
2 files changed, 97 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index c47624f2c791..06a7274b7cb7 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.297 2011/01/03 18:49:18 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.298 2011/01/04 23:13:45 williamh Exp $
+
+*dhcpcd-5.2.10-r1 (04 Jan 2011)
+
+ 04 Jan 2011; William Hubbs <williamh@gentoo.org> +dhcpcd-5.2.10-r1.ebuild:
+ fix the libdir on non-multilib systems for bug #350511.
+ Thanks to Jory Pratt for the patch.
03 Jan 2011; William Hubbs <williamh@gentoo.org> dhcpcd-4.0.15.ebuild,
dhcpcd-5.2.6.ebuild, dhcpcd-5.2.7.ebuild, dhcpcd-5.2.8.ebuild,
diff --git a/net-misc/dhcpcd/dhcpcd-5.2.10-r1.ebuild b/net-misc/dhcpcd/dhcpcd-5.2.10-r1.ebuild
new file mode 100644
index 000000000000..02f5abdf02ea
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-5.2.10-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.2.10-r1.ebuild,v 1.1 2011/01/04 23:13:45 williamh Exp $
+
+EAPI=1
+
+inherit eutils
+
+MY_P="${P/_alpha/-alpha}"
+MY_P="${MY_P/_beta/-beta}"
+MY_P="${MY_P/_rc/-rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+SLOT="0"
+IUSE="+zeroconf elibc_glibc"
+
+DEPEND=""
+RDEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use zeroconf; then
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "# dhcpcd ebuild requested no zeroconf"
+ echo "noipv4ll"
+ } >> dhcpcd.conf
+ fi
+}
+
+src_compile() {
+ local hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ econf --prefix= --libexecdir=/$(get_libdir)/dhcpcd --dbdir=/var/lib/dhcpcd \
+ --localstatedir=/var ${hooks}
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+
+ elog
+ elog "Users upgrading from 4.0 series should pay attention to removal"
+ elog "of compat useflag. This changes behavior of dhcp in wide manner:"
+ elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
+ elog "This is so we can re-use the address the kernel DHCP client found."
+ elog "To retain the old behaviour of sending a default ClientID based on the"
+ elog "hardware address for interface, simply add the keyword clientid"
+ elog "to dhcpcd.conf or use commandline parameter -I ''"
+ elog
+ elog "Also, users upgrading from 4.0 series should be aware that"
+ elog "the -N, -R and -Y command line options no longer exist."
+ elog "These are controled now by nohook options in dhcpcd.conf."
+}