summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-02-07 14:38:08 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-02-07 14:38:08 +0000
commit4e6f44b0b5e89519f1091b65e567c96590a4bcd8 (patch)
treee9238f96df0f9ebb72faa55476fc0143e85921c0 /net-misc/dhcpcd
parentgconf USE flag needs use_with, bug #255657. (diff)
downloadgentoo-2-4e6f44b0b5e89519f1091b65e567c96590a4bcd8.tar.gz
gentoo-2-4e6f44b0b5e89519f1091b65e567c96590a4bcd8.tar.bz2
gentoo-2-4e6f44b0b5e89519f1091b65e567c96590a4bcd8.zip
arm/ia64/s390/sh/sparc stable wrt #254812, remove old
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r2 ia64)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog8
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.0.ebuild86
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.1-r1.ebuild88
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.2.ebuild86
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.3.ebuild86
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.4.ebuild86
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.5.ebuild94
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.6.ebuild95
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.7.ebuild4
9 files changed, 9 insertions, 624 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 6ef3220e70cd..b4b394b13436 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.236 2009/02/04 09:37:47 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.237 2009/02/07 14:38:08 armin76 Exp $
+
+ 07 Feb 2009; Raúl Porcel <armin76@gentoo.org> -dhcpcd-4.0.0.ebuild,
+ -dhcpcd-4.0.1-r1.ebuild, -dhcpcd-4.0.2.ebuild, -dhcpcd-4.0.3.ebuild,
+ -dhcpcd-4.0.4.ebuild, -dhcpcd-4.0.5.ebuild, -dhcpcd-4.0.6.ebuild,
+ dhcpcd-4.0.7.ebuild:
+ arm/ia64/s390/sh/sparc stable wrt #254812, remove old
*dhcpcd-4.0.10 (04 Feb 2009)
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.0.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.0.ebuild
deleted file mode 100644
index d0498005cde4..000000000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.0.ebuild,v 1.2 2009/01/08 01:39:08 darkside Exp $
-
-EAPI=1
-
-inherit toolchain-funcs
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/dhcpcd"
-SRC_URI="http://roy.marples.name/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.1-r1.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.1-r1.ebuild
deleted file mode 100644
index 27e2b8973e63..000000000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.1-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.1-r1.ebuild,v 1.8 2009/01/08 01:39:08 darkside Exp $
-
-EAPI=1
-
-inherit toolchain-funcs eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-
- epatch "${FILESDIR}"/${PN}-4.0.1-no-empty-clientid.patch
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.2.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.2.ebuild
deleted file mode 100644
index 178225f046d2..000000000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.2.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.2.ebuild,v 1.10 2009/01/08 01:39:08 darkside Exp $
-
-EAPI=1
-
-inherit toolchain-funcs eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.3.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.3.ebuild
deleted file mode 100644
index baf6a4749204..000000000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.3.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.3.ebuild,v 1.2 2009/01/08 01:39:08 darkside Exp $
-
-EAPI=1
-
-inherit toolchain-funcs eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.4.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.4.ebuild
deleted file mode 100644
index 2542ed91b12b..000000000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.4.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.4.ebuild,v 1.2 2009/01/08 01:39:08 darkside Exp $
-
-EAPI=1
-
-inherit toolchain-funcs eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.5.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.5.ebuild
deleted file mode 100644
index 8f7173ac0d41..000000000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.5.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.5.ebuild,v 1.2 2009/01/08 01:39:08 darkside Exp $
-
-EAPI=1
-
-inherit toolchain-funcs eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
- if ! use compat; then
- elog
- elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
- elog "This is so we can re-use the address the kernel DHCP client found."
- elog "To retain the old behaviour of sending a default ClientID based on the"
- elog "hardware address for interface, simply add the keyword clientid"
- elog "to dhcpcd.conf or use commandline parameter -I ''"
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.6.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.6.ebuild
deleted file mode 100644
index 084d723546af..000000000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.6.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.6.ebuild,v 1.3 2009/01/08 01:39:08 darkside Exp $
-
-EAPI=1
-
-inherit toolchain-funcs eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- use compat && hooks="${hooks} 50-dhcpcd-compat"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
- if ! use compat; then
- elog
- elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
- elog "This is so we can re-use the address the kernel DHCP client found."
- elog "To retain the old behaviour of sending a default ClientID based on the"
- elog "hardware address for interface, simply add the keyword clientid"
- elog "to dhcpcd.conf or use commandline parameter -I ''"
- fi
-}
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.7.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.7.ebuild
index 3ec0dc3d5816..dca2edae3214 100644
--- a/net-misc/dhcpcd/dhcpcd-4.0.7.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-4.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.7.ebuild,v 1.8 2009/01/18 16:32:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.7.ebuild,v 1.9 2009/02/07 14:38:08 armin76 Exp $
EAPI=1
@@ -16,7 +16,7 @@ HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
LICENSE="BSD-2"
-KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc ~sparc-fbsd x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
SLOT="0"
IUSE="+compat zeroconf"