summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-10 00:24:19 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-10 00:24:19 +0000
commit4c959da96aac3e57e97c7cb75d0b20feb3dc8c44 (patch)
tree9909fcd34ebcb6dd1cf77f528625844f59f122f4 /net-misc/dropbear
parentAdd first version of patchset for perl 5.18.2 (diff)
downloadgentoo-2-4c959da96aac3e57e97c7cb75d0b20feb3dc8c44.tar.gz
gentoo-2-4c959da96aac3e57e97c7cb75d0b20feb3dc8c44.tar.bz2
gentoo-2-4c959da96aac3e57e97c7cb75d0b20feb3dc8c44.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-misc/dropbear')
-rw-r--r--net-misc/dropbear/ChangeLog9
-rw-r--r--net-misc/dropbear/dropbear-2014.63.ebuild101
2 files changed, 108 insertions, 2 deletions
diff --git a/net-misc/dropbear/ChangeLog b/net-misc/dropbear/ChangeLog
index d615a9259928..51b20e897a9d 100644
--- a/net-misc/dropbear/ChangeLog
+++ b/net-misc/dropbear/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dropbear
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dropbear/ChangeLog,v 1.116 2013/12/31 04:08:14 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dropbear/ChangeLog,v 1.117 2014/03/10 00:24:19 vapier Exp $
+
+*dropbear-2014.63 (10 Mar 2014)
+
+ 10 Mar 2014; Mike Frysinger <vapier@gentoo.org> +dropbear-2014.63.ebuild:
+ Version bump.
31 Dec 2013; Tim Harder <radhermit@gentoo.org> -dropbear-2012.55.ebuild,
-dropbear-2013.56.ebuild, -dropbear-2013.57.ebuild, -dropbear-2013.58.ebuild,
diff --git a/net-misc/dropbear/dropbear-2014.63.ebuild b/net-misc/dropbear/dropbear-2014.63.ebuild
new file mode 100644
index 000000000000..e66d562067cc
--- /dev/null
+++ b/net-misc/dropbear/dropbear-2014.63.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dropbear/dropbear-2014.63.ebuild,v 1.1 2014/03/10 00:24:19 vapier Exp $
+
+EAPI="4"
+
+inherit eutils savedconfig pam user
+
+DESCRIPTION="small SSH 2 client/server designed for small memory environments"
+HOMEPAGE="http://matt.ucc.asn.au/dropbear/dropbear.html"
+SRC_URI="http://matt.ucc.asn.au/dropbear/releases/${P}.tar.bz2
+ http://matt.ucc.asn.au/dropbear/testing/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bsdpty minimal multicall pam +shadow static syslog zlib"
+
+LIB_DEPEND="zlib? ( sys-libs/zlib[static-libs(+)] )
+ dev-libs/libtommath[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+RDEPEND+=" pam? ( >=sys-auth/pambase-20080219.1 )"
+
+REQUIRED_USE="pam? ( !static )"
+
+set_options() {
+ progs=(
+ dropbear dbclient dropbearkey
+ $(usex minimal "" "dropbearconvert scp")
+ )
+ makeopts=(
+ MULTI=$(usex multicall 1 0)
+ STATIC=$(usex static 1 0)
+ )
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.46-dbscp.patch
+# sed -i '1i#define _GNU_SOURCE' scpmisc.c || die
+ sed -i \
+ -e '/SFTPSERVER_PATH/s:".*":"/usr/lib/misc/sftp-server":' \
+ -e '/XAUTH_COMMAND/s:/X11R6/:/:' \
+ options.h || die
+ sed -i \
+ -e '/pam_start/s:sshd:dropbear:' \
+ svr-authpam.c || die
+ restore_config options.h
+}
+
+src_configure() {
+ # XXX: Need to add libtomcrypt to the tree and re-enable this.
+ # --disable-bundled-libtom
+ econf \
+ $(use_enable zlib) \
+ $(use_enable pam) \
+ $(use_enable !bsdpty openpty) \
+ $(use_enable shadow) \
+ $(use_enable syslog)
+}
+
+src_compile() {
+ set_options
+ emake "${makeopts[@]}" PROGRAMS="${progs[*]}"
+}
+
+src_install() {
+ set_options
+ emake "${makeopts[@]}" PROGRAMS="${progs[*]}" DESTDIR="${D}" install
+ doman *.8
+ newinitd "${FILESDIR}"/dropbear.init.d dropbear
+ newconfd "${FILESDIR}"/dropbear.conf.d dropbear
+ dodoc CHANGES README TODO SMALL MULTI
+
+ # The multi install target does not install the links right.
+ if use multicall ; then
+ cd "${ED}"/usr/bin
+ local x
+ for x in "${progs[@]}" ; do
+ ln -sf dropbearmulti ${x} || die "ln -s dropbearmulti to ${x} failed"
+ done
+ rm -f dropbear
+ dodir /usr/sbin
+ dosym ../bin/dropbearmulti /usr/sbin/dropbear
+ cd "${S}"
+ fi
+ save_config options.h
+
+ if ! use minimal ; then
+ mv "${ED}"/usr/bin/{,db}scp || die
+ fi
+
+ pamd_mimic system-remote-login dropbear auth account password session
+}
+
+pkg_preinst() {
+ enewgroup sshd 22
+ enewuser sshd 22 -1 /var/empty sshd
+}