summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-06-03 20:59:43 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-06-03 20:59:43 +0000
commit26f22ea5b19eee5c12017c4a567fa4c96ac3735c (patch)
treedc94fd7d12b6f1d2cd18ce788a84e49025b23414 /net-misc/freenet6
parentQA, various fixes from trailing whitespaces to invalid metadata.xml (diff)
downloadgentoo-2-26f22ea5b19eee5c12017c4a567fa4c96ac3735c.tar.gz
gentoo-2-26f22ea5b19eee5c12017c4a567fa4c96ac3735c.tar.bz2
gentoo-2-26f22ea5b19eee5c12017c4a567fa4c96ac3735c.zip
Remove old version
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-misc/freenet6')
-rw-r--r--net-misc/freenet6/ChangeLog6
-rw-r--r--net-misc/freenet6/files/digest-freenet6-1.0.03
-rw-r--r--net-misc/freenet6/files/gentoo.sh166
-rw-r--r--net-misc/freenet6/files/tspc.conf53
-rw-r--r--net-misc/freenet6/files/tspc.rc15
-rw-r--r--net-misc/freenet6/freenet6-1.0.0.ebuild50
6 files changed, 5 insertions, 288 deletions
diff --git a/net-misc/freenet6/ChangeLog b/net-misc/freenet6/ChangeLog
index 555fd672f6aa..56554f7987cb 100644
--- a/net-misc/freenet6/ChangeLog
+++ b/net-misc/freenet6/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/freenet6
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/ChangeLog,v 1.23 2007/06/02 23:01:05 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/ChangeLog,v 1.24 2007/06/03 20:59:43 voyageur Exp $
+
+ 03 Jun 2007; Bernard Cafarelli <voyageur@gentoo.org> -files/gentoo.sh,
+ -files/tspc.conf, -files/tspc.rc, -freenet6-1.0.0.ebuild:
+ Remove old version
02 Jun 2007; Markus Ullmann <jokey@gentoo.org> freenet6-4.2.2.ebuild:
Stable on x86 wrt bug #180450
diff --git a/net-misc/freenet6/files/digest-freenet6-1.0.0 b/net-misc/freenet6/files/digest-freenet6-1.0.0
deleted file mode 100644
index ac5d872da253..000000000000
--- a/net-misc/freenet6/files/digest-freenet6-1.0.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a2b4edb1d52b874587533b4cf40de1ba freenet6-1.0.0.tgz 330953
-RMD160 28c7cceaaea5ffe4b740d09f7dbd4aed5abac69d freenet6-1.0.0.tgz 330953
-SHA256 0d834b55538eff2abc569aa5c7831f24525bea56354727d0f6d5933d0e5f1116 freenet6-1.0.0.tgz 330953
diff --git a/net-misc/freenet6/files/gentoo.sh b/net-misc/freenet6/files/gentoo.sh
deleted file mode 100644
index 3a8b2f2518d1..000000000000
--- a/net-misc/freenet6/files/gentoo.sh
+++ /dev/null
@@ -1,166 +0,0 @@
-#!/bin/sh
-
-LANGUAGE=C
-
-if [ -z $TSP_VERBOSE ]; then
- TSP_VERBOSE=0
-fi
-
-KillProcess()
-{
- if [ ! -z $TSP_VERBOSE ]; then
- if [ $TSP_VERBOSE -ge 2 ]; then
- echo killing $*
- fi
- fi
- PID=`ps axww | grep $1 | grep -v grep | awk '{ print $1;}'`
- echo $PID
- if [ ! -z $PID ]; then
- kill $PID
- fi
-}
-
-Display()
-{
- if [ -z $TSP_VERBOSE ]; then
- return;
- fi
- if [ $TSP_VERBOSE -lt $1 ]; then
- return;
- fi
- shift
- echo "$*"
-}
-
-Exec()
-{
- if [ ! -z $TSP_VERBOSE ]; then
- if [ $TSP_VERBOSE -ge 2 ]; then
- echo $*
- fi
- fi
- $* # Execute command
- if [ $? -ne 0 ]; then
- echo "Error while executing $1"
- echo " Command: $*"
- exit 1
- fi
-}
-
-ExecNoCheck()
-{
- if [ ! -z $TSP_VERBOSE ]; then
- if [ $TSP_VERBOSE -ge 2 ]; then
- echo $*
- fi
- fi
- $* # Execute command
-}
-
-# Program localization
-
-Display 1 "--- Start of configuration script. ---"
-Display 1 "Script: " `basename $0`
-
-ifconfig=/sbin/ifconfig
-route=/sbin/route
-ipconfig=/sbin/ip
-rtadvd=/usr/sbin/radvd
-sysctl=/sbin/sysctl
-rtadvdconfigfilename=radvd.conf
-rtadvdconfigfile=/etc/radvd/$rtadvdconfigfilename
-
-if [ -z $TSP_HOME_DIR ]; then
- echo "TSP_HOME_DIR variable not specified!;"
- exit 1
-fi
-
-if [ ! -d $TSP_HOME_DIR ]; then
- echo "Error : directory $TSP_HOME_DIR does not exist"
- exit 1
-fi
-#
-
-if [ -z $TSP_HOST_TYPE ]; then
- echo Error: TSP_HOST_TYPE not defined.
- exit 1
-fi
-
-#change to upper case
-TSP_HOST_TYPE=`echo $TSP_HOST_TYPE | tr a-z A-Z`
-
-if [ X"${TSP_HOST_TYPE}" = X"HOST" ] || [ X"${TSP_HOST_TYPE}" = X"ROUTER" ]; then
- #
- # Configured tunnel config (IPv6)
-
- Display 1 "$TSP_TUNNEL_INTERFACE setup"
- Display 1 "Setting up link to $TSP_SERVER_ADDRESS_IPV4"
- if [ -x $ipconfig ]; then
- Exec $ipconfig tunnel add $TSP_TUNNEL_INTERFACE mode sit ttl 64 remote $TSP_SERVER_ADDRESS_IPV4
- else
- Exec $ifconfig $TSP_TUNNEL_INTERFACE tunnel ::$TSP_SERVER_ADDRESS_IPV4
- fi
-
- Exec $ifconfig $TSP_TUNNEL_INTERFACE up
-
- PREF=`echo $TSP_CLIENT_ADDRESS_IPV6 | sed "s/:0*/:/g" |cut -d : -f1-2`
- OLDADDR=`$ifconfig $TSP_TUNNEL_INTERFACE | grep "inet6.* $PREF" | sed -e "s/^.*inet6 addr: //" -e "s/ Scope.*\$//"`
- if [ ! -z $OLDADDR ]; then
- Display 1 "Removing old IPv6 address $OLDADDR"
- Exec $ifconfig $TSP_TUNNEL_INTERFACE inet6 del $OLDADDR
- fi
- Display 1 "This host is: $TSP_CLIENT_ADDRESS_IPV6/$TSP_TUNNEL_PREFIXLEN"
- Exec $ifconfig $TSP_TUNNEL_INTERFACE add $TSP_CLIENT_ADDRESS_IPV6/$TSP_TUNNEL_PREFIXLEN
-
- #
- # Default route
- Display 1 "Adding default route"
- ExecNoCheck $route -A inet6 del ::/0 2>/dev/null # delete old default route
- Exec $route -A inet6 add ::/0 dev $TSP_TUNNEL_INTERFACE
- Exec $route -A inet6 add 2000::/3 dev $TSP_TUNNEL_INTERFACE
-fi
-
-# Router configuration if required
-if [ X"${TSP_HOST_TYPE}" = X"ROUTER" ]; then
- Display 1 "Router configuration"
- Display 1 "Kernel setup"
- #Better way on linux to avoid loop with the remaining /48?
- $route -A inet6 add $TSP_PREFIX::/$TSP_PREFIXLEN dev $TSP_HOME_INTERFACE 2>/dev/null
- Exec $sysctl -w net.ipv6.conf.all.forwarding=1 # ipv6_forwarding enabled
- Display 1 "Adding prefix to $TSP_HOME_INTERFACE"
- OLDADDR=`$ifconfig $TSP_HOME_INTERFACE | grep "inet6.* $PREF" | sed -e "s/^.*inet6 addr: //" -e "s/ Scope.*\$//"`
- if [ ! -z $OLDADDR ]; then
- Display 1 "Removing old IPv6 address $OLDADDR"
- Exec $ifconfig $TSP_HOME_INTERFACE inet6 del $OLDADDR
- fi
- Exec $ifconfig $TSP_HOME_INTERFACE add $TSP_PREFIX:1::1/64
- # Router advertisement configuration
- Display 1 "Create new $rtadvdconfigfile"
- echo "##### radvd.conf made by TSP ####" > "$rtadvdconfigfile"
- echo "interface $TSP_HOME_INTERFACE" >> "$rtadvdconfigfile"
- echo "{" >> "$rtadvdconfigfile"
- echo " AdvSendAdvert on;" >> "$rtadvdconfigfile"
- echo " prefix $TSP_PREFIX:0001::/64" >> "$rtadvdconfigfile"
- echo " {" >> "$rtadvdconfigfile"
- echo " AdvOnLink on;" >> "$rtadvdconfigfile"
- echo " AdvAutonomous on;" >> "$rtadvdconfigfile"
- echo " AdvRouterAddr on;" >> "$rtadvdconfigfile"
- echo " };" >> "$rtadvdconfigfile"
- echo "};" >> "$rtadvdconfigfile"
- echo "" >> "$rtadvdconfigfile"
- if [ -f /var/run/radvd/radvd.pid ]; then
- /etc/init.d/radvd stop
- fi
- if [ -f $rtadvdconfigfile ]; then
- /etc/init.d/radvd start
- else
- echo "Error : file $rtadvdconfigfile not found"
- exit 1
- fi
-fi
-
-Display 1 "--- End of configuration script. ---"
-
-exit 0
-
-#---------------------------------------------------------------------
diff --git a/net-misc/freenet6/files/tspc.conf b/net-misc/freenet6/files/tspc.conf
deleted file mode 100644
index 13df8e013b3d..000000000000
--- a/net-misc/freenet6/files/tspc.conf
+++ /dev/null
@@ -1,53 +0,0 @@
-#-----------------------------------------------------------------------------
-# tspc.conf
-#-----------------------------------------------------------------------------
-
-#
-# tsp client version
-#
-tsp_version=1.0.1
-tsp_dir=/etc/freenet6
-
-#
-# auth_method=any|supported mechanism
-# if any is specified, the first mechanism that is supported by both the
-# server and the client will be picked. The order of precedence is the
-# mechnism list shown by the output of -h. supprted mechanism is one of
-# the token shown by th output of -h (case sensitive).
-auth_method=any
-
-#
-# client_v4=auto|1.1.1.1 (valid ip address)
-# if auto is specified, if_source or -s cmd line option must be specified.
-client_v4=auto
-
-# userid=anonymous
-# the userid can be anonymous or any alphanumeric value that is dns legal.
-userid=anonymous
-
-# passwd=
-# The passwd must be empty if userid is anonymous or an alphanumeric string
-# if userid is not anonymous.
-passwd=
-
-# template=target
-# template tells which configuration script needs to be run for interface
-# setup.
-# Normally you only need to put your osname in the value.
-# You can also use "checktunnel" if you only want the tunnel info print out.
-#template=checktunnel
-template=linux
-
-# server=FQDN
-# Freenet6 server address
-server=tsps1.freenet6.net
-
-# retry_delay=time
-# retry tells the client to retry connection after time (seconds) in case of
-# failure (0 = no retry)
-retry_delay=0
-
-if_tunnel=sit1
-
-# end of tspc.conf
-#-----------------------------------------------------------------------------
diff --git a/net-misc/freenet6/files/tspc.rc b/net-misc/freenet6/files/tspc.rc
deleted file mode 100644
index 4e6f8698d781..000000000000
--- a/net-misc/freenet6/files/tspc.rc
+++ /dev/null
@@ -1,15 +0,0 @@
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting Freenet6 IPv6 Client"
- tspc
- eend $?
-}
-
-stop() {
- ebegin "Stopping Freenet6 IPv6 Client"
- kill `pidof tspc`
- eend $?
-}
diff --git a/net-misc/freenet6/freenet6-1.0.0.ebuild b/net-misc/freenet6/freenet6-1.0.0.ebuild
deleted file mode 100644
index 3774468e8e0a..000000000000
--- a/net-misc/freenet6/freenet6-1.0.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/freenet6-1.0.0.ebuild,v 1.13 2007/04/28 16:53:02 swegener Exp $
-
-DESCRIPTION="Client to configure an IPv6 tunnel to freenet6"
-HOMEPAGE="http://www.freenet6.net/"
-SRC_URI="mirror://gentoo/${P}.tgz"
-
-LICENSE="VPL-1.0"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa"
-DEPEND=""
-S=${WORKDIR}/freenet6-client-1.0
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- mv -f src/Makefile ${T}
- sed "s:gcc -g -I\$(INC) -Wall:${CC} -I\$(INC) ${CFLAGS}:" \
- ${T}/Makefile > src/Makefile
-}
-
-src_compile() {
- emake all target=linux || die "Build Failed"
-}
-
-src_install() {
- dosbin bin/tspc
-
- insopts -m 600
- insinto /etc/freenet6
- doins ${FILESDIR}/tspc.conf
- exeinto /etc/freenet6/template
- doexe template/{linux,checktunnel}.sh
- doexe ${FILESDIR}/gentoo.sh
-
- dodoc CONTRIB.txt LEGAL README
- doman man/{man5/tspc.conf.5,man8/tspc.8}
-
- newinitd ${FILESDIR}/tspc.rc tspc
-}
-
-pkg_postinst() {
- einfo "The freenet6 ebuild installs an init script named 'tspc'"
- einfo "to coincide with the name of the client binary installed"
- einfo "To add support for a freenet6 connection at startup, do"
- einfo ""
- einfo "# rc-update add tspc default"
-}